swiss and wii - burning iso

All your console related questions and answers :)
Post Reply
User avatar
mat8888
Posts: 65
Joined: Fri May 24, 2013 11:03 pm
Location: northeast USA

swiss and wii - burning iso

Post by mat8888 » Tue Sep 17, 2013 9:17 pm

So can I just burn a regular swiss .iso to a full sized dvd blank for my wii? Or do I have to do something first to the iso?

I use a homebrew app (forget name) that boots backup GameCube discs.
Thanks
User avatar
emu_kidid
Site Admin
Posts: 4645
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: swiss and wii - burning iso

Post by emu_kidid » Tue Sep 17, 2013 10:19 pm

It might work, since you're using some homebrew app it really depends on what that homebrew app does. I know if you've got a proper drive modchip that can boot GameCube backups then it should be fine.
Image
User avatar
Apache Thunder
Posts: 92
Joined: Wed Aug 28, 2013 5:12 am

Re: swiss and wii - burning iso

Post by Apache Thunder » Thu Sep 26, 2013 4:17 am

I have no idea if DIOS-MIOS supports loading those "El Torito Specification" format homebrew ISOs. The ones I've seen have a "catalog" file and the lone DOL file. At least the Swiss ISO is set up like this. It's not structured at all like a retail GCM iso, so I don't know if a softmodded Wii will boot one correctly.

However on a related note.... :P

Earlier today I managed to jury rig a GCM format iso to load Swiss by replacing the apploader.ldr file (using GCRebuilder and also used a zero byte sized start.dol file as the apploader is now Swiss and won't make any attempt to load that file). I also hex-edited the ISO.hdr and gave it a custom game ID (with a proper region code).


I basically just stripped down Mario Kart Double dash to just the system files the GameCube needs to boot. I finally got a custom banner icon working after spending a good part of the day trying to find out what format BMPs have to be in before GCRebuilder will accept as input. Rebuilt the whole thing minus the game files that were originally in the GCM file. So now it's just a barebones Swiss loader. :D

The resulting GCM boots up in Dolphin (but spits out an error about unknown DVD command when Swiss tries to access the DVD drive, but me thinks that's because using a backup loader within an emulator is redundant and will produce errors that won't occur on the real hardware). I click away those errors and Swiss still works and was able to access the same DVD it was on. But the controls in Dolpin were all funky and couldn't get the menu to behave right. :P

Don't have a Gamecube memory card slot on my PC so can't really test SD loading from Swiss from within Dolphin. lolz. :P

However I tested it on my gamecube via SD loader and Swiss won't boot it (though didn't expect it too).

But the older SD Boot app does load it just fine. At this point I assume it will be fully functional once I burn it to a mini-DVD once my mini-DVDs come. The banner shows up fine. I even enabled GameCube BIOS in dolphin and checked there too. Banner and description shows up correctly. :D

My gamecube now has a XenoGC mod chip so I don't think it supports directly booting those odd format ISO files that most bootable homebrew ISOs are in. But this is the first time I've used a XenoGC, so someone feel free to let me know about that. Not about to waste a mini-dvd to find out. :P

If it turns out my XenoGC will boot those homebrew ISOs...well I would like it better this way anyway. At least mine will have proper banner and description when I boot it up from the GameCube bios. :D

EDIT:

Just got my mini-dvds today. Worked on the first try! :D

EDIT2: Ok went to burn a second ISO...now IMGBURN is telling me the blank DVD doesn't have enough space....So I burned a trimmed version instead...It...Worked....

I thought the GameCube couldn't read discs that were burned using trimmed ISO images? Apparently mine does...
ImageImage
dylanyo
Posts: 1
Joined: Tue Feb 18, 2014 5:00 am

Re: swiss and wii - burning iso

Post by dylanyo » Tue Feb 18, 2014 5:38 am

Any chance you could elaborate a little on how you got swiss booting off a dvd or maybe even post the image that you created. I've been trying to get this thing to boot off of dvd for a while and no matter what I do I can't get it to work. Any help would be appreciated.
Post Reply