SOLVED: MEGAdrive V3/WASP fails to load after SWISS update (bricked?)

All your console related questions and answers :)
Post Reply
Posts: 2
Joined: Mon Jul 27, 2015 4:34 am

SOLVED: MEGAdrive V3/WASP fails to load after SWISS update (bricked?)

Post by zonerails » Tue Nov 22, 2016 6:17 pm


Tried to update my MegaDriveV3/WASP using SWISS r377 (which was working fine) and now the device doesn't boot properly. Normally where I would select Swiss to boot, I just have a "?". When I try to start it, it just says "Please insert Nintendo Gamecube Disc" repeatedly rather than booting SWISS.

I used r377, with both files swiss_r377.fzn and swiss_r377.fzn.fw. I selected the fzn file directly from SWISS and it appeared to flash successfully. I did not boot from the SD adapter SWISS. I powered off the WASP but when I powered it back on it was dead.

I have a soft-modded Wii but not an action replay/media player. I don't have an extra Gamecube. This system doesn't have the DVD drive anymore (I bought it with a broken drive).

I created a recovery ISO, booted it and then swapped back to my SD card with the firmware files (swiss_r377.fzn and swiss_r377.fzn.fw). I tried writing the fzn again, but it says "didn't find firmware, writing menu only". It "succeeds", but doesn't recover the WASP. Do the files need to be named differently, or am I missing something?

Thanks a bunch for your help.

edit: Ended up using the instructions here, I'm unbricked now. Had to load the firmware files from a FAT16 formatted card in the SD Gecko slot A.
Post Reply