Is this really a black screen of death?

All your console related questions and answers :)
Post Reply
User avatar
sk8er000
Posts: 23
Joined: Fri May 16, 2014 6:33 pm
Contact:

Is this really a black screen of death?

Post by sk8er000 » Sun Aug 25, 2019 5:40 pm

Hello,
Recently I went to Japan, and I've found a pretty cheap untested Gamecube (console + 2 original controllers for 980 yen).
Today I powered up the console and it showed a strange behaviour:

-it boots fine and it works with composite, rgb, but with component I had some weird colour when in swiss (original cable).
-if I put a disc on the console it starts, BUT not if it's a game!

When I use the "region changer disc" or "SD media launcher" it works but if I try to load a game from CD or from sd (via swiss+ sd media laucher) it stucks on a black screen (no loss of sync). The only exception was with the japanese version of bonk that crashed after the memory card advise.
I've tried with and without gameboy player.

If I try to use the gameboy player (from original disc or gbi) it works normally (tried a game a couple of minutes).

I'm pretty sure that it's an HW problem but I'd like to know the cause of this issue and if there is a way to fix it.

Thank you in advance!
Using Tapatalk
User avatar
emu_kidid
Site Admin
Posts: 4533
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: Is this really a black screen of death?

Post by emu_kidid » Sun Aug 25, 2019 11:02 pm

I've had a Orange NTSC-J GameCube that behaved like this and I could never figure out what the cause was - mine would also black screen on things like loading certain homebrew/etc, it's probably the DVD drive intermittently working/failing to communicate properly since it would only happen when DVD loading/init was involved in some way.
Image
User avatar
Papy.G
Posts: 111
Joined: Mon Mar 04, 2019 6:14 am
Location: France, Occitanie
Contact:

Re: Is this really a black screen of death?

Post by Papy.G » Mon Aug 26, 2019 5:15 am

I though about unsupported video mode or misuse/misunderstanding of the cables abilities, since many statements bugs me:
Jap GCs are not RGB able, so It doesn't output this unless you have the digital AV port to RGB cable (does this even exists?). Using an European RGB cable will just end up getting Composite signal through the SCART connector, while keeping other benefits from it, such as TV automatic wake-up and input setting.
The GC's original cable is only Composite able, the Component cables are optionnal (Digital AV port to 5 RCA (cinch), or to 1 D-terminal)

What type of display do you use, and what region/standard is it intended to be used if it's a TV?

Did you try to boot a game while pressing B to try disabling progressive scan first when using 480p compatible cable?
Can you keep the composite cable connected and check its signal on a second display while testing?

It is very strange that a bad drive would mess the video out only when the digital AV out is used.
DMG/Mf Overclock, AGB/supercard miniSD
DS Fat/NeoMK3 2006 512Mb, DS Lite/flashme V8/Supercard miniSD
DOL001(EUR)/RGB/GBP/WiiSD+Gamexploit/SD2SP2, RVL 001/RGB/CMP/WiiSD
User avatar
emu_kidid
Site Admin
Posts: 4533
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: Is this really a black screen of death?

Post by emu_kidid » Mon Aug 26, 2019 6:00 am

It was actively displaying a black screen rather than a loss of video output in my case.
Image
User avatar
sk8er000
Posts: 23
Joined: Fri May 16, 2014 6:33 pm
Contact:

Re: Is this really a black screen of death?

Post by sk8er000 » Mon Aug 26, 2019 6:15 am

It's certainly not a loss of video unfortunately since I used the same setup as my main gamecube (that is a jap model too). I send the audio directly to my hi-fi, so if it was a not supported video signal the audio should work anyway. When I get a black screen I don't lose the sync it's just a solid black screen with no audio (tried direct on pvm/bvm and ossc). For example when it goes black connected to ossc, the linedoubler still shows the right resolution and not the "no sync message", same on the CRTs.
No inputs works neither pressing reset on the console.
From my understanding it's not the disc drive, because I get the blackscreen even if I load the games from the SD via Swiss using the adapter from as media launcher
Using Tapatalk
User avatar
Papy.G
Posts: 111
Joined: Mon Mar 04, 2019 6:14 am
Location: France, Occitanie
Contact:

Re: Is this really a black screen of death?

Post by Papy.G » Mon Aug 26, 2019 9:01 am

It would be nice to compare both of your IPL/MB/DVD drive rev. to know if that defect is random or not.

It would be nice to first check for proper voltage by scope-ing every of them, and changing the battery.
DMG/Mf Overclock, AGB/supercard miniSD
DS Fat/NeoMK3 2006 512Mb, DS Lite/flashme V8/Supercard miniSD
DOL001(EUR)/RGB/GBP/WiiSD+Gamexploit/SD2SP2, RVL 001/RGB/CMP/WiiSD
User avatar
emu_kidid
Site Admin
Posts: 4533
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: Is this really a black screen of death?

Post by emu_kidid » Tue Aug 27, 2019 12:15 am

sk8er000 wrote:
Mon Aug 26, 2019 6:15 am
It's certainly not a loss of video unfortunately since I used the same setup as my main gamecube (that is a jap model too). I send the audio directly to my hi-fi, so if it was a not supported video signal the audio should work anyway. When I get a black screen I don't lose the sync it's just a solid black screen with no audio (tried direct on pvm/bvm and ossc). For example when it goes black connected to ossc, the linedoubler still shows the right resolution and not the "no sync message", same on the CRTs.
No inputs works neither pressing reset on the console.
From my understanding it's not the disc drive, because I get the blackscreen even if I load the games from the SD via Swiss using the adapter from as media launcher
Run the HW test disc if you have a copy, if not, I feel like you might have a bad section of ARAM, DOL loading (and the DOL loading for games in swiss) all happens via ARAM usage.
Image
Post Reply