Audio streaming not working with physical discs

All your console related questions and answers :)
Post Reply
User avatar
neuropunk
Posts: 5
Joined: Fri May 22, 2020 1:11 am

Audio streaming not working with physical discs

Post by neuropunk » Fri May 22, 2020 1:53 am

Hello, moderately new to the forums and Gamecube modding as a whole, so please bear with me. I've recently acquired a modded Gamecube from Stone Age Gamer, sporting a Pluto-IIx XC3S200 FPGA HDMI mod, as well as a Xeno chip. Over the past week, I've been playing a lot of F-Zero GX, but recently decided to start a Star Fox Adventure playthrough. I initially tried running the .iso from an SD card (via sd2sp2) through Swiss-r827, but immediately noticed that all dialogue was missing, as well as music during the cutscenes. After searching online, I discovered that enabling "Emulate Audio Streaming" would give me the dialogue and music during cutscenes, but at the expense of some static, crackling, and stuttering during any FMV stuff. Discontent with this, I decide to break out my actual disc copy.
Here is the strange part, after trying to play the game from my actual disc, and had the same initial problem. There was no dialogue, and music was missing from cutscenes. Keep in mind that the disc is in pretty good condition. This has left me both stumped and frustrated, as all I want to do is sit down, relax, and enjoy the game.
I'm very much unfamiliar with what changes are made to the drive when a Xeno chip is installed, but I'm concerned that there must be an issue with the drive if even the actually disc isn't playing the audio. I understand that running games from an SD card can have it's quirks, but I'm quite shocked to find that actual disc is having the same issue. If anyone has any information relating to this issue, I'd love to hear it. I've reached out to Stone Age Gamer, but don't really expect to hear back from them until tomorrow.

UPDATE:
It seems audio streaming is just borked in general. Wave Race: Blue Storm has no music at all. Please let me know if this is an issue I can remedy.
Last edited by neuropunk on Fri May 22, 2020 11:12 pm, edited 2 times in total.
User avatar
Papy.G
Posts: 475
Joined: Mon Mar 04, 2019 6:14 am
Location: France, Occitanie
Contact:

Re: Various Star Fox Adventures issues

Post by Papy.G » Fri May 22, 2020 9:10 am

Do you launch the disc through SWISS?
Try just running the game off the disc from boot, the regular way.
Do you have an unmodded GC or Wii to try?

If this is chip related, it would mean that these are more and more troublesome than helpful. :evil:

A friend recenytly told me that Luigi's Mansion Jap can't run on a chipped PAL console.
DMG/MF OC, AGB/SC miniSD, NTR/NeoMK3, USG/flashme V8/SC miniSD
DOL001(EUR)/RGB/GCPlug/GBP/SD2SP2, RVL 001(EUR)/RGB/CMP/WiiSD

Zelda WW with Tingle Tuner in split screen was what the GC RF modulator was made for! (Video)
User avatar
neuropunk
Posts: 5
Joined: Fri May 22, 2020 1:11 am

Re: Various Star Fox Adventures issues

Post by neuropunk » Fri May 22, 2020 9:41 am

Papy.G wrote:
Fri May 22, 2020 9:10 am
Do you launch the disc through SWISS?
Try just running the game off the disc from boot, the regular way.
Do you have an unmodded GC or Wii to try?

If this is chip related, it would mean that these are more and more troublesome than helpful. :evil:

A friend recenytly told me that Luigi's Mansion Jap can't run on a chipped PAL console.
Thanks for the reply, No, I was running the disc from boot. I do have a Wii, so I'll try that out tomorrow. Part of me hopes it's just the disc; it'd be a bummer, but it's much less troublesome to replace Star Fox Adventures than a modded console. I find it strange that I'm unable to find anything related to this exact issue online. There are tons of posts of the same issue from people emulating using Dolphin or trying to run the iso, but nothing about the actual disc having problems.

I'm also wondering three things:
1.) Should having my SD card in through sd2sp2 affect actual game discs I boot? Would it be worth trying to play the game without my sd2sp2 plugged in?
2.) I was reading the XenoGC page on the wiki, and read this under the Settings section:

[L button] Disable audiofix
If you have previously modified your backup images to work with a BIOS that did not have proper support for audio streaming, this setting will disable that modification.


While I'm not playing from a backup image, could this have anything to do with this issue? I find the the excerpt "BIOS that did not have proper support for audio streaming" curious. What BIOS is this referring to?
3.) I haven't done much research on pot adjustment, but could this be related to a potential improper pot adjustment during the modding process? I'm not completely sure what all was done on Stone Age Gamer's end, but I can't help but think it could possible be the drive.
User avatar
Papy.G
Posts: 475
Joined: Mon Mar 04, 2019 6:14 am
Location: France, Occitanie
Contact:

Re: Various Star Fox Adventures issues

Post by Papy.G » Fri May 22, 2020 4:21 pm

Strange that it hasn't been related online, but everything is not online.

1) I'm rarely running games the regular way on my cube, with both the SDGecko sitting with an SD card in, an the SD2SP2 as well, but never noticed any problems the rare times I did.

2) I don't know as I don't have chipmodded cubes and am not aware of all those BIOSes concern, but as the disc is genuine, I don't see why it would mess up the original way to work. Try and see, it may not hurt.

3) I know that some modders can get GCs with faulty drives to mod, then, tweak up the pot a little more than usual to get the beam to better catch data. Also, I know that many drives have died this way. Touching it may void your warranty, send them a mail first.
DMG/MF OC, AGB/SC miniSD, NTR/NeoMK3, USG/flashme V8/SC miniSD
DOL001(EUR)/RGB/GCPlug/GBP/SD2SP2, RVL 001(EUR)/RGB/CMP/WiiSD

Zelda WW with Tingle Tuner in split screen was what the GC RF modulator was made for! (Video)
User avatar
neuropunk
Posts: 5
Joined: Fri May 22, 2020 1:11 am

Re: Various Star Fox Adventures issues

Post by neuropunk » Fri May 22, 2020 10:01 pm

Okay, tried the following:
1.) Tested disc on Wii, audio is fine, so it isn't the disc.
2.) Burned a REDUMP iso to a disc, and tried that on my Gamecube; same issue, which reiterates that it isn't the disc.
3.) Tried removing all external peripherals (sd2sp2, broadband adapter, game boy player), did nothing unsurprisingly.
4.) Tried playing my Pikmin 2 disc, as this game supposedly also uses Audio Streaming. Didn't notice any issues.
5.) Tried holding "L" during boot to disable audio fix. Not entirely sure if I did this correctly, but this was not a fix.
User avatar
Extrems
Posts: 970
Joined: Tue Aug 17, 2010 10:40 pm
Location: Québec, Canada
Contact:

Re: Various Star Fox Adventures issues

Post by Extrems » Fri May 22, 2020 10:08 pm

Pikmin 2 doesn't use streaming audio.
User avatar
neuropunk
Posts: 5
Joined: Fri May 22, 2020 1:11 am

Re: Various Star Fox Adventures issues

Post by neuropunk » Fri May 22, 2020 10:37 pm

Extrems wrote:
Fri May 22, 2020 10:08 pm
Pikmin 2 doesn't use streaming audio.
I read this here:
https://www.gc-forever.com/wiki/index.p ... _Streaming

Do you have a proper list? I have the following physical discs to test:
Animal Crossing
Billy Hatcher
Super Mario Sunshine
Wind Waker
Pikmin 1/2
F-Zero GX (tested this one extensively; no issues)
Super Monkey Ball 2
Melee
Turok: Evolution
Pokemon Channel
Wave Race
Crystal Chronicles
User avatar
Extrems
Posts: 970
Joined: Tue Aug 17, 2010 10:40 pm
Location: Québec, Canada
Contact:

Re: Various Star Fox Adventures issues

Post by Extrems » Fri May 22, 2020 10:52 pm

Wave Race: Blue Storm is the quintessential streaming audio game.
User avatar
neuropunk
Posts: 5
Joined: Fri May 22, 2020 1:11 am

Re: Various Star Fox Adventures issues

Post by neuropunk » Fri May 22, 2020 10:59 pm

Extrems wrote:
Fri May 22, 2020 10:52 pm
Wave Race: Blue Storm is the quintessential streaming audio game.
Ok, yeah, just tested it out, no music. What would this imply exactly? Hardware or software issue?
User avatar
Diego borella
Posts: 127
Joined: Sat Jan 11, 2020 8:37 pm
Location: Brazil

Re: Audio streaming not working with physical discs

Post by Diego borella » Wed Jul 01, 2020 10:25 pm

One way found is to trigger all the patches: audio emulator and reading speed.
then give an IGR.dol, activate again only for tab 4, the two parameters.
in the game configuration; not the global!
there is also a detail, I stopped using swiss.ini
with that, I created an empty swiss.ini, by notepad, which cannot be written by swiss.
in fact, bringing the settings through the gamecube SRAM, brought me better results with the sound, and so far it hasn't failed, for the games I played ...
the downside is having to tidy up all the settings every time i go into a game.
at least the sound of pandora tomorrow is working like a drive for my ...
User avatar
emu_kidid
Site Admin
Posts: 4680
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: Various Star Fox Adventures issues

Post by emu_kidid » Mon Jul 06, 2020 11:57 pm

neuropunk wrote:
Fri May 22, 2020 10:59 pm
Extrems wrote:
Fri May 22, 2020 10:52 pm
Wave Race: Blue Storm is the quintessential streaming audio game.
Ok, yeah, just tested it out, no music. What would this imply exactly? Hardware or software issue?
Try a game completely outside of Swiss, remove any XenoGC or whatever you might have too. If you have a spare DVD drive, swap that in and try that too. The audio streaming from the drive relies on a few pins to function, check that these have continuity on both the DVD drive side and the GameCube mainboard, they are listed here: https://gc-forever.com/yagcd/chap2.html#sec2.4.1.5

There are other topics here pertaining to the pinout and its orientation with pictures provided on this forum if you can't work out which pins to look at.
Image
Post Reply