Progress report for V2 ide-exi firmware

Support forum for the IDE to EXI adapter
Post Reply
andre104623
Posts: 642
Joined: Wed May 07, 2014 2:24 pm

Progress report for V2 ide-exi firmware

Post by andre104623 » Tue Aug 12, 2014 8:58 pm

Subject says it all where are we at with v2 firmware for ide-exi, Does it exist?, Is there a beta to test, Has DMA really been fixed? These questions are important for someone willing to want to build a batch. I been hearing everywhere that DMA has been fixed I know its up in the air and I know that mega was using v2 in his version of ide-exi but was having issues. So my main goal for this topic is to give everyone that has an ide-exi some much needed info and how will the update be used (swiss update or ide-exi flash).
User avatar
emu_kidid
Site Admin
Posts: 4327
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: Progress report for V2 ide-exi firmware

Post by emu_kidid » Tue Aug 12, 2014 10:47 pm

I actually looked into this last week, and v2 has bugs that I am trying to work out (DMA works but is broken for larger reads). If that is fixable (I hope so), then it should work pretty well in Swiss with DMA.
Image
User avatar
megalomaniac
Posts: 2480
Joined: Sun Aug 21, 2011 5:33 am
Location: Drunk in Texas
Contact:

Re: Progress report for V2 ide-exi firmware

Post by megalomaniac » Wed Aug 13, 2014 12:46 am

andre104623 wrote:These questions are important for someone willing to want to build a batch.
other than this recent peek into V2....there has been no progress on it in years
why not use v1? unless you want to build a v2 batch
..but even if the code had been released it would offer zero benefit at this time...
...it possibly might never allow for the intended benefit unless it can get fixed...

those problems you mention i had...those were related to some bugs with v2 identified during my trials with swiss...
because of those bugs, i only sold ide-exi with v1
emu_kidid wrote: beer is like WD40 for megalomaniac's brain, gets the gears moving
>>> BadAssConsoles.com <<<

Image Image Image
andre104623
Posts: 642
Joined: Wed May 07, 2014 2:24 pm

Re: Progress report for V2 ide-exi firmware

Post by andre104623 » Wed Aug 13, 2014 1:34 am

megalomaniac wrote:
andre104623 wrote:These questions are important for someone willing to want to build a batch.
other than this recent peek into V2....there has been no progress on it in years
why not use v1? unless you want to build a v2 batch
..but even if the code had been released it would offer zero benefit at this time...
...it possibly might never allow for the intended benefit unless it can get fixed...

those problems you mention i had...those were related to some bugs with v2 identified during my trials with swiss...
because of those bugs, i only sold ide-exi with v1
This isn't attended to be a rush on any progress just info for people that have the ide-exi that's all.
andre104623
Posts: 642
Joined: Wed May 07, 2014 2:24 pm

Re: Progress report for V2 ide-exi firmware

Post by andre104623 » Wed Aug 13, 2014 1:42 am

Emu-kidd has stated that DMA is working somewhat so that was my goal here just some info and if the larger file bug doesn't get fixed then oh well. At least it was some official word about it
andre104623
Posts: 642
Joined: Wed May 07, 2014 2:24 pm

Re: Progress report for V2 ide-exi firmware

Post by andre104623 » Wed Aug 13, 2014 1:51 am

And one of the reasons the Ide-exi progress is so slow is because there are so little out there. You figure there was 100 made at first then mega made some but has sold very few of them (Im guessing between 20-25 if that) and then you have your homemade ones also so think about it maybe 250 out there. That's all and to me that's not much of a push for development
User avatar
emu_kidid
Site Admin
Posts: 4327
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: Progress report for V2 ide-exi firmware

Post by emu_kidid » Wed Aug 13, 2014 3:00 am

Even if there were 10,000 out there, the push for development wouldn't be greater, there'd just be more complaints :P

I work at my own pace and on whatever motivates me. Having 10,000 people asking for something wouldn't necessarily motivate me more.

The bug is on multi-sector reads, which would be the entire benefit of using DMA, if this isn't fixed, you might as well stick to v1 cause it won't be any faster, just different code.
Image
andre104623
Posts: 642
Joined: Wed May 07, 2014 2:24 pm

Re: Progress report for V2 ide-exi firmware

Post by andre104623 » Wed Aug 13, 2014 3:11 am

emu_kidid wrote:Even if there were 10,000 out there, the push for development wouldn't be greater, there'd just be more complaints :P

I work at my own pace and on whatever motivates me. Having 10,000 people asking for something wouldn't necessarily motivate me more.

The bug is on multi-sector reads, which would be the entire benefit of using DMA, if this isn't fixed, you might as well stick to v1 cause it won't be any faster, just different code.
That's understandable but if I had the knowledge to code I would be helping to get DMA fully working for sure but I'm not asking for anything I love the ide-exi just for movies and TV shows. There was just a lot of rumors our there I was trying to clear up. I love swiss and all the work you have put into the scene
User avatar
MockyLock
Posts: 319
Joined: Tue Aug 07, 2012 8:12 pm

Re: Progress report for V2 ide-exi firmware

Post by MockyLock » Wed Aug 13, 2014 5:28 am

Just a question,
V2 is a firmware/code update or a complete new board ?
User avatar
emu_kidid
Site Admin
Posts: 4327
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: Progress report for V2 ide-exi firmware

Post by emu_kidid » Wed Aug 13, 2014 6:46 am

code, requiring jtag to update it.
Image
User avatar
MockyLock
Posts: 319
Joined: Tue Aug 07, 2012 8:12 pm

Re: Progress report for V2 ide-exi firmware

Post by MockyLock » Wed Aug 13, 2014 7:38 am

Thank you,
i encountered many issue with JTAG when i tried to build my own IDE-EXI, it seemed it was a voltage issue, a few 1/10 of volts -_-
i sent my chips to megalomaniac and he found the trick.
andre104623
Posts: 642
Joined: Wed May 07, 2014 2:24 pm

Re: Progress report for V2 ide-exi firmware

Post by andre104623 » Wed Aug 13, 2014 2:16 pm

MockyLock wrote:Thank you,
i encountered many issue with JTAG when i tried to build my own IDE-EXI, it seemed it was a voltage issue, a few 1/10 of volts -_-
i sent my chips to megalomaniac and he found the trick.
Just some info in case you want to build some more you can buy a nand-x for xbox j-taging and use that to program the chip. Also its usb
User avatar
MockyLock
Posts: 319
Joined: Tue Aug 07, 2012 8:12 pm

Re: Progress report for V2 ide-exi firmware

Post by MockyLock » Wed Aug 13, 2014 5:37 pm

I don't think i will try a second time.
I found an IDE-EXI from the first batch, and wait for 2 from the second.
andre104623
Posts: 642
Joined: Wed May 07, 2014 2:24 pm

Re: Progress report for V2 ide-exi firmware

Post by andre104623 » Wed Aug 13, 2014 6:08 pm

MockyLock wrote:I don't think i will try a second time.
I found an IDE-EXI from the first batch, and wait for 2 from the second.
I know what you mean I got 5 bare pcb from sunstone pcb and I ordered a white solder mask I should of got green mask instead. I think why it's really hard for me to solder it and they where not cheap I paid 65 with shipping for the pcb's then I only was able to get 2 IC chips they were 15 after shipping and the ide headers I ordered came broken so I have some old PC's laying around so I de-soldered the ide header from one of them. I got one working but I still like mega's a lot better but this was just a project/test because I was planning to make a batch of these but in order for this to be affordable for the end user I would have to order 50 or more from the pcb maker. I least they are fast I sent the files over to them then they gave me a quote I paid them 8 days later they were in my hands that's fast.
Post Reply