Homebrew for the IDE-EXI

Support forum for the IDE to EXI adapter
Post Reply
User avatar
emu_kidid
Site Admin
Posts: 4533
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Homebrew for the IDE-EXI

Post by emu_kidid » Mon Dec 20, 2010 11:17 pm

WARNING WRITE SUPPORT IS NOT 100% TESTED AND CAN CORRUPT FILES ON THE HARD DISK - Bug fixes should be made eventually.

This topic will contain all the homebrew which supports the IDE-EXI.

All will share the same base interface code so and all source will be provided bundled with the binaries.

Most are placeholders but eventually they should all be available with full IDE-EXI support :)
MPlayer CE (Media Player Homebrew for Gamecube)
Limitations:
- Maxes out at about the 1500kbps mark in combined video+audio so keep it low res for now until we have DMA on the IDE-EXI worked out
Instructions:
- Extract contents to the root of your IDE HDD :)
- Plug in the IDE-EXI into either Slot A or Slot B
- Boot up mplayer.dol using your favorite loader
- Select GC SD Slot A or B (this will point to ide-exi instead of SD)
- Enjoy!
mplayer-653-ide-exi.zip
(3.12 MiB) Downloaded 524 times
Cube64
CubeSX
FCE Ultra GX 3.2.3 for Gamecube
Instructions:
- Use as normal, except now you can use the IDE-EXI as a device - saving works too
Image Image
fceugc-ide-exi.7z
(4.68 MiB) Downloaded 570 times
GenPlusGX 1.4.1 for Gamecube
Instructions:
- Click on Load SD and it'll load from the IDE-EXI instead - saving works too
genplus-gx-ide-exi.7z
(2.63 MiB) Downloaded 487 times
SMSPlusGX
Snes9xGX 4.2.5 for Gamecube
Instructions:
- Use as normal, except now you can use the IDE-EXI as a device - saving works too
Image Image
snes9x-gx-ide-exi.7z
(4.78 MiB) Downloaded 579 times
VBA GX 2.2.2 for Gamecube
Instructions:
- Use as normal, except now you can use the IDE-EXI as a device - saving works too
Image Image
vba-wii.7z
(4.52 MiB) Downloaded 500 times
WiiMC (GC Port)

If anyone can name anything I've missed that is available for GC, let me know.
Image
User avatar
emu_kidid
Site Admin
Posts: 4533
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: Homebrew for the IDE-EXI

Post by emu_kidid » Fri Jan 28, 2011 11:56 pm

heh, that's a lot of stuff!
Image
kevstah2004
Posts: 308
Joined: Wed Mar 31, 2010 1:07 pm
Location: UK, Hull

Re: Homebrew for the IDE-EXI

Post by kevstah2004 » Sat Jan 29, 2011 9:31 pm

Always keeping you busy ;-P
User avatar
emu_kidid
Site Admin
Posts: 4533
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: Homebrew for the IDE-EXI

Post by emu_kidid » Wed Feb 09, 2011 3:08 am

P.S. I've got to update all of the above emulators - the code had a pretty serious bug that only made it work on a select few hdd's :(

Should be happening soon.
Image
User avatar
emu_kidid
Site Admin
Posts: 4533
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: Homebrew for the IDE-EXI

Post by emu_kidid » Sat Feb 12, 2011 1:17 am

added MPlayer CE for ide-exi.
Image
User avatar
Extrems
Posts: 773
Joined: Tue Aug 17, 2010 10:40 pm
Location: Quebec, Canada
Contact:

Re: Homebrew for the IDE-EXI

Post by Extrems » Sat Feb 12, 2011 2:37 am

I don't get it, no one ever spell MPlayer CE right.
User avatar
emu_kidid
Site Admin
Posts: 4533
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: Homebrew for the IDE-EXI

Post by emu_kidid » Sat Feb 12, 2011 3:01 am

there we go.
Image
User avatar
Jaecus
Posts: 77
Joined: Sun Feb 20, 2011 2:54 am
Location: England

Re: Homebrew for the IDE-EXI

Post by Jaecus » Fri Mar 18, 2011 8:11 pm

I have been testing the MPlayer CE for IDE-EXI.
I keep having to replace the mplayer installation folder as it becomes corrupt in some way and will not boot the dol in swiss.
At first I thought it may have been due to the DMA and 1500kbps max of audio/video as mentioned in first post.
But I have just launched mplayer through IDE, swiss 0.1r33 Played only one track of music and then went to quit mplayer. After reboot of the console and loading up swiss I find that when loading Mplayer.dol it gives a black screen with install directory error. Folder has to be replaced with the original.

This is my experience and i have not tested any other harddrive only a Hitachi Deskstar IDE 60gb 7200rpm

Still great work, keep it up :D
User avatar
emu_kidid
Site Admin
Posts: 4533
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: Homebrew for the IDE-EXI

Post by emu_kidid » Fri Mar 18, 2011 11:47 pm

the write code still has bugs that I need to iron out
Image
Post Reply