Viper GC Extreme USB Adapter problems

Support forum for the IDE to EXI adapter
Riku64
Posts: 16
Joined: Thu Jul 07, 2011 12:11 am

Re: Viper GC Extreme USB Adapter problems

Post by Riku64 » Sat Jul 16, 2011 8:21 am

Ah, wondered where it went! :P
Fits much better here.
Now I don't have to repeat myself. :mrgreen:
Dragoon
Posts: 323
Joined: Thu Jan 27, 2011 1:01 pm

Re: Viper GC Extreme USB Adapter problems

Post by Dragoon » Sat Jul 16, 2011 10:08 am

Put cobra 2.1 on it and try to flash a compressed swiss dol on it, and tell us your experience ;)
Image
Riku64
Posts: 16
Joined: Thu Jul 07, 2011 12:11 am

Re: Viper GC Extreme USB Adapter problems

Post by Riku64 » Sat Jul 16, 2011 8:46 pm

Dragoon wrote:Put cobra 2.1 on it and try to flash a compressed swiss dol on it, and tell us your experience ;)
Used Windows 7 Netbook, Viper USB Driver that comes with ViperFlasherUSB.
Flashed with Cobra Manager 1.1 (Running as admin), flashed Swiss-0.1-rf7 successfully.
However when I try to boot this program, it just hangs at Running DOL.
Tried DOLSendUSB, It sends the file, closes, and the viper just sits there on USB Mode.
With other DOL files DOLSendUSB works great, so I'm at a rock and a hard spot here :lol: , anybody know of a Viper version of Swiss?

For the record, Cobra 2.1 running on ViperGC Extreme, NTSC Version 1.1, DOL-001 USA. :P
Dragoon
Posts: 323
Joined: Thu Jan 27, 2011 1:01 pm

Re: Viper GC Extreme USB Adapter problems

Post by Dragoon » Sun Jul 17, 2011 10:12 am

I finally got it to work!
here is the trick:
compile the latetest version of swiss (wich is r52 now),
make a .bat file where your swiss.dol is and also copy d0lz.exe in that folder,
type this into your .bat file:
d0lz.exe swiss.dol swiss-lz.dol -v
pause

then turn on your gamecube and open cobra manager 1.1
click connect and click on add, select swiss-lz.dol and let it flash

Something else to remember is, wait with connecting for around 5 seconds after turning the gamecube on, cobra needs to load the disc first.

small Q&A:
Q: It hangs at flashing and says Cobra bios remote is not responding
A: close the cobra manager, turn off your gamecube, turn it back on, open cobra manager and try again

Q: It tells me Cobra bios is not initialized
A: Go to the settings screen and hit save and exit, turn off your gamecube and turn it back on, close and reopen cobra manager
Last edited by Dragoon on Sun Jul 17, 2011 10:20 am, edited 1 time in total.
Image
User avatar
liquitt
Posts: 1753
Joined: Thu Apr 01, 2010 5:43 am
Location: neverland
Contact:

Re: Viper GC Extreme USB Adapter problems

Post by liquitt » Sun Jul 17, 2011 10:18 am

Dragoon wrote:I finally got it to work!
here is the trick:
compile the latetst version of swiss (wich is r52 now),
make a .bat file where your swiss.dol is and also copy d0lz.exe in that folder,
type this into your .bat file:
d0lz.exe swiss.dol swiss-lz.dol -v
pause
didnt help me either, we had that discussion about setting the viper option in dollz sometime back then
so weird, i guess mine is just broken
please search before you ask - a lot has been discussed already!
(or use google with "site:gc-forever.com *term*")
http://is.gd/MDmZcr

we also have a wiki filled with knowledge
http://is.gd/dX58Rm
Dragoon
Posts: 323
Joined: Thu Jan 27, 2011 1:01 pm

Re: Viper GC Extreme USB Adapter problems

Post by Dragoon » Sun Jul 17, 2011 10:22 am

If you want I can flash your viper for you, cause I think your usb adapter is the problem.
Image
User avatar
liquitt
Posts: 1753
Joined: Thu Apr 01, 2010 5:43 am
Location: neverland
Contact:

Re: Viper GC Extreme USB Adapter problems

Post by liquitt » Sun Jul 17, 2011 10:28 am

Dragoon wrote:If you want I can flash your viper for you, cause I think your usb adapter is the problem.
i have 3 of them
please search before you ask - a lot has been discussed already!
(or use google with "site:gc-forever.com *term*")
http://is.gd/MDmZcr

we also have a wiki filled with knowledge
http://is.gd/dX58Rm
Dragoon
Posts: 323
Joined: Thu Jan 27, 2011 1:01 pm

Re: Viper GC Extreme USB Adapter problems

Post by Dragoon » Sun Jul 17, 2011 11:30 am

Wow, did you order the other 2 from devineo.es?
Image
Riku64
Posts: 16
Joined: Thu Jul 07, 2011 12:11 am

Re: Viper GC Extreme USB Adapter problems

Post by Riku64 » Sun Jul 17, 2011 11:03 pm

liquitt wrote:
didnt help me either, we had that discussion about setting the viper option in dollz sometime back then
so weird, i guess mine is just broken
Are you having trouble flashing the bios? Or flashing files to the file system?
Either way what version of windows are you using and did you happen to use "ViperUSBWin7Driver.zip"?

EDIT: If you are flashing files, ( this may be a dumb question ) Are both switches set correctly, and is your USB adapter plugged into the serial port?
EDIT 2: Nevermind, why oh why don't I read?
User avatar
liquitt
Posts: 1753
Joined: Thu Apr 01, 2010 5:43 am
Location: neverland
Contact:

Re: Viper GC Extreme USB Adapter problems

Post by liquitt » Mon Jul 18, 2011 6:20 am

Riku64 wrote:EDIT 2: Nevermind, why oh why don't I read?
i dunno.... :roll:
please search before you ask - a lot has been discussed already!
(or use google with "site:gc-forever.com *term*")
http://is.gd/MDmZcr

we also have a wiki filled with knowledge
http://is.gd/dX58Rm
boozezela
Posts: 27
Joined: Tue Apr 16, 2013 12:54 am

Re: Viper GC Extreme USB Adapter problems

Post by boozezela » Sun Jan 19, 2014 9:58 pm

I know I am very late to the party on this, however I have experienced the same problem, with the transfer that would freeze from time to time and the dreaded error message as well.

I managed to find a silly workaround that - for whatever reason - works for me all the time: when I transfer files keep I wiggling slightly the USB adapter on the bottom of the GC till he transfer completes. I don't know why it works, but it prevents the Viper from becoming "unseen" by Cobra Manager.
Gamecube DOL-001 (EUR)
Viper GC Extreme + Cobra 2.1
SD Card Adapter
User avatar
liquitt
Posts: 1753
Joined: Thu Apr 01, 2010 5:43 am
Location: neverland
Contact:

Re: Viper GC Extreme USB Adapter problems

Post by liquitt » Thu Jan 23, 2014 8:31 am

boozezela wrote:I know I am very late to the party on this, however I have experienced the same problem, with the transfer that would freeze from time to time and the dreaded error message as well.

I managed to find a silly workaround that - for whatever reason - works for me all the time: when I transfer files keep I wiggling slightly the USB adapter on the bottom of the GC till he transfer completes. I don't know why it works, but it prevents the Viper from becoming "unseen" by Cobra Manager.
whenever i dig my gc out again i will try this - and probably feel like an idiot doing so :D
please search before you ask - a lot has been discussed already!
(or use google with "site:gc-forever.com *term*")
http://is.gd/MDmZcr

we also have a wiki filled with knowledge
http://is.gd/dX58Rm
korn16ftl3
Posts: 14
Joined: Mon Oct 17, 2011 6:26 pm

Re: Viper GC Extreme USB Adapter problems

Post by korn16ftl3 » Sun Aug 06, 2017 5:54 pm

boozezela wrote:I know I am very late to the party on this, however I have experienced the same problem, with the transfer that would freeze from time to time and the dreaded error message as well.

I managed to find a silly workaround that - for whatever reason - works for me all the time: when I transfer files keep I wiggling slightly the USB adapter on the bottom of the GC till he transfer completes. I don't know why it works, but it prevents the Viper from becoming "unseen" by Cobra Manager.
I seem to be having connection issues between my viper flasher and the chip it's self as well...or maybe even between the usb port and flasher as I don't have the oem usb cord that it came with. I ordered some shorter and more insulated usb cords and hopefully that will resolve my issue.

My chip when trying to flash to the flash memory and add DOL files just starts to flash and the progress bar starts to fill up reaches maybe an 8th of the way then errors out after about a 5 minute wait at that status.

I've also noticed that when I click connect to begin the process that the connect button almost immediately turns to a clickable reconnect button. I need to check and see if it's connected up in the "about" section as mentioned in a few other threads (I didn't know I could check there) but the viper flasher does detect in winows xp under the my devices screen on my virtual machine.....worst case scenario I will either add solder to the contact pads on the flasher or maybe just hardwire the flasher to the serial port connectors with some IDE ribbon from an old pc but I'm still not 100% certain where to start as I flashed from dvd to begin with.

If anyone has any thoughts or ideas where to look or how to resolve this I'd love too hear em.....ive seen the question asked if this chip can write to the flash memory via media as well how ever I do not think I have seen a specific yes or no reply to those...is it possible or is the flasher the only way to communicate with the flash space on the chip?
Post Reply