Starting Zelda Ocarina of Time standard version

Discuss one of the most feature filled GameCube applications here :)
Post Reply
dc_coder_84
Posts: 3
Joined: Sun May 26, 2019 7:47 pm

Starting Zelda Ocarina of Time standard version

Post by dc_coder_84 » Thu Jun 06, 2019 8:10 pm

Game: Zelda Ocarina of Time Bonus Disc from Zelda Wind Waker
Region: PAL
Medium: Original Disc
Swiss version: r646

I already posted this under compatibility issues. But I am not sure if this was the right place. So posted it here again. Sorry for double posting.

I am trying to play Ocarina of time in 480p with Swiss. I was successful with this with the Master Quest version but not with the standard version. When I load the last DOL file in the list of patched files I can start Zelda Ocarina of Time Master Quest. I can also load a DOL file to access the selection screen where I can choose between Master Quest and standard version. When I then select the standard version then on the next screen I have the option to enable the rumble feature and when I continue from there I will get a black screen. There seems to be no DOL to start the standard version directly. Can anybody please advise? Many thanks. Is it possible to start the standard version?
User avatar
emu_kidid
Site Admin
Posts: 4507
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: Starting Zelda Ocarina of Time standard version

Post by emu_kidid » Fri Jun 07, 2019 3:19 am

Try the following and see if it works:

- In the settings area of Swiss, enable "Alternative Read Patches"
- With or without the above option, press B instead of selecting an individual DOL file.
Image
dc_coder_84
Posts: 3
Joined: Sun May 26, 2019 7:47 pm

Re: Starting Zelda Ocarina of Time standard version

Post by dc_coder_84 » Fri Jun 07, 2019 1:58 pm

I tested this now but without success :( Maybe I should try another revision?
theclaw
Posts: 324
Joined: Tue Dec 13, 2011 12:01 pm

Re: Starting Zelda Ocarina of Time standard version

Post by theclaw » Sat Jun 08, 2019 6:15 pm

The NTSC version officially supports 480p. If that helps.

I'm not familiar with how Swiss handles booting games with multiple DOLs.
Try setting Swiss to force 480p, then run the game in the original way (without selecting a DOL).
User avatar
Papy.G
Posts: 89
Joined: Mon Mar 04, 2019 6:14 am
Location: France, Occitanie
Contact:

Re: Starting Zelda Ocarina of Time standard version

Post by Papy.G » Tue Jun 11, 2019 11:32 am

With everything Euro, No Original disc, but ISO from SD:
GC, Video not forced/Alt. patches on/B launch -> error from the game: "error…read the manual" or something.
GC, Video not forced-240p-480i-480sf/Alt patches off/B launch -> OK (errors on the SD card messed up the text in French, on one of my previous attempts)
Wii, Video not forced-480p/Alt patches off/B launch -> OK (errors on the SD gave me a Swiss Message: "Too many patches enabled, memory limit reached" on previous attempts)

Edit:
Something was messed up on the SD card so I didn't get the game playing on the Wii, an not even back on the GC
Against what can be read sometimes, the game's emulator doesn't render in 240P, it can be proven with the title screen, comparing forced 240P and native 480i.

If it doesn't work, try to delete the game's patch files off your SD card, and rip the game's settings off the Swiss.ini file. You may end up getting something to work. If it still doesn't work, try to dump your game disc to your SD (with cleanrip), remember you won't be able to play the videos off the ISO on an SD.
Overclocked DMG
AGB/supercard miniSD
DS Fat/NeoMK3 2006 512Mb
DS Lite/flashme V8noautostealth/Supercard miniSD
DOL001(EUR)/RGB/GBP/WiiSD+Gamexploit
RVL 001/RGB/CMP/WiiSD
Post Reply