Swiss Nightly Build

Discuss one of the most feature filled GameCube applications here :)
User avatar
emu_kidid
Site Admin
Posts: 4208
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: Swiss Nightly Build

Postby emu_kidid » Sun Nov 24, 2013 11:08 am

glf999, cheats are broken until further notice.

Can we get r249 built soon? :)
Image

User avatar
47iscool
Posts: 140
Joined: Thu Mar 07, 2013 8:50 am
Location: Blast Processing
Contact:

Re: Swiss Nightly Build

Postby 47iscool » Mon Nov 25, 2013 5:26 pm

Little problem, can't get any game to boot with the newest ones.

Setup:
Wii NTSC 4.3U
GameCube NTSC (IPL REV 1.1) (DOL-001)
SD Gecko slot B/ 8GB SDHC/Speed 32 MHz
Swiss 0.3 r249
No disc in drive/ default settings (Deleted ini file then restarted Swiss)
No modchip in either console
Swiss ISO booted from USB with DM 2.5

Games tried:
Paper Mario TTYD, NTSC trimmed with GCM utility/ Nothing
Hitman 2 SA NTSC, trimmed with GCM utility/Shows licensed by Nintendo then noting
Sonic Adventure DX Prototype Preview NTSC-J, Shows green screen then does nothing

These games all work (except SADX Prototype) with r174. Maybe it's something wrong I'm doing? I think that the reason that the SADX Prototype won't work is because the ID is RELSAB, forcing NTSC doesn't work with me either.
Last edited by 47iscool on Mon Nov 25, 2013 10:38 pm, edited 2 times in total.
Stormcloak Soldier

User avatar
emu_kidid
Site Admin
Posts: 4208
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: Swiss Nightly Build

Postby emu_kidid » Mon Nov 25, 2013 9:33 pm

I don't support Swiss running on a Wii so I can't really fully diagnose the issues you might be having. I'd try clean ISO files on a freshly formatted card then let me know.
Image

User avatar
megalomaniac
Posts: 2479
Joined: Sun Aug 21, 2011 5:33 am
Location: Drunk in Texas
Contact:

Re: Swiss Nightly Build

Postby megalomaniac » Mon Nov 25, 2013 11:01 pm

R174 patched the iso
How do iso's that have been previously patched with those older versions of swiss perform against the latest swiss patching methods??
emu_kidid wrote: beer is like WD40 for megalomaniac's brain, gets the gears moving

>>> BadAssConsoles.com <<<

Image Image Image

User avatar
47iscool
Posts: 140
Joined: Thu Mar 07, 2013 8:50 am
Location: Blast Processing
Contact:

Re: Swiss Nightly Build

Postby 47iscool » Mon Nov 25, 2013 11:02 pm

SDHC partitions erased with HDD Low-Level Format tool, formatted to FAT32 with EaseUS Partition Master.

Nothing, tried Super Mario Sunshine GMSE01 (cleanrip MD5 checks out with the one at redump.org), access to card is now slower than before, tried on both a GameCube and Wii Console. I'm thinking it's my 8GB that swiss doesn't like. Not booting games with my 2GB either.

megalomaniac wrote:R174 patched the iso
How do iso's that have been previously patched with those older versions of swiss perform against the latest swiss patching methods??


Not sure if you're asking me or emu but I haven't tried a multi-dol game yet.
Last edited by 47iscool on Mon Nov 25, 2013 11:33 pm, edited 2 times in total.
Stormcloak Soldier

User avatar
emu_kidid
Site Admin
Posts: 4208
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: Swiss Nightly Build

Postby emu_kidid » Mon Nov 25, 2013 11:26 pm

they perform badly, use clean ISOs as Swiss writes separate patches now.
Image

User avatar
megalomaniac
Posts: 2479
Joined: Sun Aug 21, 2011 5:33 am
Location: Drunk in Texas
Contact:

Re: Swiss Nightly Build

Postby megalomaniac » Tue Nov 26, 2013 3:01 am

just a heads up:
there has been a slight change to the menu device slot selection
swiss currently defaults to slot A for the selected device
if you wish to browse slot B or change speed settings make sure to press the X button


Image


Image
Attachments
00000000-4.png
(199.95 KiB) Not downloaded yet
00000000-3.png
(189.29 KiB) Not downloaded yet
emu_kidid wrote: beer is like WD40 for megalomaniac's brain, gets the gears moving

>>> BadAssConsoles.com <<<

Image Image Image

User avatar
deckard
Posts: 67
Joined: Sat Jun 01, 2013 4:48 pm

Re: Swiss Nightly Build

Postby deckard » Tue Nov 26, 2013 3:05 am

Hehe I missed that until emu_kidid pointed it out to me :D

Diminuendo
Posts: 280
Joined: Tue Sep 18, 2012 12:32 am

Re: Swiss Nightly Build

Postby Diminuendo » Tue Dec 03, 2013 4:13 am

megalomaniac wrote:just a heads up:
there has been a slight change to the menu device slot selection
swiss currently defaults to slot A for the selected device
if you wish to browse slot B or change speed settings make sure to press the X button


Image


Image


Thanks for showing me this, two complaints though

Swiss.ini will not be accessed if the SD Gecko is in slot B when loading from the WKF, this means that when I load Wind Waker from my WKF I have to chose all my video options again from scratch.

The other problem is that having the Gecko in slot A will cause a tantrum with most games because is doesn't have a memory card there, with some games not allowing slot B saves at all (I know memory card emulating is a thing, but from what i understand it still isn't reliable)

I feel that setting slot B as the default will fix this quite easily.

User avatar
deckard
Posts: 67
Joined: Sat Jun 01, 2013 4:48 pm

Re: Swiss Nightly Build

Postby deckard » Tue Dec 03, 2013 5:55 pm

Emu_kidid stated in IRC recently that he was planning on making slot B the default for SD gecko :)

User avatar
emu_kidid
Site Admin
Posts: 4208
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: Swiss Nightly Build

Postby emu_kidid » Thu Dec 05, 2013 2:27 am

r250 is up with device info in the file browser added.

I will default slot B for SD Gecko shortly and hopefully some other misc changes.
Image

User avatar
emu_kidid
Site Admin
Posts: 4208
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: Swiss Nightly Build

Postby emu_kidid » Wed Dec 18, 2013 12:04 pm

r253 should be up soon with Slot B default and improved read code.
Image

User avatar
deckard
Posts: 67
Joined: Sat Jun 01, 2013 4:48 pm

Re: Swiss Nightly Build

Postby deckard » Fri Dec 20, 2013 12:13 am

Nice! I'll have to give the new build a try this weekend

boozezela
Posts: 27
Joined: Tue Apr 16, 2013 12:54 am

Re: Swiss Nightly Build

Postby boozezela » Sat Jan 04, 2014 1:27 am

Setup:
GameCube PAL + Viper GC
Kept an original game in the drive.
SD Gecko Slot B/ FAST / 32 GB SDHC
Swiss 0.3 R248 to R253 DOL

Game: Mario Kart Double Dash NTSC (DL-DOL-GM4E-USA v1.0)
(REGRESSION)

Results:

R248: BLACK SCREEN
R249, 250, 251, 253: The sound during the initial FMV animation is choppy like it was with earlier Swiss versions.
Sound during menu transitions is choppy as well.

With Swiss older builds R094, R174 and R189 the FMV animation visibly flickers but the sound is smooth.
Note that with SD-Boot 0.4 both the FMV animation and sound are smooth.

EDIT: Found a possible config save bug.
Put the .iso file(s) in a subdirectory (e.g. GCGAMES)
Before loading a game, edit its configuration
From page 3/3, go back to page 1/3
Next, Next, save and exit (or change something on page 3/3 and save/exit)

Result:
A file called GCGAMESswiss.ini gets created in the root of the SD card.
Last edited by boozezela on Sat Jan 18, 2014 12:25 am, edited 1 time in total.
Gamecube DOL-001 (EUR)
Viper GC Extreme + Cobra 2.1
SD Card Adapter

User avatar
emu_kidid
Site Admin
Posts: 4208
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: Swiss Nightly Build

Postby emu_kidid » Sat Jan 04, 2014 7:44 am

I'll look into the save bug.. as for the choppy audio, I'm working on it :P
Image

boozezela
Posts: 27
Joined: Tue Apr 16, 2013 12:54 am

Re: Swiss Nightly Build

Postby boozezela » Sat Jan 04, 2014 9:06 am

It is worth noting that with the new Swiss releases the audio for the introductory FMV in Super Smash Bros. Melee US NTSC's plays smoothly.
Too bad audio ends way earlier than the video. :)

Sorry if it is a silly question, but I have to ask: about Mario Kart, why SD-Boot works better than Swiss?
With SD-Boot the FMV plays smoother no "flickering"/repeated frames, plus the audio stuttering fix works.

With Swiss R094, R174 and R189 the video during FMV seems like it goes back by one frame from time to time and enabling the audio stuttering fix (on R174) makes the game unbootable.
Gamecube DOL-001 (EUR)
Viper GC Extreme + Cobra 2.1
SD Card Adapter

User avatar
AC_Orange
Posts: 398
Joined: Mon Mar 29, 2010 11:36 am

Re: Swiss Nightly Build

Postby AC_Orange » Sun Jan 05, 2014 6:19 am

I tried the latest swiss build and Tales of Symphonia and Resident Evil 2 are perfect :D

Diminuendo
Posts: 280
Joined: Tue Sep 18, 2012 12:32 am

Re: Swiss Nightly Build

Postby Diminuendo » Sun Jan 05, 2014 8:17 am

i couldn't get the mutidisc game loading to work for the longest time and then I realized I didn't hit the wiikey switch

boozezela
Posts: 27
Joined: Tue Apr 16, 2013 12:54 am

Re: Swiss Nightly Build

Postby boozezela » Mon Jan 06, 2014 8:44 am

R253 cannot detect if the .ELFs have already been patched within an image by R174/R189.
Last edited by boozezela on Sat Jan 25, 2014 8:03 pm, edited 6 times in total.
Gamecube DOL-001 (EUR)
Viper GC Extreme + Cobra 2.1
SD Card Adapter

boozezela
Posts: 27
Joined: Tue Apr 16, 2013 12:54 am

Re: Swiss Nightly Build

Postby boozezela » Mon Jan 06, 2014 5:39 pm

This is the first of three posts were I am going to detail how Swiss R253 behaves with a bunch of games I have.

I will also test the same game against R174: to check if R253 was an improvement or to check if a game that is broken with R253 worked with R174. When a game is broken using R253 and R174 I will also test it against R094 and - if i feel like it - against "sd-boot 0.4 final edition".

If you have a request for a specific title, let me know and I will test it for you if I have a disc to take a clean rip from.

Setup:
GameCube PAL + Viper GC
DVD drive - No Disk unless specified otherwise.
SD Gecko Slot B / FAST / 32 GB SDHC
Swiss 0.3 R253 DOL

All games are Version 1.0 and "redump.org compliant" clean rips unless specified otherwise.
All isos have ben defragmented (using contig) as I have notices some games would not start otherwise (and swiss sometimes could not detect the fragmentation).

GAMECUBE GAMES #-H
=============================================================================

1080 Avalanche NTSC/US (IMPROVEMENT: NOW WORKS)
R253: Choppy FMV - Stuttering audio, video freezes
R174: Choppy FMV - Stuttering audio, video mostly OK (maybe a tad slow), buzzes during load, then "An error has occurred"

No audio streaming (as expected).

=============================================================================

007 Agent Under Fire V1.01 NTSC/US (REGRESSION: NOW BROKEN)
R253: Green screen at boot.
R174: Works, with some stuttering during FMVs. FMVs look like if they are rendered at half resolution, are badly deinterlaced or badly scaled.
R094: Same as R174 but has slower audio during FMVs (R094 also patches a lot more files).

=============================================================================

007 Everything Or Nothing NTSC/US (NO CHANGE: STILL BROKEN)
R253: Fails to find necessary functions for patching, then reboots the console.
R174: Patches the game, then reboots the console.
R094: Patches the game, then reboots the console.
sd-boot 0.4: Hangs at a green screen.

=============================================================================

007 Nightfire NTSC/US (REGRESSION: NOW BROKEN)
R253:
- Some green garbage shown on screen for 3 seconds when running the main executable
- EA Intro slower to load compared to R174/189 (Stays longer on black screen. Approximately 9 seconds vs 4)
- Hangs on a black screen after you press start

R174/R189: Works using the default settings. Audio stutters a little bit.

=================================================================================

Baten Kaitos - Eternal Wings... (REGRESSION:NOW BROKEN)
R253:
- Lots of garbage on scree after loading the main .dol
- FMV stutters, video is not in sync (I have also tried "fstfix t s" but it did not help).
- Disc 1 is incorrectly recognised as "Disc 2".

R174:
- Less garbage on screen (and for less time)
- FMV stutters
- Video is in sync.
- Disc 1 is incorrectly recognised as "Disc 2".

R094: WORKS
- Less garbage on screen (and for less time)
- FMV stutters
- Buzzes when loading
- Video is in sync.
- Disc 1 correctly recognised as Disc 1

=================================================================================

Baten Kaitos Origins NTSC/US (REGRESSION: NOW BROKEN)
R253, R174:
- Green screen + lots of garbage shows for 2-3 seconds after loading the main .dol
- Initial FMV gets skipped altogether
- Disc 1 is incorrectly recognised as "Disc 2".

R094: WORKS
- Green screen + some garbage shows for half a second after loading the main .dol
- FMV has a constant stuttering sound and black horizontal banding moving vertically
- Disc 1 correctly recognised as Disc 1

=================================================================================

Batman Begins NTSC/US (IMPROVEMENT)
R253: Sometimes it hangs with a black Screen after level 1 (save between missions just in case).
R174: Seems to load faster, but lacks some of the audio and buzzes while loading.

=============================================================================

Batman - Rise of Sin Tsu NTSC/USA (REGRESSION: NOW BROKEN)
R253:
- FMV has flashing/tearing frames
- Hangs at the loading screen

R174: Works correctly, no flashing/tearing frames, loads just fine.

=============================================================================

Batman - Vengeance NTSC/USA (POSSIBLE REGRESSION, STILL BROKEN)
R253: Fails to find functions to patch.
R094, R174: Hangs at Ubisoft Logo.

=============================================================================

Blood Omen 2 NTSC/US (WORKS+POSSIBLE REGRESSION)
R253: Choppy FMV.
R174: Buzzes while loading but FMVs are a lot better.

=============================================================================

Bloody Roar NTSC/US (IMPROVEMENT: NOW WORKS)
R253: Choppy audio during FMV
R174: Buzzing audio during FMV, but audio is more consistent. Buzzes during load, then "An error has occurred"

=============================================================================

Bomberman Generation NTSC/US (IMPROVEMENT (be sure to defrag the iso) )
R253: Works fine, with just some stuttering during when the Hudson logo appears.
R174: BROKEN.

- Without a disk: asks for the game disk
- With a disk, regardless of "Use a DVD disk for higher compatibility?" and "Stop DVD motor" combinations: "An error has occurred".

R094: Works, with some hissing when it loads.

=================================================================================

Call of Duty 2 - Big Red One NTSC/US (STILL BROKEN+REGRESSION)
R253: Hangs at loading screen with a still "2" immediately after "Licensed by Nintendo".
R174: TO DO
R094: Has stuttering FMVs with buzzing audio. Hangs on a black screen after you start a mission.
sd-boot 0.4: Hangs at loading screen with a spinning "2" immediately after "Licensed by Nintendo".

=============================================================================

Dragon's Lair 3D NTSC/US (IMPROVEMENT: NOW WORKS)
R253: Flickering FMV (with frames tearing).
R174: "Please insert disk"

=============================================================================

Fantastic 4 NTSC/US (IMPROVEMENT: NOW WORKS)
R253: Works.
R174: Asks for disk.

=============================================================================

Home Run King NTSC/US (PARTIAL IMPROVEMENT)
This seems to be a difficult game as it loads constantly.

R253:
- It takes up to 20 seconda to go past the initial MLB white screen.
- During the initial FMV the video freezes every couple of seconds, while the audio keeps playing smoothly.
- The video "between freezes" gets skipped- During the game, you can experience several slowdowns in animations as the game loads.

R174:
- It takes less time to reach the initial FMV.
- The video during the initial FMV stops every second but plays fully without skipping.
- Slowdowns happens during the game as well.
- The game buzzes like hell pretty much everywhere (FMV, menus, game...).

=============================================================================

Hulk NTSC/US (REGRESSION: NOW BROKEN)
R253: Hangs on a GREEN SCREEN. Oh the irony... :)
R174: Needs a disk in the drive (regardless on what you answer to "Use a DVD disk for higher compatibility?") or it will ask for the game disk.
Last edited by boozezela on Sun Jan 26, 2014 12:24 pm, edited 27 times in total.
Gamecube DOL-001 (EUR)
Viper GC Extreme + Cobra 2.1
SD Card Adapter

User avatar
emu_kidid
Site Admin
Posts: 4208
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: Swiss Nightly Build

Postby emu_kidid » Tue Jan 07, 2014 12:00 am

If you've pre-patched a ISO using an older version of Swiss, I don't detect it using the new version, so I would always just use clean ISO files.
Image

boozezela
Posts: 27
Joined: Tue Apr 16, 2013 12:54 am

Re: Swiss Nightly Build

Postby boozezela » Tue Jan 07, 2014 12:07 am

I was curious to see if a pre-patched image (with potentially different patch settings) could also be used.
Gamecube DOL-001 (EUR)
Viper GC Extreme + Cobra 2.1
SD Card Adapter

User avatar
emu_kidid
Site Admin
Posts: 4208
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: Swiss Nightly Build

Postby emu_kidid » Tue Jan 07, 2014 4:51 am

nope, the patches keep undergoing large changes, but that should be over now.
Image

User avatar
AC_Orange
Posts: 398
Joined: Mon Mar 29, 2010 11:36 am

Re: Swiss Nightly Build

Postby AC_Orange » Thu Jan 09, 2014 6:34 am

With Tales I guess I should mention it takes just a little bit longer for the map to load after fights, results in a black screen delay. But the annoying sound problems are gone.

What could be the problem with Baten Kaitos not detecting Disc 1 properly, shows up as Disc 2?

boozezela
Posts: 27
Joined: Tue Apr 16, 2013 12:54 am

Re: Swiss Nightly Build

Postby boozezela » Fri Jan 17, 2014 11:59 pm

Setup:
GameCube PAL + Viper GC
DVD drive - No Disk unless specified otherwise.
SD Gecko Slot B / FAST / 32 GB SDHC
Swiss 0.3 R253 DOL

All games are Version 1.0 and redump.org "compliant" unless specified otherwise.

GAMECUBE GAMES I-Q
=============================================================================

Killer 7 PAL 1.0 (REGRESSION/BROKEN)
Killer 7 NTSC/USA 1.0 (REGRESSION/BROKEN)
Killer 7 NTSC/USA 1.1 (REGRESSION/BROKEN)
R174, R253:
- Without a disk in the drive, use DVD NO: the game asks for Disc 1.
- With a disk in the drive, use DVD NO: the game stops the motor (Viper keeps the motor on), then prints "Checking the game disk", then asks for Disc 1.
- With a disk in the drive, use DVD YES, keep motor on YES: the game stops the motor, then prints "Checking the game disk", then asks for Disc 1.
- With a disk in the drive, use DVD YES, keep motor on NO: the game asks for Disc 1.

Works with R094 and SD-Boot 0.4 (with severe audio buzzing). May hang while changing rooms.

=============================================================================

Luigi's Mansion NTSC/US (REGRESSION)

R253:
- At the title screen, the music stutters for a moment and then it resumes playing
- During the attract screen animation and during the game the music is missing
- After the attract screen animation played once, pressing start will result in a black screen if not done at the right time.
- Sometimes after pressing start at the title screen, some green "garbage" will show on the bottom of the screen for a split second
- The Pikmin movie (accessible from the option menu) exits back to the option screen after the Nintendo logo.

R174/R189: Music works properly. It has the same timing/freeze problem when pressing "Start".

=============================================================================

Mario Golf - Toadstool tour NTSC/USA (POSSIBLE REGRESSION)
R253: Initial FMV: audio stutters, Waluigi animation does not show. Video frozen on frame with Mario&Luigi.
R174: Initial FMV audio stutters, video freezes periodically. Sound somewhat initially garbled during gameplay loading.

=============================================================================

Mario Kart Double Dash NTSC (REGRESSION)

R248: BLACK SCREEN
R249, 250, 251, 253:
- Sound during the initial FMV animation is choppy like it was with earlier Swiss versions.
- Sound during menu transitions is choppy as well.

R094, R174 and R189: The initial FMV visibly flickers/tears but the sound is smooth.

Note that with SD-Boot 0.4 both the FMV animation and sound are smooth.

=============================================================================

Mario Power Tennis v1.01 NTSC/USA (REGRESSION/IMPROVEMENT)
R253:
- Worse: Initial FMV extremely choppy, with video freezes (audio and video manage to stay in sync)
- Better: No flashes during menu animations and transitions

R174:
- Better: Initial FMV is smoother, with less freezes
- Worse: Strange flashes during menu animation and transitions

R094: Freezes after Wario says "Nintendo"
=============================================================================

Mario Superstar Baseball NTSC/USA (IMPROVEMENT: NOW WORKS)
R253: Initial FMV a little slow, but the audio is OK.
R174: Does not work.

=============================================================================

Mega Man: Network Connection NTSC/USA (POSSIBLE REGRESSION)
R253: Stuttering FMV: almost frozen video, extremely stuttering audio. Visible interlace artifacts.
R174: Works a lot better (with some audio stuttering and frame tearing/flashing)

=============================================================================

Mega Man X: Command Mission NTSC/USA (POSSIBLE REGRESSION)
R253: Periodic slowdowns during the initial FMV. Audio is good, some problems due to video interlace.
R174: Video goes slower (but visually seems better), audio stutters.

=============================================================================

Metal Gear Solid NTSC/USA (NO APPARENT CHANGE)
R253 has the same problems as R174:

- A couple of green flashes during Bering Sea FMV
- Green flashes on the main title screen
- Green flashes during gameplay
- Purple flashes during briefing videos (Special/Briefing)

=============================================================================

Mortal Kombat - Deadly Alliance NTSC/US (IMPROVEMENT)
R253: No more audio buzzing. No problems with interlacing.
R174: Buzzes during the initial FMV. The FMV itself has interlacing problems (like if only half of the lines are rendered on screen)

=============================================================================

Mortal Kombat - Deception NTSC/US (NO CHANGE)
R253: Constant flashing/frame tearing during initial FMV and at the title screen
R174: Constant flashing during initial FMV and at the title screen (no tearing). Audio stutters as well.

=============================================================================

Need for Speed - Carbon NTSC/US (REGRESSION: NOW BROKEN)
R253: Hangs after FMV
R174: Works. Patches speed.dol, main.dol. Buzzes when it loads.

=============================================================================

Need for Speed - Underground NTSC/US (IMPROVEMENT)
R253: Works no problems.
R174: Works. Patches speed.dol, speed.elf, main.dol. Buzzes and pauses when it loads.

=============================================================================

Need for Speed - Underground 2 NTSC/US (IMPROVEMENT)
R253: Works no problems.
R174: Works. Patches speed.dol, speed.elf, main.dol. Buzzes and pauses when it loads. Seems to load faster.

=============================================================================

Paper Mario NTSC/USA (IMPROVEMENT)
R253: Works perfectly: audio does not buzz anymore.
R174: Audio buzzes when the game loads.

=============================================================================

Pokemon Box NTSC/USA (REGRESSION: NOW BROKEN)
R253: Green Screen.
R174: Works.

=============================================================================

Pokemon Colosseum NTSC/USA (NO CHANGE: STILL BROKEN)
R253: Green Screen.
R174: Green Screen, then hangs on black screen.

=============================================================================

Pokemon XD NTSC/USA (NO CHANGE: STILL BROKEN)
R253: Green Screen with garbage.
R174: Green Screen with garbage, than hangs on black screen.
Last edited by boozezela on Sun Jan 26, 2014 1:45 am, edited 14 times in total.
Gamecube DOL-001 (EUR)
Viper GC Extreme + Cobra 2.1
SD Card Adapter


Return to “Swiss”

Who is online

Users browsing this forum: No registered users and 2 guests