Swiss Nightly Build

Discuss one of the most feature filled GameCube applications here :)
User avatar
CaptainSodaPop
Posts: 15
Joined: Thu Mar 10, 2016 12:48 am

Re: Swiss Nightly Build

Post by CaptainSodaPop » Wed Apr 27, 2016 6:48 pm

red_dirt wrote:I'm having trouble running backups from my sd card.

1. Nightly Build version: swiss_r342 DOL
2. Hardware: GC PAL-AUS
3. Hardware Configuration: SD Gecko
4. Boot Method: ACTION REPLAY DVD
5. Info: Hangs on a black screen after an ISO is loaded from SWISS. This happens with both the 2gb SD card that i use to boot DOL's and a 16gb SD card that is filled with ISO's. I haven't tried using a disc method yet because i have no gamebits and no DVD's anyway.
I had the problem with old SanDisk 2gb, then I ordered SanDisk Extreme one (32GB) and everything works like a charm.SanDisk Extreme are reliable and verified to work.You must use swap trick of course.
Image
If you wish to add me to the Multitap, PM me please.
red_dirt
Posts: 3
Joined: Wed Apr 27, 2016 3:49 pm

Re: Swiss Nightly Build

Post by red_dirt » Thu Apr 28, 2016 4:18 am

Streetwalker wrote:What game are you trying to launch ? Some games have compatibility issues.
I've tried a selection of most common titles. All clean rips so i don't think it's that.
CaptainSodaPop wrote:I had the problem with old SanDisk 2gb, then I ordered SanDisk Extreme one (32GB) and everything works like a charm.SanDisk Extreme are reliable and verified to work.You must use swap trick of course.
I've tried using both the 2gb sd card that i use to boot dols to boot an iso on swiss with abd a 16gb sdhc card to boot the iso's with. Same issue with both
User avatar
CaptainSodaPop
Posts: 15
Joined: Thu Mar 10, 2016 12:48 am

Re: Swiss Nightly Build

Post by CaptainSodaPop » Thu Apr 28, 2016 7:41 pm

What brand is your SDHC card?
Image
If you wish to add me to the Multitap, PM me please.
red_dirt
Posts: 3
Joined: Wed Apr 27, 2016 3:49 pm

Re: Swiss Nightly Build

Post by red_dirt » Fri Apr 29, 2016 1:14 am

CaptainSodaPop wrote:What brand is your SDHC card?
Both sandisk.
Nukatha
Posts: 83
Joined: Thu Aug 25, 2011 2:22 am

Re: Swiss Nightly Build

Post by Nukatha » Mon May 16, 2016 3:24 am

I don't have any idea behind the technicalities of it, but Pokemon Box (NTSC-U) is still broken, and has been since v174 or so.
But my old copy of Swiss 0.1 (v62) was able to load it just fine.
User avatar
Sierron
Posts: 160
Joined: Mon Apr 18, 2016 11:33 pm
Location: Germany

Re: Swiss Nightly Build

Post by Sierron » Wed May 25, 2016 4:31 pm

Just tried swiss r342 out on both my japanese and pal gamecubes. So far things work great.

On the japanese gamecubes (both NTSC rev. 1.0 and 1.1) the memorycard (for jap consoles formated) cannot be read. Something along invalid device inserted.

On the pal gamecube (PAL rev. 1.0) my GC USB Memorycard Adapter which is (1023 blocks) gets detected as following:
Image
Attachments
20160525-182939.JPG
(24.84 KiB) Not downloaded yet
Own a couple PAL and JPN cubes. And three BBAs. Homeland and PSO I/II.
User avatar
emu_kidid
Site Admin
Posts: 4576
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: Swiss Nightly Build

Post by emu_kidid » Wed May 25, 2016 11:50 pm

Yep, memory card stuff is being totally redone at the moment, all that will be fixed :)
Image
User avatar
emu_kidid
Site Admin
Posts: 4576
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: Swiss Nightly Build

Post by emu_kidid » Tue Jun 07, 2016 2:14 pm

r363 posted, new build system is in place so I can build it all automatically now. I'll make a page or something that will list all nightly builds in the coming days/weeks.
Image
Xaranar
Posts: 109
Joined: Tue Sep 22, 2015 12:50 pm

Re: Swiss Nightly Build

Post by Xaranar » Tue Jun 07, 2016 7:27 pm

What the hell is "480sf"?
User avatar
Streetwalker
Posts: 1736
Joined: Mon Dec 30, 2013 7:50 am
Location: Israel

Re: Swiss Nightly Build

Post by Streetwalker » Tue Jun 07, 2016 11:35 pm

https://en.wikipedia.org/wiki/Progressi ... nted_frame

Swiss could use a manual at this point. :P
retango
Posts: 7
Joined: Sun Aug 23, 2015 4:18 pm

Re: Swiss Nightly Build

Post by retango » Thu Jun 09, 2016 11:28 pm

Thanks for the new build!
MR.JOE
Posts: 9
Joined: Fri Jun 10, 2016 10:01 am

Re: Swiss Nightly Build

Post by MR.JOE » Fri Jun 10, 2016 10:22 am

What is the current resolution SWISS uses to render it's games? E.g. for 480i: 720x480 or 640x480? I'm wondering because with Nintendont we got the option to switch between 720 and 640 making it more convenient, especially for widescreen games, to use the full native resolution.
E.g. Using 720 screen width with 20XTE 4.05 (Melee mod) it's possible to use the "true widescreen" ingame feature to get proper 16:9 AR.

edit: regarding sf-resolution: Is there any downside (e.g. framerate/refreshrate) to using this instead of progressive resolution?
User avatar
RazorX2014
Posts: 165
Joined: Sun Feb 23, 2014 6:50 pm

Re: Swiss Nightly Build

Post by RazorX2014 » Sat Jun 11, 2016 6:35 pm

Edit:
Solved
Last edited by RazorX2014 on Sat Jun 11, 2016 7:43 pm, edited 1 time in total.
User avatar
tesla246
Posts: 118
Joined: Tue Dec 11, 2012 1:48 pm

Re: Swiss Nightly Build

Post by tesla246 » Sat Jun 11, 2016 7:18 pm

Autoboot solution has been discovered by andre104623 and works with every sd-card. If I remember correctly a ''lid switch pin'' of the megadrive board need to be connected to ground, and then connected to the other ''lid switch pin''; in short basically ground between the 2 pins when soldering them together.

Here is the thread: viewtopic.php?f=26&t=3046&hilit=autoboot. Enjoy!
Dream mod: RAM expansion for serial port 2 with wifi, bluetooth and usb port :shock:
Favourite mod: Wasp fusion autoboot with flashed swiss. :D
Eagerly awaiting a normal, form-factor wise, wireless controller with rumble. :)
User avatar
RazorX2014
Posts: 165
Joined: Sun Feb 23, 2014 6:50 pm

Re: Swiss Nightly Build

Post by RazorX2014 » Sat Jun 11, 2016 7:25 pm

tesla246 wrote:Autoboot solution has been discovered by andre104623 and works with every sd-card. If I remember correctly a ''lid switch pin'' of the megadrive board need to be connected to ground, and then connected to the other ''lid switch pin''; in short basically ground between the 2 pins when soldering them together.

Here is the thread: viewtopic.php?f=26&t=3046&hilit=autoboot. Enjoy!
oh nice thats pretty easy i will try that in a few mins

Edit:
thanks that worked
User avatar
Joybit
Posts: 13
Joined: Mon Jul 21, 2014 8:44 pm

Re: Swiss Nightly Build

Post by Joybit » Sun Jun 12, 2016 9:00 pm

1. Nightly Build version:
swiss_r364 dol and wkf

2. Hardware:
Both units: GC NTSC-J

3. Hardware Configuration:
Unit 1: Wasp Via Megadrive V3, BBA, GBP, SD Gecko in slot A, Component Cables, One official controller in the first port, Region Switch
Unit 2: DVD w/ XenoGC, BBA, GBP, SD Gecko in slot A, Component Cables, One official controller in the first port, Region Switch

4. Boot Method:
Unit 1: WKF and SD Gecko
Unit 2: SD Gecko via DVD

5. Info:
From WKF: Boots almost instantly into a DSI Exception
From SD Gecko: A brief wait, may be able to scroll through the SD card a bit, but then an almost instant DSI Exception

My current DVD for Unit 2 is r334.

EDIT: I have tried booting both units without the BBA and there was no DSI exception. Having just the GBP was fine.
EDIT 2: I also tried booting with the BBA installed but no cable plugged in and everything was fine again. I guess it's not handling network initialization well?
User avatar
emu_kidid
Site Admin
Posts: 4576
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: Swiss Nightly Build

Post by emu_kidid » Sun Jun 12, 2016 11:45 pm

Right, I'll fix that in the next nightly. Thanks for spotting it!
Image
User avatar
RazorX2014
Posts: 165
Joined: Sun Feb 23, 2014 6:50 pm

Re: Swiss Nightly Build

Post by RazorX2014 » Tue Jun 14, 2016 2:01 am

now that ive fixed the autoboot by grounding the lid switch was there ever a fix for the audio streaming issue with the megadrive v3 thanks
User avatar
megalomaniac
Posts: 2480
Joined: Sun Aug 21, 2011 5:33 am
Location: Drunk in Texas
Contact:

Re: Swiss Nightly Build

Post by megalomaniac » Tue Jun 14, 2016 5:24 am

there is no audio streaming issue with MEGAdrive V3
it passes all the commands thru
emu_kidid wrote: beer is like WD40 for megalomaniac's brain, gets the gears moving
>>> BadAssConsoles.com <<<

Image Image Image
User avatar
RazorX2014
Posts: 165
Joined: Sun Feb 23, 2014 6:50 pm

Re: Swiss Nightly Build

Post by RazorX2014 » Tue Jun 14, 2016 6:47 am

megalomaniac wrote:there is no audio streaming issue with MEGAdrive V3
it passes all the commands thru
I guess issue is the wrong word I meant for games like eternal darkness when the intro comes on I just get crackling instead of the voice speaking
User avatar
andzlay
Posts: 437
Joined: Thu Jul 08, 2010 12:53 am
Location: Germany

Re: Swiss Nightly Build

Post by andzlay » Tue Jun 14, 2016 10:23 am

Audio streaming from a drive replacement wont work. You can use an original drive with a megadrive v3 to have working audio streaming.
User avatar
emu_kidid
Site Admin
Posts: 4576
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: Swiss Nightly Build

Post by emu_kidid » Wed Jun 15, 2016 2:53 pm

Joybit wrote: EDIT: I have tried booting both units without the BBA and there was no DSI exception. Having just the GBP was fine.
EDIT 2: I also tried booting with the BBA installed but no cable plugged in and everything was fine again. I guess it's not handling network initialization well?
New build posted, please try again. Device detection speed should also be improved in this version.
Image
User avatar
RazorX2014
Posts: 165
Joined: Sun Feb 23, 2014 6:50 pm

Re: Swiss Nightly Build

Post by RazorX2014 » Wed Jun 15, 2016 2:59 pm

emu_kidid wrote:
Joybit wrote: EDIT: I have tried booting both units without the BBA and there was no DSI exception. Having just the GBP was fine.
EDIT 2: I also tried booting with the BBA installed but no cable plugged in and everything was fine again. I guess it's not handling network initialization well?
New build posted, please try again. Device detection speed should also be improved in this version.
when you gonna drop the r and change to v lol
User avatar
emu_kidid
Site Admin
Posts: 4576
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: Swiss Nightly Build

Post by emu_kidid » Wed Jun 15, 2016 3:21 pm

RazorX2014 wrote:
emu_kidid wrote: New build posted, please try again. Device detection speed should also be improved in this version.
when you gonna drop the r and change to v lol
Huh?
Image
User avatar
RazorX2014
Posts: 165
Joined: Sun Feb 23, 2014 6:50 pm

Re: Swiss Nightly Build

Post by RazorX2014 » Wed Jun 15, 2016 3:31 pm

emu_kidid wrote:
RazorX2014 wrote:
emu_kidid wrote: New build posted, please try again. Device detection speed should also be improved in this version.
when you gonna drop the r and change to v lol
Huh?
i was just joking asking when it changes from revision to version
Post Reply