Swiss Nightly Build

Discuss one of the most feature filled GameCube applications here :)
User avatar
Andross89
Posts: 106
Joined: Sun May 25, 2014 10:02 pm

Re: Swiss Nightly Build

Post by Andross89 » Mon Jul 31, 2017 7:51 pm

I am using version 386 still because the Cheats function does not appear when I press Y. There have been several updates but the problem continues. Any solution?
User avatar
emu_kidid
Site Admin
Posts: 4376
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: Swiss Nightly Build

Post by emu_kidid » Mon Jul 31, 2017 10:21 pm

Andross89 wrote:I am using version 386 still because the Cheats function does not appear when I press Y. There have been several updates but the problem continues. Any solution?
I haven't noticed, does it just say no cheats found? What device (s) are you using?
Image
boktai1000
Posts: 33
Joined: Tue Jul 12, 2016 3:01 am

Re: Swiss Nightly Build

Post by boktai1000 » Tue Aug 01, 2017 3:05 am

I feel like I've just been posting issues a lot lately, and because of that- my apologies. But I've had a really hard time with game compatibility on my 2 GB and 4GB non-SDHC card. For example I can get some games to work just fine like Luigis Mansion and Harvest Moon - it seems like smaller sized games or less intensive games work best on the slower cards, but when it comes to something like Soul Calibur II and even Mario Party 5 I just seem to have better compatibility with a faster card.

I would prefer if possible to not card swap to play some of the games, even if it means only keeping one game at a time on my SD Card. Is this a known issue, and if so is there anything that can be done? Would it be best for me to document every game I have issues somewhere to diagnose? I've also tried shrinking some of the games to see if that makes a difference and from what I can tell if a game won't load on my non-SDHC card it doesn't matter if it's shrunk or not.

For reference, I use two types of non-SDHC cards for testing. One of them is the official SanDisk for Wii 2 GB SD Card, and the other is a TOPRAM 4GB non-SHDC Card.

Any tips or ideas on working with a non-SDHC Card? Thanks!
User avatar
emu_kidid
Site Admin
Posts: 4376
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: Swiss Nightly Build

Post by emu_kidid » Tue Aug 01, 2017 6:49 am

boktai1000 wrote: Any tips or ideas on working with a non-SDHC Card? Thanks!
Tell me more about your setup, particularly how you're booting Swiss? I worry that the Action replay/SDML disc inits the SD card and leaves it in some incompatible state, so could you try the following and report back if you're using Action Replay or SDML to boot Swiss:

If you remove the entire SD Gecko and plug it back in with the same smaller non-SDHC card(s), is compatibility the same or better than if you hadn't unplugged & plugged the device in again?
Image
User avatar
Andross89
Posts: 106
Joined: Sun May 25, 2014 10:02 pm

Re: Swiss Nightly Build

Post by Andross89 » Tue Aug 01, 2017 10:03 am

emu_kidid wrote:
Andross89 wrote:I am using version 386 still because the Cheats function does not appear when I press Y. There have been several updates but the problem continues. Any solution?
I haven't noticed, does it just say no cheats found? What device (s) are you using?
I'm starting with Qoob and I load the ISOs with SD Gecko. When I press Y, nothing happens. It looks like you removed this function. Another thing: some codes do not work or need to be turned off at certain times because they can freeze the game. This has never happened to the AR engine. Can you check that everything is all right? Please.

One more thing: The information on space used, total, etc. are like the first time ever. Example: the first time I used Swiss, my card had 1.69gb free. Now, I have 7.01gb free but it always says 1.69gb no matter what I do. It's no big deal, I'm just reporting.
boktai1000
Posts: 33
Joined: Tue Jul 12, 2016 3:01 am

Re: Swiss Nightly Build

Post by boktai1000 » Tue Aug 01, 2017 4:41 pm

emu_kidid wrote:
boktai1000 wrote: Any tips or ideas on working with a non-SDHC Card? Thanks!
Tell me more about your setup, particularly how you're booting Swiss? I worry that the Action replay/SDML disc inits the SD card and leaves it in some incompatible state, so could you try the following and report back if you're using Action Replay or SDML to boot Swiss:

If you remove the entire SD Gecko and plug it back in with the same smaller non-SDHC card(s), is compatibility the same or better than if you hadn't unplugged & plugged the device in again?
No problem! My setup:
  • NTSC Gamecube DOL-001 (Digital Component Out)
    Broadband Adapter
    GameBoy Player
    Component Video Cables
  • Action Replay SD Media Launcher (the updated/revised disc)
    Two different SD "Geckos" - Stock SDML as well as the grey one from Ebay that looks like a memory card. I've tried both - my SDML one actually works great with SDHC cards, as does the grey one.
    SD Cards- SanDisk for Wii 2GB SD, TOPRAM 4GB SD (non-SDHC), Patriot LX Series 32GB SDHC. To clarify both regular SD cards work fine with launching Swiss itself as well as misc homebrew like emulators, gbi, gcmm, etc
I am launching Swiss r418 compressed DOL via "autolaunch.dol" at the root of my SD Card, and have ISOs in a folder called "games" in the root of my SD Card. I'll try removing the SD adapter and trying it again, but I would think that hardware limitations on the Gecko would prevent SDHC cards from reading faster that would enable greater game compatibility - so it's a bit confusing to me why those cards are working better. Some games just work great too on my regular SD Cards- like Mobile Suit Gundam vs Zeta Gundam, Luigi's Mansion. As does Homebrew and Emulation - it's just launching ISOs on my SDs that is so quirky, and I've tried every combination of various SWISS versions, using SDML gecko vs grey gecko, using SanDisk SD (I have two different ones from two separate purchase) as well as TOPRAM 4GB (which I also have two of, I have an identical setup that I use for testing so having two of each makes it easier). I get results that match up more in like with the wiki when using my SDHC card that I've noticed - for example I can't launch Animal Crossing, Melee, Double Dash, Mario Party 5, Soul Calibur II to name a few that just don't work on SD but work just fine on my SDHC after I insert it.

It's just strange to me that the SDHC card has greater "compatibility" with my configuration for whatever reason, and I've checked my SD cards to make sure they aren't "fakes" - they aren't - pass all the tests with two separate tools and have all the advertised but limited amount of space as they should! Ultimately my goal and why I'd like to make 2GB or 4GB work - even if it just means having one game at a time on them due to limited space, is because I'd prefer not to have to get up and reinsert the Gecko or SD Card - so while I'm willing to do it for testing it's not part of what I'm trying to achieve with this configuration. ;)

Update: after testing unmounting and then remounting the same SD Card (4GB non-SDHC) it doesn't seem to have any sort of better compatibility, same issues exist.
User avatar
Andross89
Posts: 106
Joined: Sun May 25, 2014 10:02 pm

Re: Swiss Nightly Build

Post by Andross89 » Mon Aug 14, 2017 10:10 am

I tested version v0.4r420 and the cheat window did not appear too. Is it possible to implement the option to hide system files in version 387? Thank you.
User avatar
emu_kidid
Site Admin
Posts: 4376
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: Swiss Nightly Build

Post by emu_kidid » Mon Aug 14, 2017 1:02 pm

Andross89 wrote:I tested version v0.4r420 and the cheat window did not appear too. Is it possible to implement the option to hide system files in version 387? Thank you.
Try v0.4r422, I actually fixed it this time.
Image
User avatar
Andross89
Posts: 106
Joined: Sun May 25, 2014 10:02 pm

Re: Swiss Nightly Build

Post by Andross89 » Mon Aug 14, 2017 9:39 pm

emu_kidid wrote:
Andross89 wrote:I tested version v0.4r420 and the cheat window did not appear too. Is it possible to implement the option to hide system files in version 387? Thank you.
Try v0.4r422, I actually fixed it this time.
It worked. Thank you so much.
User avatar
emu_kidid
Site Admin
Posts: 4376
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: Swiss Nightly Build

Post by emu_kidid » Mon Aug 14, 2017 10:32 pm

Andross89 wrote: It worked. Thank you so much.
Great!
boktai1000 wrote: Update: after testing unmounting and then remounting the same SD Card (4GB non-SDHC) it doesn't seem to have any sort of better compatibility, same issues exist.
It's those pesky non-standard 4GB SDHC cards, I'm not going to bother trying to support them, they can be all kinds of crazy.
Image
boktai1000
Posts: 33
Joined: Tue Jul 12, 2016 3:01 am

Re: Swiss Nightly Build

Post by boktai1000 » Tue Aug 15, 2017 2:00 am

emu_kidid wrote:
Andross89 wrote: It worked. Thank you so much.
Great!
boktai1000 wrote: Update: after testing unmounting and then remounting the same SD Card (4GB non-SDHC) it doesn't seem to have any sort of better compatibility, same issues exist.
It's those pesky non-standard 4GB SDHC cards, I'm not going to bother trying to support them, they can be all kinds of crazy.
The same thing happens on my 2GB non-SDHC card though, I guess that's the point I'm trying to make. Is there a reason why that might be? What information can I get you that might be helpful for you (or myself) to diagnose - if there is any sort of debugging I can enable I would gladly do it, not sure if that's a thing. But anyways let me know!
User avatar
emu_kidid
Site Admin
Posts: 4376
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: Swiss Nightly Build

Post by emu_kidid » Tue Aug 15, 2017 3:51 am

boktai1000 wrote:The same thing happens on my 2GB non-SDHC card though, I guess that's the point I'm trying to make. Is there a reason why that might be? What information can I get you that might be helpful for you (or myself) to diagnose - if there is any sort of debugging I can enable I would gladly do it, not sure if that's a thing. But anyways let me know!
I'll replicate your setup as best I can and see if I can also see the problem but it might just be that your card constantly needs to retry sector reads. The in game code in Swiss doesn't verify reads so that could be the problem.
Image
boktai1000
Posts: 33
Joined: Tue Jul 12, 2016 3:01 am

Re: Swiss Nightly Build

Post by boktai1000 » Tue Aug 15, 2017 4:02 am

emu_kidid wrote:
boktai1000 wrote:The same thing happens on my 2GB non-SDHC card though, I guess that's the point I'm trying to make. Is there a reason why that might be? What information can I get you that might be helpful for you (or myself) to diagnose - if there is any sort of debugging I can enable I would gladly do it, not sure if that's a thing. But anyways let me know!
I'll replicate your setup as best I can and see if I can also see the problem but it might just be that your card constantly needs to retry sector reads. The in game code in Swiss doesn't verify reads so that could be the problem.
Appreciate it emu_kidid. I just feel like I can't be the only user out there going for a single SD Card setup whether it be 2GB or 4GB and there's only many so many options to try. If there's a known "good" 2GB or 4GB card that has great compatibility and is reputable / easy to procure I'd switch to that as well if that was the answer, but its strange that all four of my non-SDHC cards all exhibit this behavior.
User avatar
CaptainSodaPop
Posts: 15
Joined: Thu Mar 10, 2016 12:48 am

Re: Swiss Nightly Build

Post by CaptainSodaPop » Fri Aug 18, 2017 11:14 pm

Last release with audio streaming fixes is a big improvement! Super Monkey Ball which would freeze for me before (with audio streaming) now works perfectly. I need to test Geist as well. I had problems with it freezing sometimes. I will report the results. :)
Image
If you wish to add me to the Multitap, PM me please.
User avatar
turnerl
Posts: 54
Joined: Sat Jul 03, 2010 10:46 am
Location: Australia

Re: Swiss Nightly Build

Post by turnerl » Mon Aug 21, 2017 7:07 am

Thanks for all your work! Really weird, tried to flash the two most recent builds to the qoob pro and it just freezes. I've always flashed the compressed dol with out any issues in the past?
User avatar
turnerl
Posts: 54
Joined: Sat Jul 03, 2010 10:46 am
Location: Australia

Re: Swiss Nightly Build

Post by turnerl » Mon Aug 21, 2017 8:20 am

I should have looked a bit harder! viewtopic.php?t=3690

All good now!
boktai1000
Posts: 33
Joined: Tue Jul 12, 2016 3:01 am

Re: Swiss Nightly Build

Post by boktai1000 » Fri Sep 15, 2017 5:00 pm

emu_kidid wrote:
boktai1000 wrote:The same thing happens on my 2GB non-SDHC card though, I guess that's the point I'm trying to make. Is there a reason why that might be? What information can I get you that might be helpful for you (or myself) to diagnose - if there is any sort of debugging I can enable I would gladly do it, not sure if that's a thing. But anyways let me know!
I'll replicate your setup as best I can and see if I can also see the problem but it might just be that your card constantly needs to retry sector reads. The in game code in Swiss doesn't verify reads so that could be the problem.
Hey emu_kidid, have you had a chance to replicate / attempt to reproduce this? If you have any other ideas on information I can provide or things to try to make a non-SDHC setup work it would be greatly appreciated, or if anyone running a similar config wants to chime that would be excellent.

Thanks everyone! :D
User avatar
Andross89
Posts: 106
Joined: Sun May 25, 2014 10:02 pm

Re: Swiss Nightly Build

Post by Andross89 » Fri Sep 15, 2017 7:08 pm

boktai1000 wrote:
emu_kidid wrote:
boktai1000 wrote:The same thing happens on my 2GB non-SDHC card though, I guess that's the point I'm trying to make. Is there a reason why that might be? What information can I get you that might be helpful for you (or myself) to diagnose - if there is any sort of debugging I can enable I would gladly do it, not sure if that's a thing. But anyways let me know!
I'll replicate your setup as best I can and see if I can also see the problem but it might just be that your card constantly needs to retry sector reads. The in game code in Swiss doesn't verify reads so that could be the problem.
Hey emu_kidid, have you had a chance to replicate / attempt to reproduce this? If you have any other ideas on information I can provide or things to try to make a non-SDHC setup work it would be greatly appreciated, or if anyone running a similar config wants to chime that would be excellent.

Thanks everyone! :D
Try version 376. I have 95 games working with this version.
TABULLO
Posts: 2
Joined: Thu Sep 28, 2017 12:30 am

Re: Swiss Nightly Build

Post by TABULLO » Thu Sep 28, 2017 1:07 am

Thanks for all the work, swiss is great, I tested some games on r426 and some in r430 and added a couple to the wiki but I just wanted to mention that the Adata 32 GB class 10 cards freezes with every game I tried EXCEPT for Bloody roar (NTSC trimmed iso), so I wouldn't add it to the Table as either working or not working since there might be other games that work, it works better under "fast" than under "compatible" by the way.

I load swiss via smash bros exploit, the SD that I own that works is a Kingston 8 GB class 4 and using r430 gci these work:
Harvest moon; Magical melody
SNKvsCapcom 2works fine either trimmed or full
Pikmin 2 NTSC works great (long loading times but audio and gameplay are fine)
Eternal Darkness PAL freezes after the First logo, both full and trimmed
BMXXX works but you have to manually choose to save on slot A in the options menu, All videos are broken (stutter).
Bloody roar works great in gameplay but all videos lag, some stutter or short noises in loading screens
Wario World PAL works but the music is all over the place, pausing it fixes it when it dissapears or keeps looping a short bit.
1080º Avalanche with some sound stutters
Hunter the reckoning Works perfect, the wiki mentioned audio an video not synced in cutscenes, which is now fixed apparently

Loading Via DVD:
Pikmin 1 NTSC: gives error after safety warning (the disc apparently it works on a GC with modchip)
Resident evil 0 disc 1 NTSC: The wiki says working in color yellow but doesnt specify anything but I tried it and it loads fast, absolutely no stutter in cutscenes or during gameplay, I only tested around an hour but saw no problems.

The games that I tried on the Adata SD card other than bloody roar all froze after loading logos or in the first menu, but in case someone wants to know they were: Def JAm, Pikmin 2, Hunter: The reckoning, Time Splitters 2, eternal darkness, Harvest moon Magical Melody, BMXXX (freezes in the character select), snkvscapcom 2, 1080º Avalanche, Gladius, Haunted Mansion, DDR Mario Mix. Damn card doesn't even work with mplayer.
TABULLO
Posts: 2
Joined: Thu Sep 28, 2017 12:30 am

Re: Swiss Nightly Build

Post by TABULLO » Thu Sep 28, 2017 10:32 am

I have now found that the same card that only works with bloody roar also works with PIKMIN 2 and it works better and faster than the other one, so I'm confused.
User avatar
CaptainSodaPop
Posts: 15
Joined: Thu Mar 10, 2016 12:48 am

Re: Swiss Nightly Build

Post by CaptainSodaPop » Thu Sep 28, 2017 4:14 pm

Pokémons are working now. <3 Always wanted to play those. :P

Thanks to everyone who is responsible. :D
Image
If you wish to add me to the Multitap, PM me please.
User avatar
emu_kidid
Site Admin
Posts: 4376
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: Swiss Nightly Build

Post by emu_kidid » Thu Sep 28, 2017 11:41 pm

CaptainSodaPop wrote:Pokémons are working now. <3 Always wanted to play those. :P

Thanks to everyone who is responsible. :D
Glad to hear they're at least booting now, finally.
Image
FIX94
Posts: 54
Joined: Fri Aug 05, 2011 1:55 pm

Re: Swiss Nightly Build

Post by FIX94 » Sat Sep 30, 2017 8:14 pm

good to hear that patch update I've made didnt just help out nintendont.
boktai1000
Posts: 33
Joined: Tue Jul 12, 2016 3:01 am

Re: Swiss Nightly Build

Post by boktai1000 » Sun Oct 01, 2017 1:38 am

Andross89 wrote:
boktai1000 wrote:
emu_kidid wrote:
I'll replicate your setup as best I can and see if I can also see the problem but it might just be that your card constantly needs to retry sector reads. The in game code in Swiss doesn't verify reads so that could be the problem.
Hey emu_kidid, have you had a chance to replicate / attempt to reproduce this? If you have any other ideas on information I can provide or things to try to make a non-SDHC setup work it would be greatly appreciated, or if anyone running a similar config wants to chime that would be excellent.

Thanks everyone! :D
Try version 376. I have 95 games working with this version.
Nada unfortunately. Maybe this will help troubleshoot, but occasionally when I look at the swiss .dol on my SD Card, it will report 0kb in Windows... like something is corrupting it? My best guess is that something with SWISS is corrupting the SD Cards contents... I've tried two different SD Geckos (Action Replay and the grey looking one).

Is there any way for me to debug this output somehow? I'm fairly technical and I'm a bit flabergasted that almost every combination of different SWISS versions + variations of formatting the SD Card + Different SD Cards + Different SD Geckos always results in issues for my setup. My GameCube is decked out with a Broadband Adapter + GameBoy Player + Component Cables so I feel like I might be introducing a lot of variables, but I can't imagine I'm the only one doing this.
User avatar
Andross89
Posts: 106
Joined: Sun May 25, 2014 10:02 pm

Re: Swiss Nightly Build

Post by Andross89 » Sun Oct 01, 2017 2:11 pm

boktai1000 wrote:
Nada unfortunately. Maybe this will help troubleshoot, but occasionally when I look at the swiss .dol on my SD Card, it will report 0kb in Windows... like something is corrupting it? My best guess is that something with SWISS is corrupting the SD Cards contents... I've tried two different SD Geckos (Action Replay and the grey looking one).
I think it must be your SD card. Have you tried filling it with multiple files and verifying that everything was recorded correctly? Depending on the size of the card, it can be a quick test. So far, the latest version of Swiss is working perfectly for me.
Post Reply