Submit Compatibility Issues Here

Discuss one of the most feature filled GameCube applications here :)
User avatar
emu_kidid
Site Admin
Posts: 4373
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Submit Compatibility Issues Here

Post by emu_kidid » Wed Dec 23, 2015 2:50 am

Do not post working games in here, only broken.

Things to do before submitting a report:
1. If it's a Black Screen on boot issue, try another SD card
2. If the game crashes somewhere repeatedly, verify the game is a valid dump (redump.org) then try formatting the SD card and placing the ISO as the only file on there.
3. If the game crashes at a certain point, please submit a save file with instructions on where the crash occurs.
4. Make sure you're using a GameCube, I don't support Wii due to the hacked nature of how some users run Swiss.

Please use the format below:
Game
Region
Medium
Swiss version (revision number and git version if possible)
Optional save file (.gci)
Optional on screen crash dump screenshot
USBGecko log output
Detailed report of the issue
Image
User avatar
emu_kidid
Site Admin
Posts: 4373
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: Submit Compatibility Issues Here

Post by emu_kidid » Wed Dec 23, 2015 2:56 am

I'll start this off with 2 reported by StreetWalker

Game
Metroid Prime
Region
NTSC-U
Medium
SD Gecko
Swiss version
334 (9a6e1ac)
Optional save file (.gci)
01-GM8E-MetroidPrime A_00.gci
Detailed report of the issue
If you watch this video and open the door shown at 3:54, the game hard crashes.

Game
F-Zero GX
Region
NTSC-U
Medium
SD Gecko
Swiss version
334 (9a6e1ac)
Detailed report of the issue
Green screen on boot, hangs after GX init in USBGecko log, no exception thrown.
Attachments
9d22.zip
(3.8 KiB) Downloaded 158 times
Image
cpjarrod
Posts: 20
Joined: Sun Jan 03, 2016 11:02 am

Game Crash - Swiss

Post by cpjarrod » Sun Jan 03, 2016 11:10 am

So I'm booting my gamecube iso's on the gamecube through swiss latest nightly revision.
First problem is with Mario Football randomly while playing the game will just freeze/crash and you'll just hear a loud buzzing noise until you turn the gamecube off. This happens pretty frequently and I'm wondering what is causing this? Another problem is that when I load the iso for it, I get a message saying failed to find necessary functions for patching. This happens with the us version and the pal/euro version says the exact same thing but with the pal/euro version the color is funny and is all blue for the red color shades, pretty much everything is blue.

Second problem is with need for speed carbon, I'm really keen to play this but the game just freezes/crashes after the first intro screens before I get to the main menu.

Would be great to get this fixed. Thanks.
cpjarrod
Posts: 20
Joined: Sun Jan 03, 2016 11:02 am

Re: Submit Compatibility Issues Here

Post by cpjarrod » Thu Jan 07, 2016 7:49 am

Just adding to the compatibility issues for latest swiss nightly build,

Need for speed carbon doesnt work on the latest swiss nightly build but works on swiss 0.3 rev 174. It crashes before the loading screen after the intro video.

Spyro A Heros Tail crashes at the nintendo logo screen but also works on swiss 0.3.

Mario Strikers crashes during the gameplay, you get an audio hickup and then loud buzzing + frozen game. And doesn't work on older versions of swiss, says fragmented.

Is there a way around it?
Thanks emu_kid
User avatar
Doomkeks
Posts: 27
Joined: Mon Dec 28, 2015 6:51 pm

Re: Submit Compatibility Issues Here

Post by Doomkeks » Thu Jan 07, 2016 8:16 pm

Game
Cel Damage
Region
PAL
Medium
SD Gecko
Swiss version
334
Detailed report of the issue
Starts normally and the intro sequence runs through just like it should. Game crashes after the intro sequence, cube restarts.
Iso hash verified with redump.org. I tried both full size iso and stripped iso.
Starting SWISS of a DVD, Viper Chip with Cobra 1.6
Cube: PAL 1.0

EDIT:
Same issue with my othter XenoGC Cube

EDIT #2:
Same thing with booting from WASP Chip SD (Swiss build 334 on WASP).
Interesting: Same issue as mentioned abover with full size Iso. With a trimmed iso though, I can almost make it to the next menu but it freezes there.
I'm guessing it is a audio stream issue, because music would set in in the moment where it crashes. (It doesn't matter if I disable audio streaming in the game boot settings).
Nosen
Posts: 9
Joined: Tue Jun 16, 2015 12:06 am

Re: Submit Compatibility Issues Here

Post by Nosen » Thu Mar 10, 2016 9:25 pm

Zelda Collector's Edition (U)
PAL Console with component cable
SDML
rev 342
Trying to force 480p results in 'Too many patches' error.

I love Swiss to death fyi
User avatar
CaptainSodaPop
Posts: 15
Joined: Thu Mar 10, 2016 12:48 am

Re: Submit Compatibility Issues Here

Post by CaptainSodaPop » Sun Apr 03, 2016 8:48 am

F-Zero GX (Tried both PAL and NTSC)
PAL Console with component cable
SDML
rev 342
Sandisk Micro SDHC Extreme 32GB + SDML adapter
Loading game (without touching anything) gives me a green screen freeze.Tried forcing other video modes, same thing.It's worth adding that I tried about 20 games, and they all work perfect or near perfect except F-Zero GX which won't even load.I thought it was bad iso but I tried 2 different NTSC and one PAL and all give the same problem.
Image
If you wish to add me to the Multitap, PM me please.
cpjarrod
Posts: 20
Joined: Sun Jan 03, 2016 11:02 am

Re: Submit Compatibility Issues Here

Post by cpjarrod » Sun Apr 03, 2016 2:29 pm

Still issues with need for speed and mario strikers from what I have tested so far. Launched through sd card. Need for speed freezes and black screen before home menu, mario strikers freezes with buzzing and audio issues at random points while playing and with spyro heros tail its got some patchy freezing for split seconds throughout gameplay.
User avatar
teconmoon
Posts: 41
Joined: Wed May 18, 2016 3:18 pm

Re: Submit Compatibility Issues Here

Post by teconmoon » Wed May 25, 2016 5:37 am

Game
Mario Party 4
Region
USA
Medium
SD Gecko
Swiss version
Swiss r342
Detailed report of the issue
The game doesn't crash, but during party mode after a minigame, a (seemingly) random player will jump to 999 coins. Verified that this doesn't happen when using Swiss to boot the Mario Party 4 disk, only when booting the game from the SD Gecko (Slot A or B didn't make a difference)
User avatar
emu_kidid
Site Admin
Posts: 4373
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: Submit Compatibility Issues Here

Post by emu_kidid » Wed May 25, 2016 11:51 pm

I'll showcase that one as one of the nicer bugs :P

Edit: But seriously I'll look into it, it's probably caused by the game reporting that it requires audio streaming and then Swiss taking some memory away from it.
Image
User avatar
teconmoon
Posts: 41
Joined: Wed May 18, 2016 3:18 pm

Re: Submit Compatibility Issues Here

Post by teconmoon » Thu May 26, 2016 1:22 am

Thanks! Wasn't sure if it belonged here or if it was better to report it on GitHub, or what the best way was to gather actually relevant information haha
User avatar
emu_kidid
Site Admin
Posts: 4373
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: Submit Compatibility Issues Here

Post by emu_kidid » Thu May 26, 2016 2:18 pm

teconmoon wrote:Thanks! Wasn't sure if it belonged here or if it was better to report it on GitHub, or what the best way was to gather actually relevant information haha
Can you try this build and let me know if the issue is gone?
Attachments
swiss-lz.zip
(968.02 KiB) Downloaded 125 times
Image
User avatar
teconmoon
Posts: 41
Joined: Wed May 18, 2016 3:18 pm

Re: Submit Compatibility Issues Here

Post by teconmoon » Sat May 28, 2016 1:42 am

emu_kidid wrote:Can you try this build and let me know if the issue is gone?
Unfortunately the problem still persists even with the new build. I tried disabling audio streaming, but that didn't help either (not sure why I thought it would lol)
User avatar
TALANTO
Posts: 43
Joined: Sun Jun 01, 2014 10:41 am
Contact:

Re: Submit Compatibility Issues Here

Post by TALANTO » Sun Jun 05, 2016 4:43 pm

Game The Legend of Zelda - Twilight Princess (redump.org verified, compressed with DiskEX-v0.9)
Region NTSC-U
Medium SD Gecko
Swiss version r363, r342
Optional save file (.gci) n/a
Optional on screen crash dump screenshot n/a
USBGecko log output n/a
Detailed report of the issue
- the game sometimes runs in blue colours after selecting progressive mode from the game menu
- forcing 480p from swiss seems to work every time

Game Soul Calibur II (redump.org verified, compressed with DiskEX-v0.9)
Region NTSC-U
Medium SD Gecko
Swiss version r342
Optional save file (.gci) n/a
Optional on screen crash dump screenshot
Spoiler
Show
Image
USBGecko log output n/a
Detailed report of the issue
- Running the game without patches/480i forsed/480p forsed/fast mode/compatible mode makes all graphics glitched on title screen and everything after that [most of the times but not every time].
- With compatible mode glitched once so far.
Other small issues
Spoiler
Show
ImageImage
After start of battle the picture jumps (about a pixel) from top and left, in some levels white border appears. If return to title screen and main menu the border is still visible. This issue doesn't appear in Nintendont or Dios Mios [the same level is shown on the second picture below from Dios Mios with no border].
Spoiler
Show
ImageImage
The shadows are too fat. The second picture is from Dios Mios and shows thinner shadows.

I always run the games with lid opened.
I have one suggestion. Can you put the file browser with different button instead of A + toggling from the menu. There are so many free buttons.
Attachments
dios mios.jpg
(86.07 KiB) Not downloaded yet
shadow.jpg
(140.42 KiB) Not downloaded yet
3.jpg
(100.64 KiB) Not downloaded yet
2.jpg
(91.47 KiB) Not downloaded yet
1.jpg
(119.86 KiB) Not downloaded yet
Last edited by TALANTO on Wed Jun 08, 2016 6:07 pm, edited 5 times in total.
User avatar
TALANTO
Posts: 43
Joined: Sun Jun 01, 2014 10:41 am
Contact:

Re: Submit Compatibility Issues Here

Post by TALANTO » Tue Jun 07, 2016 5:29 pm

Edit 3:
Zelda TP actually doesn't have problem with widescreen patching (it was just a luck to run normally in my previous testings). Starting the game without any patches also run in wrong colours. [the console is PAL]

Tried with another SD card fresh formatted and the problems with both games appeared.


I want to put a little update with the newer version (r363). Everything seems fixed except one but I know why it appeared randomly.
The Zelda colours - look the edit, shadows - fixed, jumping screen -fixed, white border - fixed.

The glitched graphics in Soul Calibur II - if I mash start and/or A button on sofdec logo to skip the animation with smoke the game works perfectly (every time so far). But if I wait for it the graphics are glitched (but not every time, I've seen the smoke few times perfectly with previous versions).

Edit:
The Zelda colours aren't fixed, it's random but I don't know what I do differently.

Edit 2:
While I was editing this post I had left Soul Calibur II playing in a fight. I was beaten, few cutscenes appeard, after that high scores and the smoke animation started again, glitched. I've pressed a button to skip and everything was glitched like before.
User avatar
megalomaniac
Posts: 2480
Joined: Sun Aug 21, 2011 5:33 am
Location: Drunk in Texas
Contact:

Re: Submit Compatibility Issues Here

Post by megalomaniac » Wed Jun 08, 2016 7:08 pm

soul calibur has issues loading from SD Gecko, otherwise it works perfect with swiss thru WASP
emu_kidid wrote: beer is like WD40 for megalomaniac's brain, gets the gears moving
>>> BadAssConsoles.com <<<

Image Image Image
User avatar
emu_kidid
Site Admin
Posts: 4373
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: Submit Compatibility Issues Here

Post by emu_kidid » Wed Jun 08, 2016 11:45 pm

*cough*stoppromotingupcomingsales?*cough*
Image
User avatar
megalomaniac
Posts: 2480
Joined: Sun Aug 21, 2011 5:33 am
Location: Drunk in Texas
Contact:

Re: Submit Compatibility Issues Here

Post by megalomaniac » Thu Jun 09, 2016 3:33 am

video proof of the same issue back in 2014

emu_kidid wrote: beer is like WD40 for megalomaniac's brain, gets the gears moving
>>> BadAssConsoles.com <<<

Image Image Image
User avatar
TALANTO
Posts: 43
Joined: Sun Jun 01, 2014 10:41 am
Contact:

Re: Submit Compatibility Issues Here

Post by TALANTO » Thu Jun 09, 2016 8:50 am

@megalomaniac: Your issue is because of slower speed of SD Gecko but mine is different see the pictures.

I don't thing you understand me so everything I can do is to make more pictures and I am done about reporting these issues:
The smoke animation:
Image
Main menu:
Image
A battle:
Image

I've never uploaded pictures about Zelda because I think the issue is common.
Title Screen:
Image
In game:
Image
Attachments
smoke.jpg
(78.55 KiB) Not downloaded yet
mainMenu.jpg
(42.1 KiB) Not downloaded yet
home.jpg
(59.52 KiB) Not downloaded yet
game.jpg
(99.69 KiB) Not downloaded yet
fight.jpg
(106.39 KiB) Not downloaded yet
User avatar
tesla246
Posts: 118
Joined: Tue Dec 11, 2012 1:48 pm

Re: Submit Compatibility Issues Here

Post by tesla246 » Thu Jun 09, 2016 10:42 am

I remember coming across this very issue regarding Twilight Princess (NTSC version) in an older revision of swiss when played trough SD gecko (for testing purposes). Apparently the red and blue colours are swapped (green is fine). I just tested it now again, and it seems the problem only occurs when displaying in progressive mode (480p). On top of that there were some artifacts (a few lines) at the top and bottom of the picture.

When selecting 480i however, the game's colours display correctly. Maybe the problem only exists in certain titles (Soul Calibur 2, Twilight Princesst) when selecting progressive mode?
The game plays fine in both 480i and 480p with wasp fusion though.
Dream mod: RAM expansion for serial port 2 with wifi, bluetooth and usb port :shock:
Favourite mod: Wasp fusion autoboot with flashed swiss. :D
Eagerly awaiting a normal, form-factor wise, wireless controller with rumble. :)
User avatar
emu_kidid
Site Admin
Posts: 4373
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: Submit Compatibility Issues Here

Post by emu_kidid » Thu Jun 09, 2016 12:47 pm

Looking into it at the moment, thanks for the pictures
Image
tueidj
Posts: 564
Joined: Fri May 03, 2013 6:57 am

Re: Submit Compatibility Issues Here

Post by tueidj » Thu Jun 09, 2016 1:35 pm

The color swapping happens when the switch into progressive mode is done during the wrong field transition, it also normally stutters along at half-rate and crashes if it tries to change modes again.
User avatar
emu_kidid
Site Admin
Posts: 4373
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: Submit Compatibility Issues Here

Post by emu_kidid » Thu Jun 09, 2016 1:53 pm

Yeah, and I mangle interrupt timing like a boss.
Image
MR.JOE
Posts: 9
Joined: Fri Jun 10, 2016 10:01 am

Re: Submit Compatibility Issues Here

Post by MR.JOE » Fri Jun 10, 2016 10:11 am

I'd like to post a major issue, present since the latest nightly (363):
Game
any disc-based game tested so far
Region
PAL
Medium
disc
Swiss version
363
Detailed report of the issue
Everytime I boot a retail game via SWISS I get an immediate ingame error, stating something like "an error has occured, please switch off your GAMECUBE and read the user's manual...". This does neither happen when I boot a game from SD-gecko nor when I use an older version of SWISS.
User avatar
emu_kidid
Site Admin
Posts: 4373
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: Submit Compatibility Issues Here

Post by emu_kidid » Fri Jun 10, 2016 12:14 pm

MR.JOE wrote:I'd like to post a major issue, present since the latest nightly (363):
Game
any disc-based game tested so far
Region
PAL
Medium
disc
Swiss version
363
Detailed report of the issue
Everytime I boot a retail game via SWISS I get an immediate ingame error, stating something like "an error has occured, please switch off your GAMECUBE and read the user's manual...". This does neither happen when I boot a game from SD-gecko nor when I use an older version of SWISS.
Try the latest nightly build :)
Image
Post Reply