Page 8 of 8

Re: Submit Compatibility Issues Here

Posted: Thu Nov 19, 2020 12:48 pm
by wano_ryuuma
Papy.G wrote:
Wed Nov 18, 2020 6:13 pm
You probably can't adress it, if someone else is experiencing the same, you just have to wait for the next release and try it to see if it does better.

You can get to SWISS's GitHub, and download the latest release, while it may not adress it yet, as most of the changes from previous version were done to add Virtual Memory Card support.

I don't know how audio streaming emulation works as I have never been bothered by that with the few games I play, but I can see there is a commit concerning that function.
I suspect we may move forward to an "automatic" setting so nobody will have to worry about that and mess with. ;)
Like a said in the last post, I tried to use the older revision of swiss and no matter what I tried, couldn't recover the original configuration. I fomated my SD, redownloaded the isos and tried every possible config.

Do you know if swiss change some configuration on the GC hardware when I patch a game?

Re: Submit Compatibility Issues Here

Posted: Sun Nov 22, 2020 3:31 am
by Django
game: Pokémon Colosseum PAL EUR
console: PAL EUR
Swiss v0.5r963
Game says there is no memory card on slot A when ussing virtual memory cards
EDIT: Pokemon XD works perfect, so maybe there's something wrong with how coloseum checks the memory card.

Re: Submit Compatibility Issues Here

Posted: Tue Jan 19, 2021 3:59 pm
by Diego borella
well, let's go to one more interesting fact ,.
Swiss 994

Tales of Symphonia
Spanish PAL

if speed emulation is active and I select disk 1, when in IPL mode, the game will change to disk 2, within the IPL menu; when I press Start, it enters the game and will ask you to open the cover of the gamecube physically, not as a disc change, but as if the disc was not there.

or if you select disk 2, it usually gives an error,

if i open the lid, it will run the Zelda WW boot disk.
And order the Tales record.
The interesting thing is that the introduction of the Game seems to run much better without the IPL enabled ...
I hope that this serves to some debugging, since Tales seems to present problems.

Re: Submit Compatibility Issues Here

Posted: Fri Jan 22, 2021 3:13 pm
by Papy.G
IMHO, boot through IPL should only be used when you really need the IPL to do something with it and can't access it straight from power on (some modded consoles and DOL-002 on NTSC TVs). ;)
We are all looking for the fastest way to boot games, and booting every game through IPL (not mentionning speed emulation) is just going the exact opposite side, unless compatibility issues force the need for you to do so. :?

Re: Submit Compatibility Issues Here

Posted: Mon Feb 01, 2021 4:55 pm
by Diego borella
in reality, the problem is with the compatibility list.
and when reporting minor issues, we may be helping to debug SWISS.
for example:
Skies of Arcadia Legends
NTSC dol 001

if I activate the speed emulation and activate the mode
PAL AVE-N-DOL, and apply the IGR command, it will fall on a black screen.
but if I reset the game first, it will return to the SEGA logo and then apply the IGR command, it will then return to SWiss.

in that game. to apply the IGR, I must first reset, and then it accepts the IGR ... the video mode seems to be affecting this.
interesting fact.

Re: Submit Compatibility Issues Here

Posted: Mon Feb 08, 2021 3:35 pm
by Diego borella
SD card gekko
Audio Streaming games are incompatible for me. :|
Zelda master Quest. USA
Zelda Collector, USA.
pandora splinter cell tomorrow PAL
It didn't work for me for memory card emulation. :!:
tried with and without IPL. It does not appear.
Enabling speed emulation also creates incompatibilities ...

Re: Submit Compatibility Issues Here

Posted: Mon Feb 08, 2021 3:37 pm
by Extrems
Memory card emulation is disabled when either streaming audio emulation or disc read speed emulation is enabled.
There isn't enough space to do everything at once.

Re: Submit Compatibility Issues Here

Posted: Wed Mar 31, 2021 8:51 pm
by Papy.G
I don't know if it's because of my dying battery (yes, once more, I got a bad battery batch…), or the exploit and boot forwarder (Dolauncher) that I use, but I can't load SWISS anymore, either from Exploit or IGR, when the microphone is plugged into Slot B. I wasn't sure I did before, but I have the video I made as a proof that I used to be able to.

I wonder if I'm the only one to experience this issue?