Page 4 of 4

Re: Submit Compatibility Issues Here

Posted: Mon Oct 14, 2019 2:57 pm
by Jweeber
Hello friends, the recent update (r682) has broken wasp/wiikey device compatibility for me. Can someone confirm this? As always, thank you for your efforts.

Re: Submit Compatibility Issues Here

Posted: Tue Oct 15, 2019 10:15 pm
by emu_kidid
It's fixed in r683

Re: Submit Compatibility Issues Here

Posted: Wed Oct 16, 2019 3:38 am
by Jweeber
That was fast! This community is the best.

Re: Submit Compatibility Issues Here

Posted: Sun Dec 01, 2019 8:35 am
by wangice
r688 ! NICE! Great Work emu_kidid~
Most game i tested with SDCard runs like use disc.
but one game WaveRace bluestorm no BGM.This game is audiostream.and other audiostream is fine(METROID Prime i tested)
wish can be fixed after version.

Re: Submit Compatibility Issues Here

Posted: Sun Dec 01, 2019 1:30 pm
by Extrems
Metroid Prime doesn't use streaming audio. The next version will fix such bogus flagging by the game developers.

Re: Submit Compatibility Issues Here

Posted: Wed Dec 04, 2019 8:16 am
by MarioMania
I have Version r714

I'm using the compressed & Non Conpressed version

Still won't work with Sonic Mega Collection (J)

Disk Shrunk using an unsupported tool

Please use Nkit

Re: Submit Compatibility Issues Here

Posted: Wed Dec 04, 2019 11:15 am
by Papy.G
As said, use Nkit to check and clean your file, if possible, or find a clean rip of it, and shrink it with Nkit.
I was thinking about it last week, finding clean rips can be quite challenging for some games.


Excellent! Rogue Squadron II works now (well, I hadn't try for a while, so maybe it is not a big news), I have put some games that didn't work as releases before ~r400, me and my son will be testing them and report back.

I have a problem, though:
Boot off AUF-PAL on DOL-001 PAL, RGB cable, Brosexec auto dolauncher, 64GB µSD in WiiSD SlotB
When SWISS boots, I have no game vignettes in the list, and trying to open a game gives "invalid or corrupt file", "ejecting" and trying to re-load SD slotB fixes the problem. Still, I can't see SD2SP2 card, it doesn't show in the device menu.

Edit: Not the µSD card's fault, same problem booting off all my cards (µSD HC 8GB, regular SDs 1 and 2GB)

Re: Submit Compatibility Issues Here

Posted: Wed Dec 04, 2019 1:47 pm
by Extrems
MarioMania wrote:
Wed Dec 04, 2019 8:16 am
Still won't work with Sonic Mega Collection (J)
Image
Works for me.
Papy.G wrote:
Wed Dec 04, 2019 11:15 am
When SWISS boots, I have no game vignettes in the list, and trying to open a game gives "invalid or corrupt file", "ejecting" and trying to re-load SD slotB fixes the problem.
Weird, I was sure I fixed that.

Re: Submit Compatibility Issues Here

Posted: Wed Dec 04, 2019 2:36 pm
by Papy.G
The only way to get the SD2SP2 in the device's list is to have an SD present in it at bootup, and this way it has the vignettes without having to re-select the device too.

Maybe the presence of the SD2SP2 in the device list related to a SD present at bootup is intended?

Re: Submit Compatibility Issues Here

Posted: Wed Dec 04, 2019 2:51 pm
by Extrems
There's no way to detect the SD2SP2 without an SD card in it. I specifically looked at fixing Memory Slot B without an SD2SP2.

Re: Submit Compatibility Issues Here

Posted: Wed Dec 04, 2019 3:12 pm
by Papy.G
Yes, I know that by design there's no way to detect it, but can you test it once more when we access to the devices menu, instead of just at bootup? Or is there a good reason for not displaying the SD2SP2 device permanently in this menu?

I don't know if it may help, but with my Zelda µSD, the last in the root folder, that is the Ocarina/Master Quest, gets a "banner unavailable" vignette, and recognized as a NTSC-J game.

Re: Submit Compatibility Issues Here

Posted: Wed Dec 04, 2019 5:58 pm
by s8n187
just reporting Sonic Mega Collection (US) working fine over here , btw thank you Extrems for the Alternate Read Patch efforts. Really impressive and a joy to use with Swiss

Re: Submit Compatibility Issues Here

Posted: Wed Dec 04, 2019 7:36 pm
by MarioMania
Papy.G wrote:
Wed Dec 04, 2019 11:15 am
As said, use Nkit to check and clean your file, if possible, or find a clean rip of it, and shrink it with Nkit.
I was thinking about it last week, finding clean rips can be quite challenging for some games.


Excellent! Rogue Squadron II works now (well, I hadn't try for a while, so maybe it is not a big news), I have put some games that didn't work as releases before ~r400, me and my son will be testing them and report back.

I have a problem, though:
Boot off AUF-PAL on DOL-001 PAL, RGB cable, Brosexec auto dolauncher, 64GB µSD in WiiSD SlotB
When SWISS boots, I have no game vignettes in the list, and trying to open a game gives "invalid or corrupt file", "ejecting" and trying to re-load SD slotB fixes the problem. Still, I can't see SD2SP2 card, it doesn't show in the device menu.

Edit: Not the µSD card's fault, same problem booting off all my cards (µSD HC 8GB, regular SDs 1 and 2GB)
What file do I use to do that?

I'm on Windows 10

and the .exe crashes

Re: Submit Compatibility Issues Here

Posted: Thu Dec 05, 2019 11:42 am
by Papy.G
Extrems wrote:
Wed Dec 04, 2019 2:51 pm
There's no way to detect the SD2SP2 without an SD card in it. I specifically looked at fixing Memory Slot B without an SD2SP2.
I just noticed that my Backup battery is fading out, the clock stops when the console is off (well, after four to five hours in fact), my problems seem to come from that (I was not able to save settings either).
My other DOL-001 is apart to trace the SD2SP2's CPU vias, so I've tried with a DOL-101, and everything is working (I couldn't test SD2SP2 related stuff, will report once I've changed the battery).


I'm really sorry for all this as it wasn't related to your Software. I feel dumb. :oops:

Edit: Back for more!
The battery change didn't solve everything,
My SD2SP2 is custom made, and when it is plugged with no SD in it, the first loading of the Slot B root shows no banners. (Still have to check with Dol-001 and no SD2SP2 plugged in at all)
If I load an SD from the SD2SP2 from quitting GBI, it is OK.
The settings save problem appeared when I first set it to SD2SP2, if I want it back to Slot B and no settings file is present on the SD, it fails, I have to put the SD in the SD2SP2 to create the file first, then, I can set it back to save on Slot B, and it works.
The SRAM kept the time and date static the whole time needed to change the battery (took 15 to 20 mn).