Swiss with Samba

Discuss one of the most feature filled GameCube applications here :)
Post Reply
User avatar
Stormspark
Posts: 3
Joined: Sat Feb 29, 2020 2:37 am

Swiss with Samba

Post by Stormspark » Tue Mar 03, 2020 12:33 am

I have Samba set up on my Linux server. I've set everything up in the config files, and it should work, but it always just says "Failed to initialize SMB" no matter what I do. The IP address I'm getting is correct.

Code: Select all

SMBUserName=stormspark
SMBPassword=<redacted>
SMBShareName=stormspark
SMBHostIP=192.168.0.1
This share works perfectly fine on every other device I have that supports SMB, so I can't figure out why this doesn't. There's also precious little documentation. All I really want is a convenient way to copy files back and forth between my Gamecube and server without fussing about with removing and reinserting MicroSD cards.
User avatar
Extrems
Posts: 962
Joined: Tue Aug 17, 2010 10:40 pm
Location: Québec, Canada
Contact:

Re: Swiss with Samba

Post by Extrems » Tue Mar 03, 2020 1:30 am

We only support SMB 1.0, which is disabled by default in modern systems for security reasons.

If you're looking to copy disc images, use the File Service Protocol instead. You could play directly off your server.
User avatar
Stormspark
Posts: 3
Joined: Sat Feb 29, 2020 2:37 am

Re: Swiss with Samba

Post by Stormspark » Tue Mar 03, 2020 2:41 am

I'm still looking into FSP (I noticed it in the options), unfortunately my distro does not have any included ebuilds for it so it'll take me some time, as I'll either have to find an overlay or build one myself to get it working (and during the week I don't have a lot of time). I've also tried getting FTP to work (my server also includes FTP, and it works). Unfortunately, FTP seems to do nothing at all...it's like I didn't select anything. Server IP and credentials are definitely correct.
User avatar
Aleron Ives
Posts: 90
Joined: Thu Oct 13, 2016 3:56 am
Location: California

Re: Swiss with Samba

Post by Aleron Ives » Tue Mar 03, 2020 10:38 pm

As per this thread: https://forums.linuxmint.com/viewtopic.php?t=270442

Have you tried adding vers=1.0 to force allowing SMB1?
User avatar
Stormspark
Posts: 3
Joined: Sat Feb 29, 2020 2:37 am

Re: Swiss with Samba

Post by Stormspark » Wed Mar 04, 2020 2:39 am

I'm actually going to try that when I have time. FTP would be preferable at this point though, and I have no clue why that doesn't work.
Post Reply