Memory Card Problem

Portables, case replacements, mods etc, all in here!
Natsu2000
Posts: 25
Joined: Sat Nov 18, 2017 12:47 am

Memory Card Problem

Post by Natsu2000 » Sun Dec 24, 2017 10:56 pm

Hello,
I've got a problem. My memory card doesn't work anymore. My Gamecube says it has to be formatted.
Does someone know how to solve this problem because I don't want to format the card because of the game saves.
User avatar
Streetwalker
Posts: 1736
Joined: Mon Dec 30, 2013 7:50 am
Location: Israel

Re: Memory Card Problem

Post by Streetwalker » Mon Dec 25, 2017 6:35 am

Can you run homebrew on your GC, or do you have access to a modded Wii? If so, try to read the memory card with gcmm, and post a raw backup of it.
Natsu2000
Posts: 25
Joined: Sat Nov 18, 2017 12:47 am

Re: Memory Card Problem

Post by Natsu2000 » Mon Dec 25, 2017 4:46 pm

Streetwalker wrote:Can you run homebrew on your GC, or do you have access to a modded Wii? If so, try to read the memory card with gcmm, and post a raw backup of it.
Yes, I can run homebrew on GC and Wii.
I tried to make a raw backup but it shows "No saved games to backup!"
User avatar
Streetwalker
Posts: 1736
Joined: Mon Dec 30, 2013 7:50 am
Location: Israel

Re: Memory Card Problem

Post by Streetwalker » Mon Dec 25, 2017 9:05 pm

Looking at the code, when you try to make a raw backup (L+Y), it doesn't do that check, so you must be pressing the wrong buttons.
Natsu2000
Posts: 25
Joined: Sat Nov 18, 2017 12:47 am

Re: Memory Card Problem

Post by Natsu2000 » Tue Dec 26, 2017 2:46 am

I tried it again (by pressing L+Y) but it shows the same message. Maybe I should try it on Wii
User avatar
Andross89
Posts: 145
Joined: Sun May 25, 2014 10:02 pm

Re: Memory Card Problem

Post by Andross89 » Tue Dec 26, 2017 9:20 am

Natsu2000 wrote:Hello,
I've got a problem. My memory card doesn't work anymore. My Gamecube says it has to be formatted.
Does someone know how to solve this problem because I don't want to format the card because of the game saves.
You must have used some code that created a save that corrupted the memory card. It happened to me in RE4. I had to format. I did not find a solution.
Natsu2000
Posts: 25
Joined: Sat Nov 18, 2017 12:47 am

Re: Memory Card Problem

Post by Natsu2000 » Tue Dec 26, 2017 10:30 am

Yes, I remember that I saved the game once while cheating on Wind Waker. Maybe that's the reason for my corrupted card.
I tried the gcmm on wii and it didn't work, too. So I think I'll format my card.
But I wonder how it happened because the card wasn't corrupted after saving on wind waker while cheating. It happened later after I played another game (without cheats).

Thanks for your help :)
User avatar
Streetwalker
Posts: 1736
Joined: Mon Dec 30, 2013 7:50 am
Location: Israel

Re: Memory Card Problem

Post by Streetwalker » Tue Dec 26, 2017 11:09 am

Don't format it just yet. What version of GCMM are you using?
Natsu2000
Posts: 25
Joined: Sat Nov 18, 2017 12:47 am

Re: Memory Card Problem

Post by Natsu2000 » Tue Dec 26, 2017 11:27 am

Streetwalker wrote:Don't format it just yet. What version of GCMM are you using?
I'm using version 1.4f
User avatar
Andross89
Posts: 145
Joined: Sun May 25, 2014 10:02 pm

Re: Memory Card Problem

Post by Andross89 » Tue Dec 26, 2017 1:37 pm

Natsu2000 wrote:...But I wonder how it happened because the card wasn't corrupted after saving on wind waker while cheating. It happened later after I played another game (without cheats)...
I will tell a story:

I started RE3 with a code that changed Carlos's status. I saved, I realized the error and I used the right code. I was playing and saving normally. But when it came time for Carlos: black screen. Something similar happened. I guess. Always be prepared for these things.
User avatar
Streetwalker
Posts: 1736
Joined: Mon Dec 30, 2013 7:50 am
Location: Israel

Re: Memory Card Problem

Post by Streetwalker » Tue Dec 26, 2017 2:22 pm

Natsu2000 wrote:I'm using version 1.4f
I'll upload a test build for you tonight.
Natsu2000
Posts: 25
Joined: Sat Nov 18, 2017 12:47 am

Re: Memory Card Problem

Post by Natsu2000 » Tue Dec 26, 2017 2:57 pm

Streetwalker wrote:
Natsu2000 wrote:I'm using version 1.4f
I'll upload a test build for you tonight.
Ok Thank You :)
User avatar
Streetwalker
Posts: 1736
Joined: Mon Dec 30, 2013 7:50 am
Location: Israel

Re: Memory Card Problem

Post by Streetwalker » Tue Dec 26, 2017 11:00 pm

I've tried removing those checks but I can confirm again that they aren't in the raw backup path. This is a GC build. Remove the zip extension, the file is actually a dol but the board won't let me upload it as is.
Attachments
gcmm_GC.dol.zip
(1.53 MiB) Downloaded 35 times
Natsu2000
Posts: 25
Joined: Sat Nov 18, 2017 12:47 am

Re: Memory Card Problem

Post by Natsu2000 » Tue Dec 26, 2017 11:50 pm

Streetwalker wrote:I've tried removing those checks but I can confirm again that they aren't in the raw backup path. This is a GC build. Remove the zip extension, the file is actually a dol but the board won't let me upload it as is.
Thank You for doing this :)
Those checks are now removed but unfortunately after pressing L+Y it shows "Bad id". When I'm pressing A for continue I can see some information on the right site (Backup Mode). It shows on "Blocks:" 00 (59 free), if this is important to know. (I've added a picture of the information from Backup Mode.) Then after pressing A again, it shows "Error reading MC file".
When I try to backup all savegames by pressing R it worked according to gcmm, but there are no files on my SD Card.

Maybe my memory card is really corrupted and I have to format it.
Attachments
Backup Mode.JPG
(4.01 MiB) Not downloaded yet
User avatar
Streetwalker
Posts: 1736
Joined: Mon Dec 30, 2013 7:50 am
Location: Israel

Re: Memory Card Problem

Post by Streetwalker » Wed Dec 27, 2017 12:02 am

I think your L trigger is broken. You're just ending up in the regular single save backup mode.
Natsu2000
Posts: 25
Joined: Sat Nov 18, 2017 12:47 am

Re: Memory Card Problem

Post by Natsu2000 » Wed Dec 27, 2017 1:19 am

Streetwalker wrote:I think your L trigger is broken. You're just ending up in the regular single save backup mode.
It worked now. After you said that my trigger is broken I tried it with my second controller and then again with the other one.
The trigger is not broken. It was my fault. I was too stupid for this. This time I pressed and hold the L button first and then I've pressed Y, instead of pressing both at the same time. Sorry, my fault xD

Here is the raw backup. I did it like you with the file extension.
Attachments
0059b_2017_12Dec_27_02-13-02.raw.zip
(512 KiB) Downloaded 43 times
User avatar
Streetwalker
Posts: 1736
Joined: Mon Dec 30, 2013 7:50 am
Location: Israel

Re: Memory Card Problem

Post by Streetwalker » Wed Dec 27, 2017 12:44 pm

Your save files are there but the filesystem seems to be gone. The game must have crashed or power was lost the last time you saved. I need more time to analyze this a little more in-depth. In the meantime, you can format the card and use it.
Natsu2000
Posts: 25
Joined: Sat Nov 18, 2017 12:47 am

Re: Memory Card Problem

Post by Natsu2000 » Wed Dec 27, 2017 1:55 pm

Streetwalker wrote:Your save files are there but the filesystem seems to be gone. The game must have crashed or power was lost the last time you saved. I need more time to analyze this a little more in-depth. In the meantime, you can format the card and use it.
Thank You :)
I remember that one game crashed while playing. I think it was because of the cheats I used.
N7Kopper
Posts: 6
Joined: Tue May 12, 2015 2:04 pm

Re: Memory Card Problem

Post by N7Kopper » Thu Dec 28, 2017 1:03 pm

I had a similar problem that happened while running Swiss. I don't know if it was actually that build of Swiss' fault, or just some cosmic ray stuff. (I'm fairly certain it wasn't Crystal Chronicles PAL's fault) But I keep regular backups, so I don't have a raw dump for forensics.

Still, good on you for thinking better than me and keeping that dump.
User avatar
Streetwalker
Posts: 1736
Joined: Mon Dec 30, 2013 7:50 am
Location: Israel

Re: Memory Card Problem

Post by Streetwalker » Tue Jan 02, 2018 10:10 pm

I'm sorry, I was hoping for a partially corrupted filesystem that would let me extract at least a few save files but it seems that all of the metadata is gone. If you have games in particular that you'd like to extract the save of, I could give it a shot, but I can't do anything blindly. For that I need the exact game IDs to make sure I extract them properly.
Natsu2000
Posts: 25
Joined: Sat Nov 18, 2017 12:47 am

Re: Memory Card Problem

Post by Natsu2000 » Wed Jan 03, 2018 8:48 pm

No problem thank you for trying :)

Here are the Game ID's:
G4QP01
GZLP01
User avatar
Hulksfan
Posts: 15
Joined: Tue Jan 02, 2018 2:34 pm

Re: Memory Card Problem

Post by Hulksfan » Mon Jan 15, 2018 10:04 am

How's about saving the games to additional drive and format the memory card?
A good game is easy to learn, but hard to master :geek:
Ralf@gc-forever
Posts: 1328
Joined: Sun Mar 16, 2014 9:31 am

Re: Memory Card Problem

Post by Ralf@gc-forever » Sat Jan 20, 2018 6:51 pm

@Natsu2000: The attached zip archive contains some of your lost game saves in .gci file format. The "Star Wars: The Clone Wars" game save is untested (I don't have the game), but should be working.
Attachments
Game_Saves.zip
(77.38 KiB) Downloaded 41 times
User avatar
Streetwalker
Posts: 1736
Joined: Mon Dec 30, 2013 7:50 am
Location: Israel

Re: Memory Card Problem

Post by Streetwalker » Sat Jan 20, 2018 6:58 pm

Great job, Ralf. I had totally forgotten about this.
Natsu2000
Posts: 25
Joined: Sat Nov 18, 2017 12:47 am

Re: Memory Card Problem

Post by Natsu2000 » Sat Jan 20, 2018 8:43 pm

Ralf@gc-forever wrote:@Natsu2000: The attached zip archive contains some of your lost game saves in .gci file format. The "Star Wars: The Clone Wars" game save is untested (I don't have the game), but should be working.
It works. Thanks a lot! :D
Post Reply