SWISS Incompatible With XENO GC Modchip?

Portables, case replacements, mods etc, all in here!
Post Reply
Ceros
Posts: 17
Joined: Sun Mar 11, 2018 10:33 am

SWISS Incompatible With XENO GC Modchip?

Post by Ceros » Fri May 04, 2018 6:25 pm

Hey!
So I have had my japanese gamecube modded with a xeno chip for a while and it works like an absolute charm. I am able to boot discs from all regions (I do not burn my own because I do not want to mess with the pot meter). I also installed a region switch and managed to install a self assembled and programmed GCDUAL kit by citrus3000psi. So I am almost done with my monster cube. Today I finally got the SD Media Launcher disc from codejunkies and I am able to use the gameboy interface too. Neat! But I try to launch a PAL game in swiss, it is resetting the drive, then thinks it is a backup, throws the error "disk not initialized" and then "Failed to mount DVD. Press A". When I turn it off and run the game like I normally would, it still works. What is the problem here? Why is swiss unable to read the discs? Is the modchip blocking swiss from reading its region?

edit: strangely enough, it throws the exact same error as when a disc is not inserted. How come?
User avatar
Streetwalker
Posts: 1744
Joined: Mon Dec 30, 2013 7:50 am
Location: Israel

Re: SWISS Incompatible With XENO GC Modchip?

Post by Streetwalker » Fri May 04, 2018 10:16 pm

Swiss works fine with the xeno, but I think it tries to disable it and apply its own drive patch which doesn't work as well in my experience. Or your xeno isn't repatching the drive when Swiss resets it.
Ceros
Posts: 17
Joined: Sun Mar 11, 2018 10:33 am

Re: SWISS Incompatible With XENO GC Modchip?

Post by Ceros » Sat May 05, 2018 7:47 am

Streetwalker wrote:Swiss works fine with the xeno, but I think it tries to disable it and apply its own drive patch which doesn't work as well in my experience. Or your xeno isn't repatching the drive when Swiss resets it.
So that sounds like it could be correct. But is there a workaround for this?

Edit: do i need to remove some of the files from swiss? Patch files perhaps?
User avatar
Streetwalker
Posts: 1744
Joined: Mon Dec 30, 2013 7:50 am
Location: Israel

Re: SWISS Incompatible With XENO GC Modchip?

Post by Streetwalker » Sat May 05, 2018 8:54 am

https://github.com/emukidid/swiss-gc/co ... 03d09febe0
This is all I can do for you, emu_kidid will have to take it from there if it still doesn't work. Wait until he releases a new build and try again.
That said, if you're booting out of region original, the drive definitely doesn't need to be patched, so something else might be wrong with it.
User avatar
emu_kidid
Site Admin
Posts: 4645
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: SWISS Incompatible With XENO GC Modchip?

Post by emu_kidid » Sat May 05, 2018 9:01 am

Streetwalker wrote:https://github.com/emukidid/swiss-gc/co ... 03d09febe0
This is all I can do for you, emu_kidid will have to take it from there if it still doesn't work. Wait until he releases a new build and try again.
That said, if you're booting out of region original, the drive definitely doesn't need to be patched, so something else might be wrong with it.
New release is up.
Image
Ceros
Posts: 17
Joined: Sun Mar 11, 2018 10:33 am

Re: SWISS Incompatible With XENO GC Modchip?

Post by Ceros » Sat May 05, 2018 1:10 pm

emu_kidid wrote:
Streetwalker wrote:https://github.com/emukidid/swiss-gc/co ... 03d09febe0
This is all I can do for you, emu_kidid will have to take it from there if it still doesn't work. Wait until he releases a new build and try again.
That said, if you're booting out of region original, the drive definitely doesn't need to be patched, so something else might be wrong with it.
New release is up.
Decided to do some digging around his github. Will test it out tonight. Thanks! Posted the issue there as well because it might be better to pick it up there if still persistent.
Post Reply