GCVideo DVI PLuto board reprogramming

Portables, case replacements, mods etc, all in here!
Post Reply
GizmoTheGreen
Posts: 54
Joined: Fri Aug 17, 2018 12:40 pm

GCVideo DVI PLuto board reprogramming

Post by GizmoTheGreen » Tue Sep 11, 2018 10:44 am

Hey, so apparantly there's a bug in how 2.4a calcluates colors and a 2.5 rewritten version is on the way that's fixed this?

but I can't get much info on how to actually program the board other than RS232, would something like this https://www.ebay.co.uk/itm/USB-To-RS232 ... SwsaZa2n8y work?

I happen to have one I used with a raspberry pi a while back.
User avatar
Streetwalker
Posts: 1744
Joined: Mon Dec 30, 2013 7:50 am
Location: Israel

Re: GCVideo DVI PLuto board reprogramming

Post by Streetwalker » Tue Sep 11, 2018 11:19 am

This looks like it should work. The pinout of the serial header on the Pluto is described here on page 14.
GizmoTheGreen
Posts: 54
Joined: Fri Aug 17, 2018 12:40 pm

Re: GCVideo DVI PLuto board reprogramming

Post by GizmoTheGreen » Tue Sep 11, 2018 11:29 am

okay cool, thanks!
d4rkst4r
Posts: 2
Joined: Mon Apr 01, 2019 7:21 pm
Location: Germany

Re: GCVideo DVI PLuto board reprogramming

Post by d4rkst4r » Mon Apr 01, 2019 8:30 pm

Hello everyone,

I tried to reprogramm my Pluto-IIx HDMI board over the serial interface. Unfortunately with no success.

I used a FTDI chip FT232R and connected it in this way:
FTDI GND to Pluto GND
FTDI Vcc (5V) to Pluto Vunreg
FTDI Rx (3V3) to Pluto Tx
FTDI Tx (3V3) to Pluto Rx

Then I opend FPGAconf, chose Pluto IIx S200 as the board and configured the right com port. After selecting the GCVideo DVI p2xh bit-File I pressed the button "program boot-prom".
But I always get an error: communication timeout.

Do I miss something? Has anybody succesfully updated the GCVideo firmare over the serial Interface?

I also tryed to invert the tx signal of the FTDI chip with FT_Conf but still not working.
User avatar
Papy.G
Posts: 467
Joined: Mon Mar 04, 2019 6:14 am
Location: France, Occitanie
Contact:

Re: GCVideo DVI PLuto board reprogramming

Post by Papy.G » Tue Apr 02, 2019 10:46 am

Maybe forgot to put pull-up resistor somewhere on the lines? :P
Don't know the pluto Board and FTDI you are using, but it is a very common issue when dealing with that kind of raw serial connexions. :roll:
DMG/MF OC, AGB/SC miniSD, NTR/NeoMK3, USG/flashme V8/SC miniSD
DOL001(EUR)/RGB/GCPlug/GBP/SD2SP2, RVL 001(EUR)/RGB/CMP/WiiSD

Zelda WW with Tingle Tuner in split screen was what the GC RF modulator was made for! (Video)
d4rkst4r
Posts: 2
Joined: Mon Apr 01, 2019 7:21 pm
Location: Germany

Re: GCVideo DVI PLuto board reprogramming

Post by d4rkst4r » Tue Apr 02, 2019 7:16 pm

Thanks for your advice! Since I am on holiday I do not have access to an oscilloscope. For now I bought the official programming adapter from knjn. When it is delivered and I am back at work I will compare the signals of the official adapter to my FTDI chip with an oscilloscope. I will let you guys know if the official adapter works and I was able to find the issue.
GizmoTheGreen
Posts: 54
Joined: Fri Aug 17, 2018 12:40 pm

Re: GCVideo DVI PLuto board reprogramming

Post by GizmoTheGreen » Sun Jan 05, 2020 4:59 pm

d4rkst4r wrote:
Tue Apr 02, 2019 7:16 pm
Thanks for your advice! Since I am on holiday I do not have access to an oscilloscope. For now I bought the official programming adapter from knjn. When it is delivered and I am back at work I will compare the signals of the official adapter to my FTDI chip with an oscilloscope. I will let you guys know if the official adapter works and I was able to find the issue.
hey you never got back to us ...!!

trying to program again and still no luck with my FTDI, it's a sparkfun ftdi basic.
I set TxD as inverted with FTProg of course.
GizmoTheGreen
Posts: 54
Joined: Fri Aug 17, 2018 12:40 pm

Re: GCVideo DVI PLuto board reprogramming

Post by GizmoTheGreen » Sun Jan 26, 2020 10:33 am

ended up getting an xilinx jtag compatible box (DLC10) which I needed to run on XP (I had an xp laptop at hand, all other machines have win10 and xilinx impact 11.1 won't even run installer on that)
with some mucking around I got impact to see the fpga and attached spi rom, told it to use the gc-video .mcs file and bam. updated to 3.0b

3.0c released day after and I could confirm the new update over video (.dol) work on both Pluto 2x board and Carby plug-n-play adapter!
BlueParts
Posts: 1
Joined: Thu Mar 05, 2020 7:27 pm

Re: GCVideo DVI PLuto board reprogramming

Post by BlueParts » Thu Mar 05, 2020 7:38 pm

Ended up making a new account just to answer here.

I tried the exact same thing as others, but with the Arduino USB2Serial Adapter, but that sadly resulted in the same error: communication timeout.
Everything was double and triple checked and various things were tried: TX/RX swapped, external power for the pluto, different drivers, matching the driver settings as in the manual, nothing.

But i believe for me it's still a driver issue, as the Adapter is a Atmel, and i'm not sure what the KNJN TXDI/FTDI USB Adapter is.
Almost enough desperation to get the KNJN one ^^
Post Reply