Problems with wiikey fusion and gamecube

Portables, case replacements, mods etc, all in here!
Post Reply
Posts: 3
Joined: Sun Apr 12, 2020 1:00 pm

Problems with wiikey fusion and gamecube

Post by Kenny_Ken93 » Sun Apr 12, 2020 1:13 pm

Hey folks,
I've been trying to get my wkf to run for about 3 days straight. First, I had problems with my solder joins. I resoldered everything multiple times. I took a 32gb microSD card (Sandisk class 10, high quality) and formatted it to WBFS using WBFS Manager 4.0. This worked straight! I managed to update the WKF to 1.5. After a reboot, nothing worked anymore. The blue LED on the WKF was not lit but it tries to flash every second or so. And its also very dim, you can barely see it.
Fast forward, I resoldered everything - again. After that, I still had that issue. I thought, that I maybe bricked the wkf whilst flashing 1.5, so I used the 1.2 rescue iso - it worked! I used a cheapo 8gb SD card. After that, I used a 8gb micro SD card, formatted to WBFS - Nothing. Again, the problem I stated above.

I tried:
6 differend SD and Micro SD cards, from 2gb to 32gb, I tried WBFS Manager 3.0 and 4.0, I tried different computers, different cardreaders, different Operating Systems, different micro SD to SD adaptors - Nothing.

So, in conclusion:
the 1.5 update worked once
the 1.2 rescue SD works everytime (this is why I can rule out a wiring fault)
All other SD cards with any iso's don't work at all, even the SD card which has 1.2 rescue on it does not work when formatted to WBFS

I am very sure at this point, that it's a faulty WBFS file system or else, so the WKF does not recognize the SD card. I came to that conclusion, because the 8gb SD card with the WKF recovery firmware works everytime and this one was flashed using dd, so a bytewise flashing of each sector instead of file systems or else. Or maybe it's something else. Do you have any ideas? I'm just annoyed that it won't work and tired of all this :(

Chip: Genuine WKF
No DVD drive attached
Pin 29 to GND, permanently
Switch to the LID pins, NC
Megadrive 1.0 board, not directly attached to the port
I used <3cm 30AWG wire and checked every connection multiple times

Thanks in Advance,
Posts: 3
Joined: Sun Apr 12, 2020 1:00 pm

Re: Problems with wiikey fusion and gamecube

Post by Kenny_Ken93 » Sun Apr 12, 2020 2:28 pm

I made it. It works now.
I tried to stick to the tutorial, posted on the wikiHere but I could not get the WKF 1.5 Firmware installed, no matter what.
I get it to work by doing the following:
  1. Flashing the WKF 1.2 recovery firmware to an SD card using dd under Linux or Cygwin for Windows
  2. Updating the WKF to Firmware 1.2 using the recovery disk
  3. Using the WKF Recovery Swiss iso contained in the latest Swiss nightly, also flashing it using dd
  4. At this point I can boot swiss but it says the SD image is not recognizable (makes sense since there shoudlnt be any)
  5. Continuing from the wiki tutorial, I loaded up the swiss FZN and FZN.FW files to a different SD card, formated in FAT32 and plugged it in my SD Gecko in Port A
  6. In Swiss, I flashed the .FZN swiss autoboot firmware
  7. SUCCESS! The Wiikey now reads FAT32 formatted SD cards, such as my big 32gb MicroSD without any problems.
From this point on, I loaded up some .iso games and .dol files for testing, inserted in the WKF and it works like a charm.

Prior to the list above, I tried flashing the 1.5 firmware from the SD gecko or hot swapping the SD card in the gecko while in swiss, which was not possible. I always get an error that there is a problem with the iso at Adress 0x1C

I hope this helps someone.

greets, kenny
Posts: 27
Joined: Sun Sep 15, 2019 3:42 pm

Re: Problems with wiikey fusion and gamecube

Post by SkydivinGirl » Thu Jun 11, 2020 5:36 pm

Glad you got it working! I really love the WKF in the GameCube. I can still use the DVD drive and boot images from SD card. :)

Post Reply