Bricked my Gamecube after Swiss WASP firmware update

Portables, case replacements, mods etc, all in here!
Locked
gmipf
Posts: 15
Joined: Sun Sep 08, 2013 10:55 pm
Location: Germany

Bricked my Gamecube after Swiss WASP firmware update

Post by gmipf » Mon Oct 12, 2020 9:27 pm

I have done firmware updates several times now successfully, but the last update was a failure. I have updated from r876 to r922 by starting swiss_r922.fzn with the file swiss_r922.fzn.fw in the same directory. After the update and restart I have a black screen now. There is even no Gamecube bios on power on, it is completely dead. The empty DVD drive is also trying to access a disc every time powering on. The update was done from the WASP SD Card (256GB).

How can I recover the firmware to swiss again?
User avatar
emu_kidid
Site Admin
Posts: 4713
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: Bricked my Gamecube after Swiss WASP firmware update

Post by emu_kidid » Mon Oct 12, 2020 11:26 pm

A few things here:

- WKF/WASP can't read beyond 64GB so it's possible that you flashed garbage.
- If it's trying to read the DVD drive, then the flash is probably corrupt or it can't find your SD card.

What to try:
1. Get a small SD card <= 64GB, flash the recovery ISO provided in the swiss release archive raw to the SD card using something like balenaetcher or Win32DiskImager.
2. If this boots to Swiss, put the proper .fzn and fzn.fw on another device that Swiss can read and flash it again.

I don't recall if the .fw file can handle being corrupted, hopefully it has a fail safe and can go back to booting the raw recovery ISO.
Image
gmipf
Posts: 15
Joined: Sun Sep 08, 2013 10:55 pm
Location: Germany

Re: Bricked my Gamecube after Swiss WASP firmware update

Post by gmipf » Tue Oct 13, 2020 1:00 am

YES, my GC works again. I have flashed the recovery Wiikeyfusion iso to a 64GB SD card, after a long black screen I saw the bios again but with the red error message to shut down the GC. Then I have turned it on again and swiss was booted. From there I have flashed the firmware from SP2. A little odd that the flasher utility even worked despite being after the 64GB area and flashed garbage then. Maybe the flasher should check the fw file before start flashing. But luckily the recovery process works fine. Thank you emu_kidid.

Are there any workarounds for cards bigger than 64GB? I have always used 256GB, thought it works fine but wondered that my latest added isos didn't worked, now I know why.
User avatar
emu_kidid
Site Admin
Posts: 4713
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: Bricked my Gamecube after Swiss WASP firmware update

Post by emu_kidid » Tue Oct 13, 2020 1:18 am

gmipf wrote:
Tue Oct 13, 2020 1:00 am
YES, my GC works again. I have flashed the recovery Wiikeyfusion iso to a 64GB SD card, after a long black screen I saw the bios again but with the red error message to shut down the GC. Then I have turned it on again and swiss was booted. From there I have flashed the firmware from SP2. A little odd that the flasher utility even worked despite being after the 64GB area and flashed garbage then. Maybe the flasher should check the fw file before start flashing. But luckily the recovery process works fine. Thank you emu_kidid.

Are there any workarounds for cards bigger than 64GB? I have always used 256GB, thought it works fine but wondered that my latest added isos didn't worked, now I know why.
Glad you have it sorted out :) Stick with 64GB in the WASP.

Unfortunately there are no workarounds for > 64GB. The WKF/WASP is limited to 64GB in hardware and my attempts to read beyond it have always failed.

I'd even tried setting the internal base offset to 32GB or 64GB and then reading beyond that amount, but the reads fail - suggesting that it can't handle anything larger in any sort of way internally.

I'll lock this topic, hopefully anyone else who does the same can learn from it :)
Image
Locked