Page 1 of 1

Help with Root File System

Posted: Mon Aug 26, 2019 5:42 pm
by NathanP
Hi I am new to the board,

I have been trying to get gc-linux running on my GameCube for a few weeks now. Using this ... otFS_on_SD guide by _Nold_, I was able to get the kernel to boot.

However, I cannot get it to find my init script in the root file system. I keep getting the error "kernel panic: no init found. Try passing init= option to kernel"
I have tried renaming the rootfs and making it on a 32bit system rather than a 64bit system. I just think I am doing something that should be simple, wrong. Maybe it needs to be named or compressed a certain way.Image

Here is the init script Image

Re: Help with Root File System

Posted: Tue Aug 27, 2019 12:17 am
by emu_kidid
I believe the SDHC vs SD(SC) builds Nold was pushing out were limited to one type of SD card or the other, make sure you've tried the correct type of SD card.

Re: Help with Root File System

Posted: Tue Aug 27, 2019 5:24 am
by nold360

man it's been a while.. couldn't even remember my password.. ayy..

The SDHC Patch is dirty af but it should work with both, SD and SDHC. No SDXC or whatever ofc. So, this should be working.. make sure the file is executable: chmod +x init
Did you create the devices correctly? "ls -l dev" should give some information about that.

Aside from that i don't really know what's wrong, haven't used it in ages after all..

Re: Help with Root File System

Posted: Thu Sep 05, 2019 2:09 am
by NathanP
Thanks so much for creating another account just to help!

So I don't think I had my init as executable, but after making it executable I get the same exact error. Then I tried using port A (and switched everything to A), same exact error.
I forgot to mention the "attempt to access beyond end of my device". I don't understand why it is doing that. My vfat is 300 MB and my ext3 is 1.6 G (it's a 2G card)


Here is the dev folder