Shuriken USB (USB Gecko SE (clone))

Find all your GameCube topics here
User avatar
Arnachy69
Posts: 49
Joined: Thu Jan 08, 2015 12:10 pm

Re: Shuriken USB (USB Gecko SE (clone))

Post by Arnachy69 » Sun Mar 22, 2015 12:18 pm

happy_bunny wrote:wiiRD / kenobi debug patch where do I get this from ? wiiload works fine :-) added updated gecko net source to my website.
So you've tested Gecko DNET with you versions USB Gecko [clone] and it works
So he gives to the bottom of the frame connected.?
andre104623
Posts: 643
Joined: Wed May 07, 2014 2:24 pm

Re: Shuriken USB (USB Gecko SE (clone))

Post by andre104623 » Wed Mar 25, 2015 10:12 pm

learnhacker69 wrote:
happy_bunny wrote:wiiRD / kenobi debug patch where do I get this from ? wiiload works fine :-) added updated gecko net source to my website.
So you've tested Gecko DNET with you versions USB Gecko [clone] and it works
So he gives to the bottom of the frame connected.?
I've tried geckodotnet and it does not work. It just loops on trying to find the gecko but never does. I'm only testing this on a GameCube so far its been very disappointing. I'm using his files that he modded for shuriken USB swiss server doesn't really work ether. Maybe I got a bad one or this thing just doesn't work. After trying 3 computers and 2 gamecubes (one qoob other wasp) same results
User avatar
emu_kidid
Site Admin
Posts: 4533
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: Shuriken USB (USB Gecko SE (clone))

Post by emu_kidid » Wed Mar 25, 2015 10:24 pm

You need patched versions of all PC side software because this device doesn't identify in the same way as the original. So only use what happy_bunny has posted or anything that uses the device via a COM port.
Image
andre104623
Posts: 643
Joined: Wed May 07, 2014 2:24 pm

Re: Shuriken USB (USB Gecko SE (clone))

Post by andre104623 » Wed Mar 25, 2015 10:50 pm

emu_kidid wrote:You need patched versions of all PC side software because this device doesn't identify in the same way as the original. So only use what happy_bunny has posted or anything that uses the device via a COM port.
All the software I have been using is from his site. Let's say I want to push snes9x.dol, I put the .dol file in the modified swiss server folder I must rename the file to boot.dol so when booting up swiss I select USB gecko, and I have the modified swiss server up and running on my PC, swiss does read the USB device but will get stuck on "read directory" and will not get out of the screen till I reboot. If I remove the gecko then stick it back in very quickly while in the frozen "read directory" screen the boot.dol will show on the screen. If I try to load the .dol it will do nothing and freeze but if I close the swiss server screen on the PC then reload it again then select the boot.dol it will load sometimes. I got not64.dol to boot once and snes9x.dol booted 3 times.

Geckodotnet is what I really want running anyway pushing .dol files over is pointless for me since a SD card could load as many as I want. Geckodnet just can't find the device. Also if I have the device plugged in to both my computer and GC while booting swiss it will get stuck on "reading SD card in slot B" till I remove it then swiss will load normally. I can't tell if I'm doing something wrong or there's something wrong with the gecko but I'm still playing around with it. I might fire up my programmer and try to flash the CPLD if worst comes to worst.
User avatar
emu_kidid
Site Admin
Posts: 4533
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: Shuriken USB (USB Gecko SE (clone))

Post by emu_kidid » Thu Mar 26, 2015 2:17 am

Also if I have the device plugged in to both my computer and GC while booting swiss it will get stuck on "reading SD card in slot B" till I remove it then swiss will load normally.
You need something on the other end (like cat on the COM port) to read the output from Swiss when you use it otherwise it will block/hang. Or just don't plug the usbgecko in.
Image
andre104623
Posts: 643
Joined: Wed May 07, 2014 2:24 pm

Re: Shuriken USB (USB Gecko SE (clone))

Post by andre104623 » Thu Mar 26, 2015 3:12 am

emu_kidid wrote:
Also if I have the device plugged in to both my computer and GC while booting swiss it will get stuck on "reading SD card in slot B" till I remove it then swiss will load normally.
You need something on the other end (like cat on the COM port) to read the output from Swiss when you use it otherwise it will block/hang. Or just don't plug the usbgecko in.
OK can you explain what you mean? I already understand not have the USB gecko plugged in on boot up. I was just saying that's what happens if I leave it in it's not like I can compare the real thing with the clone. I have no idea how the real USB gecko reacts to swiss if this is Normal. I been trying to get a hold of happy_bunny about the issues but he has read my emails and hasn't responded about anything that's troubling.
andre104623
Posts: 643
Joined: Wed May 07, 2014 2:24 pm

Re: Shuriken USB (USB Gecko SE (clone))

Post by andre104623 » Thu Mar 26, 2015 3:19 am

Does this explain why after I read the USB gecko in swiss it hangs on read directory till I unplug the gecko then plug it back in?
User avatar
emu_kidid
Site Admin
Posts: 4533
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: Shuriken USB (USB Gecko SE (clone))

Post by emu_kidid » Thu Mar 26, 2015 3:34 am

It should work automatically work with this, but disable the output debug over USB Gecko option in Swiss too.
Image
andre104623
Posts: 643
Joined: Wed May 07, 2014 2:24 pm

Re: Shuriken USB (USB Gecko SE (clone))

Post by andre104623 » Thu Mar 26, 2015 3:36 am

emu_kidid wrote:It should work automatically work with this, but disable the output debug over USB Gecko option in Swiss too.
OK haven't tried that yet. Will report back.
User avatar
Arnachy69
Posts: 49
Joined: Thu Jan 08, 2015 12:10 pm

Re: Shuriken USB (USB Gecko SE (clone))

Post by Arnachy69 » Thu Mar 26, 2015 7:57 am

Hmmm as it not works with Gecko Dnet what can you do with it
that's the reason i'll will buy this thing to hack wii and Gamecube codes with it :(
andre104623
Posts: 643
Joined: Wed May 07, 2014 2:24 pm

Re: Shuriken USB (USB Gecko SE (clone))

Post by andre104623 » Thu Mar 26, 2015 1:53 pm

learnhacker69 wrote:Hmmm as it not works with Gecko Dnet what can you do with it
that's the reason i'll will buy this thing to hack wii and Gamecube codes with it :(
I've tried everything to get this thing to work with geckodotnet it just can't find the device. I need someone who bought this thing to report his/her findings. What's even more troubling that it seems I can't get a hold of happy_bunny which makes me think it was a failed project and he is just trying to make back his losses. I could be wrong but this guy posted this device on almost every site I go to. Gbatemp, gc-forever, eBay all have the same listing.
tueidj
Posts: 564
Joined: Fri May 03, 2013 6:57 am

Re: Shuriken USB (USB Gecko SE (clone))

Post by tueidj » Thu Mar 26, 2015 4:24 pm

So you installed the FTDI drivers and you're using the special gecko.net build (modified for the shuriken USB) from his website?
andre104623
Posts: 643
Joined: Wed May 07, 2014 2:24 pm

Re: Shuriken USB (USB Gecko SE (clone))

Post by andre104623 » Thu Mar 26, 2015 5:02 pm

tueidj wrote:So you installed the FTDI drivers and you're using the special gecko.net build (modified for the shuriken USB) from his website?
Yes everything I'm using is from his site.
tueidj
Posts: 564
Joined: Fri May 03, 2013 6:57 am

Re: Shuriken USB (USB Gecko SE (clone))

Post by tueidj » Fri Mar 27, 2015 3:11 am

The FTDI drivers are not on his site. Did you install them or not?
andre104623
Posts: 643
Joined: Wed May 07, 2014 2:24 pm

Re: Shuriken USB (USB Gecko SE (clone))

Post by andre104623 » Fri Mar 27, 2015 5:35 am

tueidj wrote:The FTDI drivers are not on his site. Did you install them or not?
http://www.ftdichip.com/Drivers/D2XX.htm
This is where I got it and yes it is on his site. If I didn't install it I wouldn't of been able to use swiss server with it. My problem is geckodotnet
tueidj
Posts: 564
Joined: Fri May 03, 2013 6:57 am

Re: Shuriken USB (USB Gecko SE (clone))

Post by tueidj » Fri Mar 27, 2015 7:29 am

So swiss server can find the device but gecko.net can't, doesn't sound like a faulty device...
happy_bunny
Posts: 106
Joined: Mon Mar 09, 2015 10:57 pm

Re: Shuriken USB (USB Gecko SE (clone))

Post by happy_bunny » Fri Mar 27, 2015 11:35 am

did you use gecko dot net 0.66.8 of the net or the one from my website? 0.66.8 don't work. 0.63.0 should work with a wii. are you connecting it to the wii or gamecube ?
Last edited by happy_bunny on Fri Mar 27, 2015 9:31 pm, edited 1 time in total.
andre104623
Posts: 643
Joined: Wed May 07, 2014 2:24 pm

Re: Shuriken USB (USB Gecko SE (clone))

Post by andre104623 » Fri Mar 27, 2015 12:56 pm

happy_bunny wrote:did you use gecko dot net 0.66.8 of the net or the one from my website? 0.66.8 don't work. 0.66.3 should work with a wii. are you connecting it to the wii or gamecube ?
GameCube and I'm using the one from your site. I haven't tried hooking up my Wii its in a box somewhere. Geckodotnet is supposed to work with GameCube correct and wiird is for Wii?
andre104623
Posts: 643
Joined: Wed May 07, 2014 2:24 pm

Re: Shuriken USB (USB Gecko SE (clone))

Post by andre104623 » Fri Mar 27, 2015 1:01 pm

I'm at work right now but when I get home I will find my Wii and try using the USB device with that
happy_bunny
Posts: 106
Joined: Mon Mar 09, 2015 10:57 pm

Re: Shuriken USB (USB Gecko SE (clone))

Post by happy_bunny » Fri Mar 27, 2015 1:04 pm

I have only tried gecko dot net 0.63.0 with the wii and my failed project :-P, I thought wiird and gecko dot net are for the wii only !

Can you try this on the wii before we do anything else to make sure that the hardware is all good.

1) download / install the latest homebrew channel software on the wii
2) Connect the gecko clone into slotb of the wii
3) Fire up the wii and go to the homebrew channel start it.
4) In the bottom right hand corner you should see the little gecko symbol is lit up (this is important it means the wii can see the device as usb gecko this needs to be lit).
5) add this to your enviroment settings WIILOAD and then the comm port number the gecko uses for example COM4
6) Download devkitpro for the wii / gamecube and the examples. Go to the wii examples compile one (tools->make) I used the gx triangle demo then go to tools->run, wiiload should transfer the code from the pc to the wii and you should see a triangle on your screen.

does that work ?
andre104623
Posts: 643
Joined: Wed May 07, 2014 2:24 pm

Re: Shuriken USB (USB Gecko SE (clone))

Post by andre104623 » Sun Mar 29, 2015 3:33 am

Everything is working fine on the Wii I was under the impression that everything worked on GameCube sorry for the confusion. Screenshots are a little messed up they have green lines going though them. But running live cheats on Mario kart Wii is very cool. I will try some texture hacks next and some more games.
User avatar
emu_kidid
Site Admin
Posts: 4533
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: Shuriken USB (USB Gecko SE (clone))

Post by emu_kidid » Sun Mar 29, 2015 9:44 am

Lines through them? sounds like data loss?
Image
happy_bunny
Posts: 106
Joined: Mon Mar 09, 2015 10:57 pm

Re: Shuriken USB (USB Gecko SE (clone))

Post by happy_bunny » Sun Mar 29, 2015 10:26 am

thats what I was thinking at first, but its odd the way the image is displayed in the gc / wii the embedded frame buffer stores the data in YCbCr format like this

Y = brightness
Cr = chrominance (color)
Cb = chrominance (color)

it looks like the Cr & Cb bytes for some of the lines are not getting across or being processed correctly but the Y is, which is odd. If you wanted a black and white image it would display correctly.
tueidj
Posts: 564
Joined: Fri May 03, 2013 6:57 am

Re: Shuriken USB (USB Gecko SE (clone))

Post by tueidj » Sun Mar 29, 2015 12:09 pm

The embedded framebuffer never uses YCbCr format. Perhaps you are confusing it with the external framebuffer.
andre104623
Posts: 643
Joined: Wed May 07, 2014 2:24 pm

Re: Shuriken USB (USB Gecko SE (clone))

Post by andre104623 » Sun Mar 29, 2015 2:02 pm

emu_kidid wrote:Lines through them? sounds like data loss?
RMCE01-003.jpg
(253.96 KiB) Not downloaded yet
RMCE01-002.png
(493.7 KiB) Not downloaded yet
RMCE01-001.jpg
(31.07 KiB) Not downloaded yet
Its really not a problem right now because I'm playing around with the live cheats. I'm sure you guys will figure it out
Post Reply