Page 1 of 1

NeoCD won't load on WKF cube.

Posted: Sun Apr 28, 2013 11:41 pm
by siphoned
I can't load NeoCD via megaloader on a WKF gamecube. Megaloader says WKF detected - not compatible (or something like that). Has anyone had this problem or am I just missing something?

The cube has WKF installed and is running 1.5 firmware (for now). I have not loaded Swiss as initial iso. I have not installed the disc drive to the wiikey. I can load the Megaloader 1.3 iso from the wiikey menu (just like any other game) and use it to launch other emulators with no problem (from SDB/emus) but when I try to load the NeoCD Redux 'unofficial' it hangs on the search dvd menu with the picture of the disc and says WKF not compatible. Never looks for the SD in slot B. Is there a work around for this? I like it set up this way..... but not if it doesn't work. Will this problem go away if I install the disc drive to the WKF?

Re: NeoCD won't load on WKF cube.

Posted: Sun Apr 28, 2013 11:45 pm
by siphoned
Wait, it does look in Slot B first because it checks there before the DVD (and thus the WKF). Still doesn't load.

Re: NeoCD won't load on WKF cube.

Posted: Sun Apr 28, 2013 11:53 pm
by megalomaniac
did you swap cards at any time after starting megaloader??
if so, you will have to search twice....
....or its named different from what is expected "neocd-redux.dol"
this has been corrected in v2....(finally i hope)

Re: NeoCD won't load on WKF cube.

Posted: Mon Apr 29, 2013 12:05 am
by siphoned
I didn't swap any cards. 32GB wbfs formatted card in the WKF and 8GB card in slot B SDGecko with all the needed folders and files for megaloader. Everything in place at startup and nothing moved around afterwards. I know the dol is named right because I was using the same 8GD SD card in a xeno cube with megaloader iso burned to disc. Hmm... the megaloader disc I was using on the xeno cube is a different version than the megaloader iso I put on the WKF cube. I'll double check my file name.

Re: NeoCD won't load on WKF cube.

Posted: Mon Apr 29, 2013 12:37 am
by siphoned
I see, The megaloader iso I burned to disc for the xeno cube was 1.2 version. The iso I loaded to the WKF was 1.3 version. The disc is OK with file name neocdredux.dol but the 1.3 version on the wiikey wants neocd-redux.dol. A quick change in file name and everything is working. I seem to have the same problem with some of the other emulator dols (cube64, VBA GX, Genesis plus, .....)

Looks like I'm in need of a list for proper dol names to use with Megaloader 1.3 version. I've still been going by this list....

FCE Ultra GX = fceugx-gc.dol
Snes9x GX = snes9xgx-gc.dol
Cube64 = cube64.dol
VBA GX = vbagx_gc.dol
Genesis Plus = genplus_cube.dol
Hugo GX = hugo_cube.dol
NeoGeo CD = neocdredux.dol
NeoGeo Pocket = neopopgc.dol
CubeSX = cubeSX.dol
VectrexGC = vecxgc.dol
Colecovision = collisionGC.dol

ScummVM = scummvm-gc.dol
Chip8 = chip8.dol
Pong = pong.dol
Quake = quake.dol
Fruit Remover = fruitremover.dol
Tetris = tetris.dol
Ascii Fighter = af.dol
Breakout = breakout.dol
Snowlords = snowlords.dol
Super Methane Brothers = methane.dol

I'll have to burn off a new iso disc of 1.3 to bring that xeno cube up to date too. And Thanks!

Re: NeoCD won't load on WKF cube.

Posted: Mon Apr 29, 2013 1:16 am
by megalomaniac

Re: NeoCD won't load on WKF cube.

Posted: Mon Apr 29, 2013 2:00 am
by siphoned
Hmm... I have the other file names correct. Hmm... I fixed the file name for Neocd and tested it. It worked fine with the correct file name. I used the system reboot function in the Neocd emulator to go back to the megaloader main screen. Thats when I had problems loading the other emulators. They all say WKF detected - not working. Yet they all work fine if I power cycle or load them first. I see, I only get the problem if I load an emulator and use the emulator's on screen option to restart the cube to enter another emu. Like if I go into Neocd, play a game, leave the emu by selecting the system restart option and try to enter a different emu like genesis plus. Megaloader skips the slot B search at that point and goes straight to dvd search. This is not a problem for me. I don't have to use the system restart options in emulators, I can use the power button on the cube just the same. All is good. Much thanks for the help and all the work.