Trouble with GCRebuilder

All your homebrew software needs & discussion
Post Reply
Lisa McRad
Posts: 5
Joined: Thu Jan 10, 2019 2:13 pm

Trouble with GCRebuilder

Post by Lisa McRad » Thu Jan 10, 2019 4:50 pm

Hello everybody!

I am trying to translate GiFTPiA and I'm trying to solve two problems with GCRebuilder that I'm having.

1. The rip I had created from the software itself acts weird when it's opened. I get a warning that it was "Unable to read beyond the end of the stream". This is strange since A. I ripped the game with GCRebuilder and have made ISOs with those rips before... B.It opens the ISO just fine and I have no ideal whats causing it.

2. On the successful builds, the ISOs just don't run at all. I've heard that this was due to problems with the boot files being ripped wrong, but before I tried to replace the start.dol with the default.dol problem #1 happened.

In all honesty, I'm really hoping that somebody can understand what happened to cause problem 1. Not only because it can help me actually find out the answer to problem 2, but its a real pain to work with this, especially since there's no other re builder out there that seems to work.

I'm also ok with you just straight up suggesting alternatives, basically since this is already driving me batty and something else may be less cumbersome to deal with.

Thanks to anybody who replies to this!

EDIT: ISSUE 1 IS RESOLVED PLEASE DONT POST ABOUT ISSUE 1 SOLUTIONS IM GOOD NOW :lol: :lol: :lol: :lol: :lol:
Last edited by Lisa McRad on Thu Jan 10, 2019 9:08 pm, edited 1 time in total.
Lisa McRad
Posts: 5
Joined: Thu Jan 10, 2019 2:13 pm

Re: Trouble with GCRebuilder

Post by Lisa McRad » Thu Jan 10, 2019 9:08 pm

Lisa McRad wrote:
Thu Jan 10, 2019 4:50 pm
Hello everybody!

I am trying to translate GiFTPiA and I'm trying to solve two problems with GCRebuilder that I'm having.

1. The rip I had created from the software itself acts weird when it's opened. I get a warning that it was "Unable to read beyond the end of the stream". This is strange since A. I ripped the game with GCRebuilder and have made ISOs with those rips before... B.It opens the ISO just fine and I have no ideal whats causing it.

2. On the successful builds, the ISOs just don't run at all. I've heard that this was due to problems with the boot files being ripped wrong, but before I tried to replace the start.dol with the default.dol problem #1 happened.

In all honesty, I'm really hoping that somebody can understand what happened to cause problem 1. Not only because it can help me actually find out the answer to problem 2, but its a real pain to work with this, especially since there's no other re builder out there that seems to work.

I'm also ok with you just straight up suggesting alternatives, basically since this is already driving me batty and something else may be less cumbersome to deal with.

Thanks to anybody who replies to this!
Okay so I have a quick update as of now. The ISO rebuilding issue has been FIXED :lol:

But... the Isos still dont work :(

I was thinking that if I ripped them with another program, they would actually build perfectly and I'd be scott free!

That was half of the truth... I was able to make the ISO, but not get it to run.

I am still experimenting with a dump of the pure, non soiled, ISO... yet I still can't get it to run in Dolphin. If anybody has any ideal how to resolve Issue 2 please tell me.
Lisa McRad
Posts: 5
Joined: Thu Jan 10, 2019 2:13 pm

Re: Trouble with GCRebuilder

Post by Lisa McRad » Thu Jan 10, 2019 9:22 pm

GOOD NEWS EVERYBODY IT WORKS NOW!!!!!!!!!!

:D :D :D :D :D :D :D :D

I just had to replace start.dol with the main file for the game and everything went a-ok!!!!!!!!


Anyways uh... I guess I'll get to work onthe game!
User avatar
emu_kidid
Site Admin
Posts: 4406
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: Trouble with GCRebuilder

Post by emu_kidid » Fri Jan 11, 2019 1:09 am

You may also run into other issues with GCRebuilder not placing files appropriately on 32 byte boundaries for audio streaming if this game uses that. There are other tools like fstfix which can fix such issues.
Image
Lisa McRad
Posts: 5
Joined: Thu Jan 10, 2019 2:13 pm

Re: Trouble with GCRebuilder

Post by Lisa McRad » Fri Jan 11, 2019 3:55 pm

emu_kidid wrote:
Fri Jan 11, 2019 1:09 am
You may also run into other issues with GCRebuilder not placing files appropriately on 32 byte boundaries for audio streaming if this game uses that. There are other tools like fstfix which can fix such issues.
Giftopia uses a lot of streaming audio... but it seems like there's really no problem with any of it so far. I hope that stays that way
Post Reply