Swiss0.3 ISO and XenoGC 1.0 boot issue

ViperGC/Qoob/etc
Post Reply
FerociousGC
Posts: 2
Joined: Thu Jan 19, 2012 10:14 am
Location: Central Florida, US

Swiss0.3 ISO and XenoGC 1.0 boot issue

Post by FerociousGC » Wed Apr 10, 2013 8:38 pm

Hello all,

I DL Swiss 0.3 ISO [swiss(ntsc).iso], burnt the ISO to RiDATA mimi DVD-R (4x) disc at 2x. Tried two different Win7 with IMGburn and CDBurnerXP. Mini DVD Discs hangs on the NGC splash screen. What am I doing wrong? Am I suppose to have the Wiikey SD Card Adapter inserted with files or add something to the ISO to make it work. :/

Goal is to use mplayer-ce to play videos from an SD card, backups would also be nice too. :)

Thanks
User avatar
megalomaniac
Posts: 2480
Joined: Sun Aug 21, 2011 5:33 am
Location: Drunk in Texas
Contact:

Re: Swiss0.3 ISO and XenoGC 1.0 boot issue

Post by megalomaniac » Wed Apr 10, 2013 9:17 pm

use the PAL iso
there is an issue with NTSC.iso
emu_kidid wrote: beer is like WD40 for megalomaniac's brain, gets the gears moving
>>> BadAssConsoles.com <<<

Image Image Image
FerociousGC
Posts: 2
Joined: Thu Jan 19, 2012 10:14 am
Location: Central Florida, US

Re: Swiss0.3 ISO and XenoGC 1.0 boot issue

Post by FerociousGC » Wed Apr 10, 2013 11:00 pm

I burnt "swiss(pal).iso" and.... that worked! Dude your Kung-Fu is the best! Well right after "emu_kidid"... :D

Thanks!
megalomaniac wrote:use the PAL iso
there is an issue with NTSC.iso
User avatar
mautheus
Posts: 69
Joined: Tue Mar 29, 2011 2:20 am
Location: Brazil
Contact:

Re: Swiss0.3 ISO and XenoGC 1.0 boot issue

Post by mautheus » Thu Apr 11, 2013 3:14 am

FerociousGC wrote:I burnt "swiss(pal).iso" and.... that worked! Dude your Kung-Fu is the best! Well right after "emu_kidid"... :D

Thanks!
megalomaniac wrote:use the PAL iso
there is an issue with NTSC.iso
"In Brazilian" translate please.

Os 2 caras são muito bons. Eles dominam a cena GC. O megalomaniac mexe mais com hardware e o emu_kidid com software. Os dois junto arrebentam.
Image
turfster
Posts: 73
Joined: Mon Jun 03, 2013 11:37 pm

Re: Swiss0.3 ISO and XenoGC 1.0 boot issue

Post by turfster » Tue Jul 09, 2013 10:12 pm

So glad I just read this. I just wasted 4 mini dvd-r's. Now the pal version works perfectly and booted up swiss. Accessed my sd card in slot a. Time to add a game while I wait for my ide-exi to come in the mail.
User avatar
emu_kidid
Site Admin
Posts: 4645
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: Swiss0.3 ISO and XenoGC 1.0 boot issue

Post by emu_kidid » Tue Jul 09, 2013 10:22 pm

apologies, next major release - when it arrives (and the nightly builds) have this fixed.
Image
User avatar
Apache Thunder
Posts: 92
Joined: Wed Aug 28, 2013 5:12 am

Re: Swiss0.3 ISO and XenoGC 1.0 boot issue

Post by Apache Thunder » Wed Oct 02, 2013 9:19 pm

I built an NTSC ISO that retains the normal retail game filesystem. (as in uses Apploader with working opening.bnr file among others)

It boots on my XenoGC modchipped GameCube:

SwissGCMISO.rar

I've burnt this to my own DVD and shows up in GameCube BIOS with correct banner and description. It boots and I have had no issues with it. I'm not sure if anyone has built a Swiss ISO in this manner, so pull the link if it's redundant or not allowed. ;)

This ISO uses Swiss v0.3 r241.

I recall using the WiiFusion version of Swiss and simply replaced the Apploader.ldr file with Swiss and it boots. Of coarse all files relating to Mario Kart that the GCM file originally had were removed. It's untrimmed as well by the way (only 900 or so KB due to RAR file compression). Rebuilt using GCRebuilder.

When I boot this it automatically searches for a SD card on the memory card slots then displays the current DVD loaded in the GameCube. Should work on a softmodded/chipped Wii as well.
ImageImage
User avatar
emu_kidid
Site Admin
Posts: 4645
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: Swiss0.3 ISO and XenoGC 1.0 boot issue

Post by emu_kidid » Wed Oct 02, 2013 10:29 pm

megalomaniac's nightly builds also include bootable ISOs.
Image
User avatar
Apache Thunder
Posts: 92
Joined: Wed Aug 28, 2013 5:12 am

Re: Swiss0.3 ISO and XenoGC 1.0 boot issue

Post by Apache Thunder » Wed Oct 02, 2013 10:38 pm

I do recall checking his ISO files.

His ISO's like yours use a lone dol file with a catalog file which is likely something built in Linux/Homebrew ISO builder of some kind, which for the OP of this thread had initial issues with.

I had modified a retail ISO to load Swiss because at the time I did not know if my XenoGC would boot non-standard ISO formats (which until I read this thread did not know for sure. He was able to boot the PAL version so that must mean XenoGC can. But none the less....)

Hence the above GCM file. At least that one I know for sure will work. I had posted it here in-case anyone else has issues with the non-standard homebrew ISO and can use this to burn a 100% gonna work ISO. This even boots in Dolphin. :D
Last edited by Apache Thunder on Wed Oct 02, 2013 10:46 pm, edited 1 time in total.
ImageImage
User avatar
emu_kidid
Site Admin
Posts: 4645
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: Swiss0.3 ISO and XenoGC 1.0 boot issue

Post by emu_kidid » Wed Oct 02, 2013 10:46 pm

No problem. The el-torito should boot fine :)
Image
User avatar
Apache Thunder
Posts: 92
Joined: Wed Aug 28, 2013 5:12 am

Re: Swiss0.3 ISO and XenoGC 1.0 boot issue

Post by Apache Thunder » Wed Oct 02, 2013 10:48 pm

Does the "el-torito" show up in the GameCube BIOS with a banner icon and description? I suppose that catalog file might contain that information.

I wanted my personal copy to look "official" on the GameCube menu. I'm just OCD like that and was one reason why I had just went and hacked a retail GCM to boot Swiss instead. :P
ImageImage
User avatar
emu_kidid
Site Admin
Posts: 4645
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: Swiss0.3 ISO and XenoGC 1.0 boot issue

Post by emu_kidid » Wed Oct 02, 2013 11:03 pm

Yes, the banner icon and description show up in the GameCube BIOS. El-torito is overkill for Swiss as I don't use the iso9660 file system to store anything (but you could if you wanted to).

The GameCube disc format fits nicely around the iso9660 standard which is why it works in the original bios and can also be read as a iso9660 disc in the PC.
Image
User avatar
Apache Thunder
Posts: 92
Joined: Wed Aug 28, 2013 5:12 am

Re: Swiss0.3 ISO and XenoGC 1.0 boot issue

Post by Apache Thunder » Wed Oct 02, 2013 11:25 pm

Ahh I see. My burned discs do seem to be readable in my drive with Dolphin. So at least for me they both work. Official discs of coarse aren't readable on my PC since I don't have one of those rare drives that can be modified to read them. :P
ImageImage
Post Reply