Swiss v0.4 with Viper GC Extreme and BBA attached

ViperGC/Qoob/etc
Post Reply
User avatar
bytesaber
Posts: 49
Joined: Fri Aug 19, 2016 9:45 pm

Swiss v0.4 with Viper GC Extreme and BBA attached

Post by bytesaber » Tue Oct 04, 2016 7:11 am

I installed a Viper GC Extreme last night. I copied swiss_r371-lz-viper.dol (Swiss v0.4r371) to the flash memory. Works great. Except when the BBA is installed. Cobra just hangs displaying "Running DOL File". Any ideas?
User avatar
bytesaber
Posts: 49
Joined: Fri Aug 19, 2016 9:45 pm

Re: Swiss v0.4 with Viper GC Extreme and BBA attached

Post by bytesaber » Tue Oct 04, 2016 8:00 am

Also noticed that I am no longer being prompted for progressive scan, when the game boots.
User avatar
emu_kidid
Site Admin
Posts: 4533
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: Swiss v0.4 with Viper GC Extreme and BBA attached

Post by emu_kidid » Tue Oct 04, 2016 9:45 pm

Viper issues some commands to the same slot the BBA is in and it potentially it hangs as a result, is it only Swiss that has that issue? Have you tried flashing a non "viper" compressed DOL to it?

Hold B to be prompted for progressive scan, that setting is stored in SRAM and maybe the Viper intercepts SRAM communication or something strange.
Image
User avatar
bytesaber
Posts: 49
Joined: Fri Aug 19, 2016 9:45 pm

Re: Swiss v0.4 with Viper GC Extreme and BBA attached

Post by bytesaber » Wed Oct 05, 2016 2:35 pm

I have not tried a non viper precompiled flash. I can for good ol science.

Last night, strangely, the cube started prompting me for progressive scan again. I tested both Direct Disc boot and Original BIOS from Cobra 2.1. I also tested from Swiss. Each method automatically prompted me. *shrug* So I never had a chance to try holding B.

I noticed however, my Wind Waker save file was dated 2000 01 01 after playing and saving. That was weird. I went and checked the Gamecube's date. It was set. I tried overwriting the save again. Same thing.

Are Vipers known to cause odd intermittent issues of this nature? This may be off topic now. But your thoughts are always helpful.
User avatar
bytesaber
Posts: 49
Joined: Fri Aug 19, 2016 9:45 pm

Re: Swiss v0.4 with Viper GC Extreme and BBA attached

Post by bytesaber » Wed Oct 05, 2016 4:56 pm

PS, thanks for compiling a version for Viper in your releases.
User avatar
emu_kidid
Site Admin
Posts: 4533
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: Swiss v0.4 with Viper GC Extreme and BBA attached

Post by emu_kidid » Wed Oct 05, 2016 10:44 pm

The Viper doesn't properly support the real time clock/SRAM unless if a special initialisation command to silence it is issued to it which I'm not currently doing.
Image
SeeDborg
Posts: 2
Joined: Sat May 25, 2013 8:46 am

Re: Swiss v0.4 with Viper GC Extreme and BBA attached

Post by SeeDborg » Sun Feb 05, 2017 3:58 pm

Hi,
I'd like to push the latest version of SwissGC on the flash memory of my Gamecube with a ViperGC Extreme.
I could do this without problems on Windows 7, but I can't find any working drivers for Windows 10.

Is there a workaround or other working drivers ?
User avatar
bytesaber
Posts: 49
Joined: Fri Aug 19, 2016 9:45 pm

Re: Swiss v0.4 with Viper GC Extreme and BBA attached

Post by bytesaber » Sun Feb 05, 2017 9:14 pm

A Windows 7 Virtual Machine, might be a route to try. Then attach the USB virtually to it and try the same old programs. Or go all the way to an XP virtual machine to really match the era for that flashing tool. Just a random untested idea.
Post Reply