Page 1 of 1

IPLboot on Qoob pro doesnt work

Posted: Sun Apr 22, 2018 3:01 pm
by yamaharacer
Hi,
I wanted to use IPLboot from Streetwalrus, flashed Revision 3 on an empty qoob pro as bios.

SD Card formated exfat size 64GB. Swiss als ipl.dol in root of the SD card.

When I start my cube nothing happens. What do I do wrong?

Could the problem be that I have also installed a Xeno gc?

Re: IPLboot on Qoob pro doesnt work

Posted: Sun Apr 22, 2018 3:21 pm
by Extrems
You have to build from source for exFAT support.

Re: IPLboot on Qoob pro doesnt work

Posted: Sun Apr 22, 2018 3:51 pm
by yamaharacer
I have solved the problem. Though I have used the exfat supported source it seems swiss still doesnt support exfat. after formating the sd card to fat32 it works.

Re: IPLboot on Qoob pro doesnt work

Posted: Sun Apr 22, 2018 10:47 pm
by Streetwalker
Yeah, I'm not shipping exFAT yet exactly because of this. emu_kidid is working on moving Swiss to FatFs which should finally bring exFAT support.
That said, there's no good reason to use exFAT on the GC, FAT32 supports 2TiB file systems with 512 byte sectors (maximum SDHC/XC capacity), and the 4GiB file limitation shouldn't be an issue either, unless you're writing some homebrew that can take advantage of such huge files.

Re: IPLboot on Qoob pro doesnt work

Posted: Mon Apr 23, 2018 6:44 pm
by Streetwalker
It looks like the version of FatFs I was using had issues with exFAT. I've published a new build with the latest FatFs release and exFAT enabled by default. Feel free to try it, but Swiss itself still doesn't support exFAT (that's WIP).