DVD Issue After Wasp Fusion Install and Audio Streaming Question

ViperGC/Qoob/etc
Post Reply
SkydivinGirl
Posts: 16
Joined: Sun Sep 15, 2019 3:42 pm

DVD Issue After Wasp Fusion Install and Audio Streaming Question

Post by SkydivinGirl » Sun Sep 15, 2019 3:57 pm

Hey everyone!

First, I want to thank everyone who contributes to this forum. The information here has been invaluable to me while hacking my GC. :)

I recently modded my GC with a GC Dual and a Wasp Fusion (using citrus3000psi's GC Wasp QSB). After a lot of playing around with firmware downgrades and Swiss, I have a perfectly functional autoboot Wasp Fusion system that works with both SD cards and the DVD drive.

So, what's the problem? Well, I have two Wasp Fusions and I'm going to put the second one in another system. Since my GC is opened and confirmed working, I unplugged the fully functional Wasp and put in the other one. Downgrading the firmware and getting everything configured was simple since I knew what to do. Autoboot is working on the SD and the DVD drive attempts to autoboot but it's like it cannot read the disc. I'm using all the cables that work on the other Wasp so I know those are good. I'm also 100% sure I configured the Wasp properly. Here's a video of what it does.

https://youtu.be/pENkiPYa8i8

The problem must be with the Wasp but I'm not sure what the issue may be. I've looked at all the solder joints and connectors under a microscope and everything looks OK. If I don't find suggestions here then I'll probably reflow all the solder joints to see if that fixes the issue.

For the audio streaming question, I know the Wasp does not work with streaming audio but the SD Gecko is supposed to. If I boot into Swiss using the Wasp then run a game from the Gecko, I still get no audio. If I try to boot from an Action Replay disc into the SD Gecko then run a streaming audio game, I get an error message on the screen when it tries to start the streaming audio. Can anyone shed some light on this?

Thank you!

Heather
User avatar
Extrems
Posts: 806
Joined: Tue Aug 17, 2010 10:40 pm
Location: Québec, Canada
Contact:

Re: DVD Issue After Wasp Fusion Install and Audio Streaming Question

Post by Extrems » Sun Sep 15, 2019 4:43 pm

SkydivinGirl wrote:
Sun Sep 15, 2019 3:57 pm
Can anyone shed some light on this?
This is because of the alternate read patches. They don't yet support streaming audio.
The current Git master no longer error out.
SkydivinGirl
Posts: 16
Joined: Sun Sep 15, 2019 3:42 pm

Re: DVD Issue After Wasp Fusion Install and Audio Streaming Question

Post by SkydivinGirl » Sun Sep 15, 2019 6:21 pm

Hi Extrems! I really appreciate everything you do for the community!

Do you mean the current Swiss Git master?

Thanks,

Heather
User avatar
Extrems
Posts: 806
Joined: Tue Aug 17, 2010 10:40 pm
Location: Québec, Canada
Contact:

Re: DVD Issue After Wasp Fusion Install and Audio Streaming Question

Post by Extrems » Sun Sep 15, 2019 6:28 pm

Yes, which you'd have to build yourself. There's still no streaming audio.
SkydivinGirl
Posts: 16
Joined: Sun Sep 15, 2019 3:42 pm

Re: DVD Issue After Wasp Fusion Install and Audio Streaming Question

Post by SkydivinGirl » Sun Sep 15, 2019 6:48 pm

I'll give it a try to see if I can get rid of that error when booting audio streaming titles from the Gecko SD using the Action Replay boot disc.

On the GC-Forever Wiki's Audio Streaming page, it says that I can get original audio streaming titles working again with the WKF installed by doing a wire mod but I can't find information on what that mod is. Does anyone have a link?

https://www.gc-forever.com/wiki/index.p ... _Streaming

Heather

*EDIT*

I think I just found a picture to do this mod on the WKF for DVD streaming audio fix. I hope this is the right one.

https://www.gc-forever.com/forums/downl ... php?id=967
User avatar
emu_kidid
Site Admin
Posts: 4573
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: DVD Issue After Wasp Fusion Install and Audio Streaming Question

Post by emu_kidid » Mon Sep 16, 2019 5:07 am

SkydivinGirl wrote:
Sun Sep 15, 2019 6:48 pm

I think I just found a picture to do this mod on the WKF for DVD streaming audio fix. I hope this is the right one.

https://www.gc-forever.com/forums/downl ... php?id=967
Yes, that's the one, it should pass audio data from the real drive through to the GameCube.

As for Swiss, I'll be building a release from master in the next few days, my automated build system just needs to work off a branch of libOGC cause the merge request for something unrelated hasn't been merged in yet :(
Image
SkydivinGirl
Posts: 16
Joined: Sun Sep 15, 2019 3:42 pm

Re: DVD Issue After Wasp Fusion Install and Audio Streaming Question

Post by SkydivinGirl » Mon Sep 16, 2019 12:42 pm

That's great news! I'll wait for the automated build. You've done a great job with the software!

I did install and successfully test the wire mod. Streaming audio is working perfectly from the DVD drive. :D

I hope I can figure out the other Wasp Fusion. I think I'll install the streaming audio wire mod, aggressively clean the flux residue that is there from the factory, then try it again. I double checked all the soldering last night and it all looks good so I don't think re-flowing the solder will make a difference.

Thanks everyone,

Heather
SkydivinGirl
Posts: 16
Joined: Sun Sep 15, 2019 3:42 pm

Re: DVD Issue After Wasp Fusion Install and Audio Streaming Question

Post by SkydivinGirl » Wed Sep 25, 2019 4:41 pm

Well, cleaning the factory flux residue from the board did not make a difference on the Wasp that is having issues so I guess I'll have to pull out the multi-meter and test all the pins on the cable sockets. That should be tedious. :)

Thanks again to everyone who responded to this thread. Your help was very welcome and appreciated.

Heather
SkydivinGirl
Posts: 16
Joined: Sun Sep 15, 2019 3:42 pm

Re: DVD Issue After Wasp Fusion Install and Audio Streaming Question

Post by SkydivinGirl » Mon Nov 04, 2019 12:46 am

Just a quick update on this issue. I checked every pin on all the connectors for continuity to the PCB as well as shorts between pins but everything checked out OK. The system seems to think the DVD drive is the SD card in the Wasp Fusion. If I leave the door of the DVD drive open, Swiss still opens and tries to read (no disc movement) but I can wait for the device selection menu, close the door, then select the DVD drive and boot the disc from there. Just plain weird.

Even though it's not perfect, it's completely usable for both discs and ODE so I'm not going to mess with it anymore. I had two Wasp Fusions and I took the WiiKey Fusion out of my Wii since the latest soft mods remove the need for an ODE in the Wii.

So, I now have three modded GameCube systems with GCDuals, Wasp/WiiKey Fusion ODEs with MicroSD slots, XenoGC Mod Chips, and Serial Port SD Adapters. I suppose I'll sell or trade the system having this issue. It is fully functional but takes a bit longer to boot discs because of the problem.

One last question for all of you. I downgraded the firmware on all these WiiKey/Wasp Fusions to 1.0 and configured the settings so they would be able to auto boot. However, when I turn on the system with a SD card in, it boots to the GC menu and I have to open Swiss from there. I thought it was supposed to boot into Swiss that is built into the WKF. Is that right or is it supposed to auto boot to a file on the SD card?

Thanks,

Heather
SkydivinGirl
Posts: 16
Joined: Sun Sep 15, 2019 3:42 pm

Re: DVD Issue After Wasp Fusion Install and Audio Streaming Question

Post by SkydivinGirl » Thu Nov 07, 2019 12:24 am

After doing a bit more reading on this forum (thanks!) it seems like the WiiKey/Wasp Fusion's autoboot does not work with every SD card. I've tried a bunch of different cards but cannot get any of them to boot directly into Swiss. Even so, selecting Swiss from the menu is quick enough so it's not a big deal.

The GC above that boots into Swiss instead of loading the DVD is actually kind of nice since it lets me configure Swiss options for the game when booting DVDs. The only downside is waiting for the initial scan to finish.

Thanks again to everyone for their help.

Heather
SkydivinGirl
Posts: 16
Joined: Sun Sep 15, 2019 3:42 pm

Re: DVD Issue After Wasp Fusion Install and Audio Streaming Question

Post by SkydivinGirl » Wed Nov 13, 2019 2:47 am

I keep responding to my own posts. :)

I finally found a SD card that autoboots in my Wasp Fusion. Yay!!!

https://www.amazon.com/HP-microSDXC-Mem ... B07SFZP6TD

I put a single ISO on the card and it booted into Swiss. My Swiss was not at the latest version so I put the FZN on the card and it wouldn't autoboot. Odd. After updating Swiss, I removed the FZN and put a second ISO on the card and autobooting worked again.

From what I've read, 64GB is the maximum addressable space for the Wasp Fusion. Please let me know if I'm wrong.

I also build my SD2SP2 devices today and they are working perfectly in my GC. Well, I think I have a fairly decked out system at this time. Time to start modding my next console. :D

Thanks everyone,

Heather
User avatar
emu_kidid
Site Admin
Posts: 4573
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: DVD Issue After Wasp Fusion Install and Audio Streaming Question

Post by emu_kidid » Thu Nov 14, 2019 2:43 am

Yep 64GB is the limit in the WASP fusion, anything higher will appear to work but reads beyond 64GB will fail.
Image
SkydivinGirl
Posts: 16
Joined: Sun Sep 15, 2019 3:42 pm

Re: DVD Issue After Wasp Fusion Install and Audio Streaming Question

Post by SkydivinGirl » Thu Nov 14, 2019 2:42 pm

Thanks emu_kidid! It's sometimes hard to find this information without digging through hundreds of threads.

Well, my autoboot bliss has been shattered. After putting a few more ISOs on the SD card, it's no longer autobooting. I guess I'm relegated to pushing Up, A, Start to open Swiss. :)

Heather
Post Reply