Help compiling!

Release threads for homebrew & utilities only
Post Reply
niuus
Posts: 35
Joined: Fri May 20, 2016 2:03 am

Help compiling!

Post by niuus » Sun Nov 06, 2016 2:06 am

Hi! I am a newbie at everything programming-related, but i have compiled some emulators in the past (Gamecube era), and did not had too much of a trouble following some guides about it. Right now i want to have a shot at this again, to not depend in other users builds.

I used DevkitPro Updater 1.6.0, installed to c:\devkitPPC. Opened C:\devkitPro\msys\etc\fstab and added this line:
c:/devkitPro/devkitPPC /ppc
After that, i opened C:\devkitPro\msys\etc\profile in Programmer's Notepad and added these 2 lines:
\033[32m\]\u@\h \[\033[33m\w\033[0m\]
$ '

alias clear=clsb
export PATH=$PATH:/ppc/bin
export DEVKITPPC=/ppc


cd "$HOME"
Extracted libogc source at C:\devkitPro\devkitPPC\libogc, then ran:
cd /ppc
cd libogc
make
make install
Went ahead with SnesGX. Right now i'm stuck at this error when trying to compile:

Image

Any help to overcome this?

I am using Windows 7 x64.
User avatar
emu_kidid
Site Admin
Posts: 4339
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: Help compiling!

Post by emu_kidid » Sun Nov 06, 2016 11:23 pm

Image
niuus
Posts: 35
Joined: Fri May 20, 2016 2:03 am

Re: Help compiling!

Post by niuus » Mon Nov 07, 2016 4:14 pm

Thanks for your answer, emu_kidid. I am a fan of your work and thoroughly tested and reported about SD Boot, way back on the TehSkeen days (i miss that website!).

So, should i download and extract all those libraries at the devkitPPC folder? (excuse the noobness)
User avatar
emu_kidid
Site Admin
Posts: 4339
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: Help compiling!

Post by emu_kidid » Mon Nov 07, 2016 11:21 pm

niuus wrote: Thanks for your answer, emu_kidid. I am a fan of your work and thoroughly tested and reported about SD Boot, way back on the TehSkeen days (i miss that website!).

So, should i download and extract all those libraries at the devkitPPC folder? (excuse the noobness)
Thanks, those were good times :)

You need to extract them and place them in: \devkitPro\portlibs\ppc
Image
niuus
Posts: 35
Joined: Fri May 20, 2016 2:03 am

Re: Help compiling!

Post by niuus » Tue Nov 08, 2016 5:16 am

emu_kidid wrote:Thanks, those were good times :)

You need to extract them and place them in: \devkitPro\portlibs\ppc
Okey, i think i am progressing. I also added fat.h and libfatversion.h, which i downloaded from the web. Same for wupc.h.

Got this far with Snes9x GX:
https://github.com/askotx/snes9x-gx
Image

Got this far with WiiSXR:
https://github.com/Mystro256/wiisxr
Image
niuus
Posts: 35
Joined: Fri May 20, 2016 2:03 am

Re: Help compiling!

Post by niuus » Thu Nov 10, 2016 11:37 pm

Mystro256 wrote:I'd rather people pick up some code and help me out rather than spend their time bad mouthing me (yes I read the old thread). I meant if people think they can do better, then I would love the help! That's what open source is all about!
@Mystro256, could you give me a hand here? =) Or anyone?
User avatar
emu_kidid
Site Admin
Posts: 4339
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: Help compiling!

Post by emu_kidid » Fri Nov 11, 2016 9:00 am

The signature to ifconfig changed, you'll need to fix it in WiiSXR or update libOGC.
Image
niuus
Posts: 35
Joined: Fri May 20, 2016 2:03 am

Re: Help compiling!

Post by niuus » Tue Nov 15, 2016 4:29 am

emu_kidid wrote:The signature to ifconfig changed, you'll need to fix it in WiiSXR or update libOGC.
I really, really wish i knew what that means :?

Sorry, i really don't know. I am using the latest liboGC (1.8.14), though.
https://github.com/devkitPro/libogc/releases
User avatar
emu_kidid
Site Admin
Posts: 4339
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: Help compiling!

Post by emu_kidid » Tue Nov 15, 2016 5:42 am

niuus wrote:
emu_kidid wrote:The signature to ifconfig changed, you'll need to fix it in WiiSXR or update libOGC.
I really, really wish i knew what that means :?

Sorry, i really don't know. I am using the latest liboGC (1.8.14), though.
https://github.com/devkitPro/libogc/releases
A new parameter was added to the if_config method in libOGC and WiiSXR is trying to use the method without supplying it. To fix it, in fileBrowser-SMB.c line 98, change it to have an extra parameter, e.g: if_config(ip, NULL, NULL, true, 10);
Image
niuus
Posts: 35
Joined: Fri May 20, 2016 2:03 am

Re: Help compiling!

Post by niuus » Wed Nov 16, 2016 4:58 am

emu_kidid wrote:
niuus wrote:
emu_kidid wrote:The signature to ifconfig changed, you'll need to fix it in WiiSXR or update libOGC.
I really, really wish i knew what that means :?

Sorry, i really don't know. I am using the latest liboGC (1.8.14), though.
https://github.com/devkitPro/libogc/releases
A new parameter was added to the if_config method in libOGC and WiiSXR is trying to use the method without supplying it. To fix it, in fileBrowser-SMB.c line 98, change it to have an extra parameter, e.g: if_config(ip, NULL, NULL, true, 10);
I am really thankful, emu_kidid. Might be silly, but it's kinda cool to run your own compiled build, after all these years. I was successful with WiiSXR, ran some games, everything cool.

I am stuck with Snes9X GX, with the error mentioned in the previous post/screenshot. I tried checking cpu.cpp and cpuexec.cpp for the remote possibility of me changing something and fixing it, but to no avail. Don't know what i am exactly looking for.
User avatar
Streetwalker
Posts: 1575
Joined: Mon Dec 30, 2013 7:50 am
Location: Israel

Re: Help compiling!

Post by Streetwalker » Wed Nov 16, 2016 7:36 am

The snes9x issue looks like it's a broken makefile. I'll take a look tonight if I don't forget.
niuus
Posts: 35
Joined: Fri May 20, 2016 2:03 am

Re: Help compiling!

Post by niuus » Wed Nov 16, 2016 11:05 pm

Streetwalker wrote:The snes9x issue looks like it's a broken makefile. I'll take a look tonight if I don't forget.
Any luck, Streetwalker? =)
User avatar
Streetwalker
Posts: 1575
Joined: Mon Dec 30, 2013 7:50 am
Location: Israel

Re: Help compiling!

Post by Streetwalker » Thu Nov 17, 2016 7:32 am

Nope, sorry, I forgot you.
sindrik
Posts: 75
Joined: Tue Jun 10, 2014 8:13 am

Re: Help compiling!

Post by sindrik » Tue Nov 22, 2016 10:59 pm

was this resolved? :shock:
niuus
Posts: 35
Joined: Fri May 20, 2016 2:03 am

Re: Help compiling!

Post by niuus » Sat Jan 21, 2017 7:30 pm

In case someone can help/suggest a solution, here is the problem with WiiMednafen:

devkit ppc r26 / libogc 1.8.11
Image
Post Reply