Wii Swiss Booter

Find all your Nintendo Wii related topics here
idbirch
Posts: 2
Joined: Sun Jun 24, 2012 11:53 am

Re: Wii Swiss Booter

Post by idbirch » Mon Jun 25, 2012 7:12 am

Vague Rant wrote:I can go as far as saying that 576p doesn't work for me on builds I've tested with that exact setup (SwissBoot > Swiss > Force 576p)
Sorry for the noob question but is the forcing 576p feature you're talking about the same as the 16:9 widescreen hack that's now in Swiss? I've been trying to get 16:9 working on Mario Sunshine and Luigi's Mansion but can't figure out how and I'm not sure if it's because I'm not selecting the right options in Swiss or whether it's something that's currently not working on the Wii implementation.

I have a Wii with an original WiiKey fitted so it boots GCOS multiboot discs from DVD-R already and I can also load these via HBC -> Wii Swiss Booter but I don't see any options relating to widescreen or aspect ratio within Swiss. I do also have an SD Gecko which I've tried connecting, I noticed Swiss created an ini file on there but again, no obvious way of toggling aspect ratio in there.

Can anyone tell me if the 16:9 hack is actually usable on Wii at the moment and if it's possible with my current combination of hardware? Thanks.
BenoitRen
Posts: 263
Joined: Sun Jul 29, 2012 3:37 pm

Re: Wii Swiss Booter

Post by BenoitRen » Sun Jul 29, 2012 4:09 pm

WiiPower, thanks for making Swiss on my Wii possible!
Hardware: Wii (PAL)
Hardware configuration: System Menu 4.1E, Priiloader
Swiss boot method: Modified Wii Swiss Booter provided by Extrems
Software medium: Retail discs
User avatar
mat8888
Posts: 65
Joined: Fri May 24, 2013 11:03 pm
Location: northeast USA

Re: Wii Swiss Booter

Post by mat8888 » Mon Jun 17, 2013 9:26 pm

The mediafire links seem to be dead.. does anyone have a link?
Cisz.
Posts: 6
Joined: Mon Dec 15, 2014 7:07 pm

Re: Wii Swiss Booter

Post by Cisz. » Mon Dec 15, 2014 7:30 pm

mat8888 wrote:The mediafire links seem to be dead.. does anyone have a link?
http://filetrip.net/wii-downloads/homeb ... 32227.html
Vague Rant wrote:WiiPower, Extrems suggested on IRC (a few hours ago and from memory, so I may need correcting on the specifics) that your booter would need to add support for the new 576p VI timing recently added to Swiss. As is, 576p apparently won't work when Swiss is launched via your tool.

I can go as far as saying that 576p doesn't work for me on builds I've tested with that exact setup (SwissBoot > Swiss > Force 576p), with my 576p-capable TV reporting no signal when the Wii switches to that mode. That said, I don't have any other rig on which to test this, so I can't confirm that that's the (only) issue.

I'd say Extrems probably knows what he's talking about, though. Hopefully we can all benefit from glorious 576p soon.
Is there any clarity on whether or not Swiss supports 576p when launched via Wii Swiss Booter? How can one verify that?
BenoitRen
Posts: 263
Joined: Sun Jul 29, 2012 3:37 pm

Re: Wii Swiss Booter

Post by BenoitRen » Tue Dec 16, 2014 12:36 am

It doesn't. Just replied to this in the "Goals for Swiss 0.4" thread.
Hardware: Wii (PAL)
Hardware configuration: System Menu 4.1E, Priiloader
Swiss boot method: Modified Wii Swiss Booter provided by Extrems
Software medium: Retail discs
Cisz.
Posts: 6
Joined: Mon Dec 15, 2014 7:07 pm

Re: Wii Swiss Booter

Post by Cisz. » Thu Dec 18, 2014 10:19 pm

Thanks BenoitRen. I got the custom booter from Extrems. Didn't realise at first that it worked differently from WiiPower's booter in that it only launched swiss.dol when it's in the booter's root directory. 576p looks a whole lot clearer in motion than both 576i and 480p.
q8v08
Posts: 51
Joined: Wed Dec 17, 2014 8:23 pm

Re: Wii Swiss Booter

Post by q8v08 » Fri Dec 19, 2014 3:10 am

Noticed in 480p on some Wii games you sometimes get a slight shudder / splitting in the middle of the screen which doesn't happen with 576i or 480i, is it the same for gc mode?
it happens on the beach / village stage of lego pirates of the caribbean.
Cisz.
Posts: 6
Joined: Mon Dec 15, 2014 7:07 pm

Re: Wii Swiss Booter

Post by Cisz. » Fri Dec 19, 2014 12:03 pm

Lego Pirates of the Caribbean is a Wii game so it doesn't have any connection to Swiss.

My guess would be that it's a game dependant vsync issue that has to do with the game's programming and performance. The game has to push 2 times the pixels for 480p compared to 480i and 576i. If the game can't keep up with that it could result in screen tearing if vsync is off.
Last edited by Cisz. on Mon Dec 22, 2014 12:12 pm, edited 1 time in total.
User avatar
Streetwalker
Posts: 1736
Joined: Mon Dec 30, 2013 7:50 am
Location: Israel

Re: Wii Swiss Booter

Post by Streetwalker » Mon Dec 22, 2014 7:32 am

Not true, the game's internal resolution should be the same no matter the video mode. It's the video encoder that doesn't ouptput the same signal (576p at 50Hz on the other hand runs at a lower framerate, 50Hz instead of 60).
q8v08
Posts: 51
Joined: Wed Dec 17, 2014 8:23 pm

Re: Wii Swiss Booter

Post by q8v08 » Mon Dec 29, 2014 7:36 pm

Could it be because i'm playing PAL games in 480p instead of the NTSC version? how can I force v-sync on original discs? I seem to remember this happening in Harry Potter and the Chamber of Secrets for the gamecube also.
Post Reply