Weird behaviour for Swiss

Find all your Nintendo Wii related topics here
Post Reply
User avatar
Shinebi
Posts: 87
Joined: Thu Apr 07, 2011 1:57 pm

Weird behaviour for Swiss

Post by Shinebi » Wed Jan 11, 2012 8:24 am

I had something strange happen to me yesterday.

At first I couldn't get to boot Swiss Booter from the HBC or the Channel Forwarder, depending on what the actual name of the path's folder was.
I resolved that finally concluding they weren't looking for the same folder.
(See my previous posts concerning this: apps/Swiss/... vs apps/SwissBooter/...)

I'd renamed this folder accordingly and also tried putting the actual swiss.dol file in the root of the DS-card (Kingston 32GB SDHC), wich is in the front port FYI. Sometimes it worked, sometimes it didn't... I checked and concluded that the apps folder was renamed to APPS folder, which seemed to prevent booting of Swiss. I fixed that and it was resolved... but was a hit or miss later on again. I thought there'd be something wrong with the SD card itself, so I copied everything which I'd still need, delete everything Swiss, formatted the card and made a fresh install of the needed files.

Then I tried booting through Homebrew Filter, which is in my system menu as a Channel Forwarder. Swiss booted without problems...! Convinced that this'd work every time because of a higher compatibility (?), I then tried different configurations again (root vs folder path).... then it suddenly didn't boot anymore... back to start ...


This was getting on my nerves, because I didn't know the exact cause of all this trial and error.
I then placed a copy of Swiss.dol in the root of my port B Sandisk 2GB SD-card which is in the WiikeySD adapter and it booted from first time!!

-So the only reason I can imagine that Swiss wouldn't boot isn't because of the HBC booter or the Channel Forwarder not working but with some sort of error from Swiss not booting correctly from the front SDHC card.
(only worked 3 times in total I think from about 15 tries)


BTW, I DL'ed the 0.2 version already by then, but this ISN'T the cause of it working, because I tried before with the other settings to no avail.

Anyone else had a similar problem?
I know it's weird, but I just wanted put this out here as a feedback...
(I hope all of this makes sense.)


PS booting games from WiiKeySD worked, I also ripped Starfox Assault PAL to SD on 'compatible setting' in about 25 minutes without problem.
PPS What's the fifth option called MemCard for?
PPPS Any future plans on including the front SD port for dumping too?
User avatar
emu_kidid
Site Admin
Posts: 4485
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: Weird behaviour for Swiss

Post by emu_kidid » Wed Jan 11, 2012 9:50 am

PPS: Memory card browsing (doesn't work on Wii)
PPPS: No.
Image
Naxil
Posts: 40
Joined: Sat Oct 29, 2011 10:56 pm

Re: Weird behaviour for Swiss

Post by Naxil » Sat Jan 14, 2012 5:09 pm

Try to put swiss.dol on root of sd inside the SDADAPTER or in SDFRONT
my trial with swissbooter 0.3+swiss0.2+sdgecko+very cheap SD in MINISD ADAPTER:
sometimes i start swiss and wii reboot.. after reboot swiss run very well.. try to reboot your wii after u plug all SD
User avatar
Shinebi
Posts: 87
Joined: Thu Apr 07, 2011 1:57 pm

Re: Weird behaviour for Swiss

Post by Shinebi » Thu Jan 19, 2012 2:33 pm

It fixed itself miraculously and now boots 95% of the time from any port/card...
Still dunno what the error was.
Post Reply