Memory cards not working in latest build

Discuss one of the most feature filled GameCube applications here :)
Post Reply
puddlez
Posts: 2
Joined: Sun Sep 26, 2021 2:23 pm

Memory cards not working in latest build

Post by puddlez » Sun Sep 26, 2021 10:31 pm

Hello, emukidid and Extrems.

I recently installed a GC Loader PNP in my DOL-001 and tried using Swiss with it. I like it a lot, but found a few very minor things I wanted to change. Primarily, I want the menu to default to 480i, even if a component cable is detected, without the need to add more hardware to save settings.

I was able to alter the source code to my needs and compile an .iso, but then I found that memory cards were no longer recognized after loading a game. This hadn't been an issue with the pre-compiled .iso, so I rolled the source back to commit f144537e7a05fb9e2291fd15fa21042dc8eb0f45 and used that as the basis for my build. Now everything is working.

I didn't step through all of them, but it seems like there is something after that commit that is breaking memory card support. Is this a known issue? For reference, I was using an official Nintendo memory card and a Melee USA rev 2 .iso. Thanks.
puddlez
Posts: 2
Joined: Sun Sep 26, 2021 2:23 pm

Re: Memory cards not working in latest build

Post by puddlez » Sun Sep 26, 2021 10:40 pm

Also, what are the differences between \dist\ISO\swiss_r1154(ntsc-u).iso and \dist\GCLoader\boot.iso? I see in the makefile that one is generated with eltorito-u.hdr and the other with eltorito-gcode.hdr, but does this change anything besides region compatibility?

I noticed that the GCLoader version doesn't wait for the startup logo animation, but I prefer to see it for nostalgia's sake. Anything else to watch out for?
User avatar
Extrems
Posts: 1151
Joined: Tue Aug 17, 2010 10:40 pm
Location: Québec, Canada
Contact:

Re: Memory cards not working in latest build

Post by Extrems » Mon Sep 27, 2021 2:52 am

I couldn't reproduce this issue using Super Smash Bros. Melee (USA) (En,Ja) (Rev 2).
User avatar
Papy.G
Posts: 750
Joined: Mon Mar 04, 2019 6:14 am
Location: France, Occitanie
Contact:

Re: Memory cards not working in latest build

Post by Papy.G » Wed Sep 29, 2021 10:32 am

May be the GCloader new FW version will help you get what you want and prevent the need to bother modifiiing SWISS itself.

By booting through IPL, you'll see the boot sequence before running an iso. Though still not at power on.
DMG/MultiFreq OC/EDGB/EZF Jr, AGB/SC miniSD, NTR/NeoMK3, USG/flashme V8/SC miniSD
DOL001(EUR)/RGB/GCPlug/GBP/SD2SP2, RVL 001(EUR)/RGB/CMP/WiiSD

Zelda WW with Tingle Tuner in split screen was what the GC RF modulator was made for! (Video)
Post Reply