Swiss Nightly Build

Discuss one of the most feature filled GameCube applications here :)
Locked
User avatar
ALSINJAN
Posts: 15
Joined: Sun Aug 29, 2010 7:08 am

Re: Swiss Nightly Build

Post by ALSINJAN » Sat Oct 25, 2014 6:39 pm

I'm having an erratic boot of Swiss (sometimes it works, sometimes black screen, sometimes code dump [see post pag. 11]) using Classic Wii, SD Gecko and Wii Swiss Booter.
Can anyone explain me how the ISO versions (PAL, NTSC and NTSC-J) Swiss-GC are used?
I guess a DVD with the corresponding ISO recording, but ... where is placed "swiss.dol" ?.
I'm using a Wii Swiss for years and now alternate with Nintendont, but want to keep Swiss. It would be possible to launch the ISO Swisss-GC from Nintendont (always boot OK) as if it were a game of GC ?.
Thank you in advance for your reply and for your great work.
User avatar
megalomaniac
Posts: 2480
Joined: Sun Aug 21, 2011 5:33 am
Location: Drunk in Texas
Contact:

Re: Swiss Nightly Build

Post by megalomaniac » Thu Oct 30, 2014 1:59 am

swiss_r281 released
emu_kidid wrote: beer is like WD40 for megalomaniac's brain, gets the gears moving
>>> BadAssConsoles.com <<<

Image Image Image
User avatar
sk8er000
Posts: 28
Joined: Fri May 16, 2014 6:33 pm
Contact:

Re: R: Swiss Nightly Build

Post by sk8er000 » Thu Oct 30, 2014 1:58 pm

megalomaniac wrote:swiss_r281 released
Fantastic!! The bug with the component cable has been solved!!! Thank you very much!!
Using Tapatalk
User avatar
megalomaniac
Posts: 2480
Joined: Sun Aug 21, 2011 5:33 am
Location: Drunk in Texas
Contact:

Re: Swiss Nightly Build

Post by megalomaniac » Tue Nov 04, 2014 3:03 am

swiss_r283 released
emu_kidid wrote: beer is like WD40 for megalomaniac's brain, gets the gears moving
>>> BadAssConsoles.com <<<

Image Image Image
User avatar
tesla246
Posts: 119
Joined: Tue Dec 11, 2012 1:48 pm

Re: Swiss Nightly Build

Post by tesla246 » Thu Nov 06, 2014 6:17 pm

Few months back bought megadrive 3/wasp among other parts. Installing it was a piece of cake and, nicely designed solution mega.
Yesterday was my first time using swiss ever; after some tinkering updated the wasp with the newest swiss nightly build, and it works like a charm, swiss is amazing.
However, I do have 2 questions, please forgive my dullness:
- I Have tried both Snes9x GX and Mplayer CE. Neat little programs, pleasantly surprised the snes emulator was indeed fullspeed in megamanX, but could not get them to work with the wasp. Am I correct in assuming they dont work using the waps's SD card? They worked correctly SDML sd gecko device, but that broke quickly after only several times of removing/inserting the sd card.
-My wiikey doesnt autoboot, but only autoloads. I red autoboot behaviour might also depend on the type of SD cards, it is like being a lottery. Might that be the cause?

Thanks for the answers and keep up the amazing work!
Dream mod: RAM expansion for serial port 2 with wifi, bluetooth and usb port :shock:
Favourite mod: Wasp fusion autoboot with flashed swiss. :D
Eagerly awaiting a normal, form-factor wise, wireless controller with rumble. :)
User avatar
megalomaniac
Posts: 2480
Joined: Sun Aug 21, 2011 5:33 am
Location: Drunk in Texas
Contact:

Re: Swiss Nightly Build

Post by megalomaniac » Thu Nov 06, 2014 7:31 pm

Most all homebrew does not support loading thru WKF/WASP slot
Take a look in the emulator section for "unofficial" builds which are compatible with browsing / loading from WFK/WASP SD slot


...keep in mind the emulators still require ini files on SD gecko since WKF is read only and cannot save ini config files.
I do have plans to fix that issue on the emulators and improve usability for WKF/WASP. Eventually i will have time to make these changes...
emu_kidid wrote: beer is like WD40 for megalomaniac's brain, gets the gears moving
>>> BadAssConsoles.com <<<

Image Image Image
User avatar
tesla246
Posts: 119
Joined: Tue Dec 11, 2012 1:48 pm

Re: Swiss Nightly Build

Post by tesla246 » Thu Nov 06, 2014 8:38 pm

Many thanks mega. Was browsing your youtube videos and , aside from genesis etc., didnt came across a snes wiikey fusion demonstration so assumed wrongly you excluded snes from the compatibility upgrade (kinda forgot about all the other forums here aside from hardware/modding ^^).

All in all an amazing and really helpful/enthusiast community here.
Dream mod: RAM expansion for serial port 2 with wifi, bluetooth and usb port :shock:
Favourite mod: Wasp fusion autoboot with flashed swiss. :D
Eagerly awaiting a normal, form-factor wise, wireless controller with rumble. :)
User avatar
megalomaniac
Posts: 2480
Joined: Sun Aug 21, 2011 5:33 am
Location: Drunk in Texas
Contact:

Re: Swiss Nightly Build

Post by megalomaniac » Sun Nov 09, 2014 1:20 am

swiss_r284 released
emu_kidid wrote: beer is like WD40 for megalomaniac's brain, gets the gears moving
>>> BadAssConsoles.com <<<

Image Image Image
User avatar
megalomaniac
Posts: 2480
Joined: Sun Aug 21, 2011 5:33 am
Location: Drunk in Texas
Contact:

Re: Swiss Nightly Build

Post by megalomaniac » Mon Nov 10, 2014 12:17 am

swiss_r285 released
emu_kidid wrote: beer is like WD40 for megalomaniac's brain, gets the gears moving
>>> BadAssConsoles.com <<<

Image Image Image
theclaw
Posts: 324
Joined: Tue Dec 13, 2011 12:01 pm

Re: Swiss Nightly Build

Post by theclaw » Mon Nov 10, 2014 1:09 am

Before I risk losing data, how does this character encoding forcing work? Does it fix only text/language issues?

Or will the memory card format also change (like a physical US/JP switch)?
User avatar
megalomaniac
Posts: 2480
Joined: Sun Aug 21, 2011 5:33 am
Location: Drunk in Texas
Contact:

Re: Swiss Nightly Build

Post by megalomaniac » Wed Nov 12, 2014 12:01 am

swiss_r287 released
emu_kidid wrote: beer is like WD40 for megalomaniac's brain, gets the gears moving
>>> BadAssConsoles.com <<<

Image Image Image
User avatar
Ashen
Posts: 994
Joined: Tue Nov 16, 2010 3:08 pm

Re: Swiss Nightly Build

Post by Ashen » Wed Nov 12, 2014 6:42 pm

Is metaradil you on the SVN page Magalomaniac?
- Add 480/576i forcing.
This finally makes Luigi's mansion PAL playable via WKF without the need for a component cable. I think I love you.

Thanks once again to all involved for keeping this great little piece of homebrew updated. :D
User avatar
emu_kidid
Site Admin
Posts: 4786
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: Swiss Nightly Build

Post by emu_kidid » Wed Nov 12, 2014 9:52 pm

metaradil is Extrems :)
Image
Ultor
Posts: 5
Joined: Sat Aug 23, 2014 10:56 pm

Re: Swiss Nightly Build

Post by Ultor » Thu Nov 13, 2014 12:47 pm

Sd Gecko don't works anymore!!! :(
User avatar
Ashen
Posts: 994
Joined: Tue Nov 16, 2010 3:08 pm

Re: Swiss Nightly Build

Post by Ashen » Thu Nov 13, 2014 2:26 pm

emu_kidid wrote:metaradil is Extrems :)
I figured it was either one or the other. My mistake. :D
Redmagnusx
Posts: 59
Joined: Thu Mar 28, 2013 3:07 am

Re: Swiss Nightly Build

Post by Redmagnusx » Fri Nov 14, 2014 4:18 pm

I'm having an issue with Super Mario Sunshine. The game simply won't boot. It acts as though it's going to boot, but the screen just turns green and goes black. No audio or anything. This happens regardless of the video mode I force and also regardless of which version (PAL or NTSC). Just giving you guys a heads up, I'm on the latest build r287, but this also happened on r285.
User avatar
Ashen
Posts: 994
Joined: Tue Nov 16, 2010 3:08 pm

Re: Swiss Nightly Build

Post by Ashen » Fri Nov 14, 2014 6:47 pm

You need to be a little more specific. What device exactly are you trying to boot from? SD gecko? Settings, etc?
User avatar
Invincible
Posts: 13
Joined: Tue May 13, 2014 6:21 am

Re: Swiss Nightly Build

Post by Invincible » Fri Nov 14, 2014 9:06 pm

use a different sd card. This happened to me with a sandisk ultra 16gb
Redmagnusx
Posts: 59
Joined: Thu Mar 28, 2013 3:07 am

Re: Swiss Nightly Build

Post by Redmagnusx » Fri Nov 14, 2014 10:01 pm

It's happening when booting the ISO from the Wiikey SD card slot. The settings are all default as I haven't changed any of them other than forcing 480p in an attempt to get it to work since doing this works with Luigi's Mansion.

Unfortunately, I've tried multiple SD cards to no avail. I've even tried it on multiple systems to no avail (the other being on r275). The SD card I am currently using is a PNY 32GB Class 10. Every other title loads fine (although Luigi's Mansion requires that I force 480p, but I believe that's normal with that title).
User avatar
emu_kidid
Site Admin
Posts: 4786
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: Swiss Nightly Build

Post by emu_kidid » Sat Nov 15, 2014 12:16 am

Do you own a USBGecko? Maybe post a video of it happening.
Image
Redmagnusx
Posts: 59
Joined: Thu Mar 28, 2013 3:07 am

Re: Swiss Nightly Build

Post by Redmagnusx » Sat Nov 15, 2014 1:27 am

Unfortunately, I do not own a USB gecko.

Update: I picked up a 64GB Micro Center Class 10 SD card and the game works as long as I force 480p. It does not work at 480i.
Last edited by Redmagnusx on Sat Nov 15, 2014 1:52 am, edited 1 time in total.
User avatar
Ashen
Posts: 994
Joined: Tue Nov 16, 2010 3:08 pm

Re: Swiss Nightly Build

Post by Ashen » Sat Nov 15, 2014 1:31 am

Why are you using the PAL iso? Is it a verified good dump? Check the md5 on redump.org
Redmagnusx
Posts: 59
Joined: Thu Mar 28, 2013 3:07 am

Re: Swiss Nightly Build

Post by Redmagnusx » Sat Nov 15, 2014 1:50 am

I'm using the PAL iso because the NTSC iso wouldn't work either so I figured I would try the PAL iso instead. It does the same thing regardless of the iso I use. This leads me to believe that the iso isn't the issue because I've already tried 4 different ones from different sources (2 NTSC and 2 PAL) and they've all had the same result. I just checked the MD5 as per your suggestion and it appears to be good on all the isos I've tried.

The new 64GB sd card I got works, but only when forced to 480p.
Redmagnusx
Posts: 59
Joined: Thu Mar 28, 2013 3:07 am

Re: Swiss Nightly Build

Post by Redmagnusx » Sat Nov 15, 2014 2:11 am

Okay, it looks as though Invincible was right on the money with this one. The SD cards I was using seemed to be the issue despite their being from different manufacturers and all of them being class 10. Just for the record the makes of the SD cards were PNY, Sandisk and Lexar. With my new SD card, the NTSC iso boots just fine without the need to force 480p. I figured that I may need to force 480p with the PAL iso because it's PAL. All is well now and I appreciate the help, but it is still an issue that others may come across.
User avatar
megalomaniac
Posts: 2480
Joined: Sun Aug 21, 2011 5:33 am
Location: Drunk in Texas
Contact:

Re: Swiss Nightly Build

Post by megalomaniac » Sat Nov 15, 2014 2:19 am

Redmagnusx wrote:Okay, it looks as though Invincible was right on the money with this one. The SD cards I was using seemed to be the issue despite their being from different manufacturers and all of them being class 10. Just for the record the makes of the SD cards were PNY, Sandisk and Lexar. With my new SD card, the NTSC iso boots just fine without the need to force 480p. I figured that I may need to force 480p with the PAL iso because it's PAL. All is well now and I appreciate the help, but it is still an issue that others may come across.
quick card testing performed here
viewtopic.php?p=26308#p26308
emu_kidid wrote: beer is like WD40 for megalomaniac's brain, gets the gears moving
>>> BadAssConsoles.com <<<

Image Image Image
Locked