High pitched audio in Swiss interface only

Discuss one of the most feature filled GameCube applications here :)
Post Reply
vaderag
Posts: 12
Joined: Sat May 29, 2021 7:13 pm

High pitched audio in Swiss interface only

Post by vaderag » Sat May 29, 2021 7:34 pm

I'm using GC Video and everything works fine except for when I'm in Swiss I get a terrible high pitched solid audio tone through my speakers
Pre Swiss (boot) and post swiss (booting a game) all fine, but Swiss has this every time... It's excruciating!!

Anyone else got this? Anyone know what might cause it?

Thanks
User avatar
retro
Posts: 27
Joined: Fri Mar 19, 2021 1:01 am

Re: High pitched audio in Swiss interface only

Post by retro » Sun May 30, 2021 1:40 am

Which version of Swiss are you using? It can be found on the upper right corner of the screen
How are you loading Swiss? Is it via GCLoader, save game exploit, etc?
Possible to show a video of this?
User avatar
Extrems
Posts: 1104
Joined: Tue Aug 17, 2010 10:40 pm
Location: Québec, Canada
Contact:

Re: High pitched audio in Swiss interface only

Post by Extrems » Sun May 30, 2021 1:41 am

It's an issue with shinehax specifically.
vaderag
Posts: 12
Joined: Sat May 29, 2021 7:13 pm

Re: High pitched audio in Swiss interface only

Post by vaderag » Sun May 30, 2021 6:06 am

retro wrote:
Sun May 30, 2021 1:40 am
Which version of Swiss are you using? It can be found on the upper right corner of the screen
How are you loading Swiss? Is it via GCLoader, save game exploit, etc?
Possible to show a video of this?
Version 5, latest. Only got it the other day
vaderag
Posts: 12
Joined: Sat May 29, 2021 7:13 pm

Re: High pitched audio in Swiss interface only

Post by vaderag » Sun May 30, 2021 6:10 am

Extrems wrote:
Sun May 30, 2021 1:41 am
It's an issue with shinehax specifically.
Ah, that would make sense as using shinehax. Seems odd it would only happen through that!
Is there likely to be a fix or workaround or should I start looking for some other way to boot?
User avatar
Papy.G
Posts: 685
Joined: Mon Mar 04, 2019 6:14 am
Location: France, Occitanie
Contact:

Re: High pitched audio in Swiss interface only

Post by Papy.G » Sun May 30, 2021 9:54 am

You may replace your boot.gci by a small version of GBI, provided you have enough space on your Memcard, then, you can load SWISS by pressing start for more than three seconds from the osd menu (works even without a GBPlayer). :|

Tell us back if it worked for you. :P
DMG/MultiFreq OC/EDGB/EZF Jr, AGB/SC miniSD, NTR/NeoMK3, USG/flashme V8/SC miniSD
DOL001(EUR)/RGB/GCPlug/GBP/SD2SP2, RVL 001(EUR)/RGB/CMP/WiiSD

Zelda WW with Tingle Tuner in split screen was what the GC RF modulator was made for! (Video)
vaderag
Posts: 12
Joined: Sat May 29, 2021 7:13 pm

Re: High pitched audio in Swiss interface only

Post by vaderag » Sun May 30, 2021 10:26 am

Papy.G wrote:
Sun May 30, 2021 9:54 am
You may replace your boot.gci by a small version of GBI, provided you have enough space on your Memcard, then, you can load SWISS by pressing start for more than three seconds from the osd menu (works even without a GBPlayer). :|

Tell us back if it worked for you. :P
Ah, interesting - will give that a try when I'm back at my GC next week

Another thought I had was having a second Swiss instance set as auto boot when I load into Swiss... Purely thought as away from cube til next week...
vaderag
Posts: 12
Joined: Sat May 29, 2021 7:13 pm

Re: High pitched audio in Swiss interface only

Post by vaderag » Mon Jun 07, 2021 12:33 pm

Okay, so done a little testing.
So long as Swiss is 'reloaded' somehow, the noise disappears.
This works with GBI and/or with a second Swiss DOL/iso.

Sadly none of these are particularly seamless as I don't see a way to get swiss to do a seamless load of a file on boot (unless I'm missing something?)

Best way I've found so far is to have an ISO of Swiss and have that set (with Z) to autoload, but problem then is that it does a full reboot and you get the auto-load screen every time (on both Swiss instances)

Would love any other ideas to fix (although _hoping_ that there might be able to be a real fix in next version of Swiss @Extrems? Pretty please ;)
User avatar
Extrems
Posts: 1104
Joined: Tue Aug 17, 2010 10:40 pm
Location: Québec, Canada
Contact:

Re: High pitched audio in Swiss interface only

Post by Extrems » Mon Jun 07, 2021 2:20 pm

The issue is in shinehax, not Swiss.
vaderag
Posts: 12
Joined: Sat May 29, 2021 7:13 pm

Re: High pitched audio in Swiss interface only

Post by vaderag » Mon Jun 07, 2021 2:26 pm

Extrems wrote:
Mon Jun 07, 2021 2:20 pm
The issue is in shinehax, not Swiss.
Presumably the interaction between the two?

I appreciate the issue isn't necessarily in Swiss code but given there are only really 6 or so decent ways to boot Swiss on a cube (of which most come into the $100s of dollars) and Shinehax is one of them (which costs around $10) would be fantastic if there could be a fix implemented in Swiss...

Some possible fixes that come to mind... Muting system in Swiss, allowing an seamless reload of Swiss, allowing seamless boot of a DOL (to boot swiss)
vaderag
Posts: 12
Joined: Sat May 29, 2021 7:13 pm

Re: High pitched audio in Swiss interface only

Post by vaderag » Tue Jun 08, 2021 10:13 am

Okay - I've found a working solution to fix this seamlessly!

Instructions...
Get dolaunch from here: https://github.com/suloku/dolaunch/rele ... /0.2-dolxz
Stick boot.gci of the standard version onto your memory card to get the DOL to be used with Shinehax
Put Swiss on your SD card (if using SD2SP2 as I am) and rename to autoexec.dol)

Load Shinehax as usual - no terrible beep!
Post Reply