Exploit Under Fire won't load Swiss

Discussion / Support for Softmods (SDML, AR, Game Hacks)
Post Reply
Posts: 1
Joined: Tue Dec 27, 2016 1:23 am

Exploit Under Fire won't load Swiss

Post by Pyrochrome » Thu Jan 16, 2020 6:27 am

I have a plain old unmodded Gamecube, a copy of 007 Agent Under Fire and a 251 (black) Memory Card with the exploit save file and Swiss gci on it. I intended to boot Swiss from the MC using Under Fire and then load ISO files from the third party SD Gecko I have; the problem is that no matter what i try, I simply cannot get Swiss to load under any circumstances. The games boots up like normal and I select Load Mission, but when the "reading from Memory Card A, don't power off etc" prompt appears, Swiss never executes; the games simply freezes.

Someone on Reddit had a similar issue and fixed it by formatting their card before reinstalling the files, so i tried that and it did nothing. I thought maybe a different build of Swiss was necessary, so I went to Github and grabbed the latest nightly build- version v0.4r766, compiled four days ago. No luck. I had been using pre-converted gci files up to that point, so I grabbed doltogci and manually converted the standard boot.dol to a gci. Still nothing. I read on the Home Bros thread that apparently you can load a boot.dol from an SD card instead using that exploit, so I thought maybe Exploit Under Fire could do the same. Stuck the boot.dol onto the root of the SD card and made sure the dongle was plugged in....still nothing. :evil:

I am at my wit's end trying to figure what I could possibly be doing wrong, and quite frankly I really don't to spend more money on a different disc to try another exploit. Can someone please help me troubleshoot?
User avatar
Posts: 682
Joined: Mon Mar 04, 2019 6:14 am
Location: France, Occitanie

Re: Exploit Under Fire won't load Swiss

Post by Papy.G » Thu Jan 16, 2020 11:57 am

The exploit usually forwards to run homebrew from the memcard that is named boot.dol before it was converted to .gci that's the first step.
boot.gci from the GCI folder in SWISS archive must load.
The preferred way to boot SWISS is from the SD Gecko on an SD card, so you have to put another forwarder onto the memcard, usually called a DoLauncher, NiHuSu added SD2SP2 to Suloku's brosexecauto, that's the one I use now.
Then, you have to put SWISS at the root of a FAT formatted (32 or 16 bits) SD card (either regular, HC or XC) renamed to autoexec.dol and you should be set up.

Exploit under fire is the one I use the most, so it just should work, you won't have to buy anything else.
DMG/MultiFreq OC/EDGB/EZF Jr, AGB/SC miniSD, NTR/NeoMK3, USG/flashme V8/SC miniSD

Zelda WW with Tingle Tuner in split screen was what the GC RF modulator was made for! (Video)
User avatar
Posts: 1101
Joined: Tue Aug 17, 2010 10:40 pm
Location: Québec, Canada

Re: Exploit Under Fire won't load Swiss

Post by Extrems » Thu Jan 16, 2020 2:06 pm

This game has 2 revisions in the NTSC-U region. Make sure you're using the correct save for your disc's revision.
Post Reply