IDE-EXI Troubles

Support forum for the IDE to EXI adapter
Post Reply
User avatar
BigRobotBil
Posts: 42
Joined: Fri Dec 17, 2010 1:28 am

IDE-EXI Troubles

Post by BigRobotBil » Mon Aug 06, 2012 1:11 am

So far, I've only gotten the thing to work once some time ago (and my gcms only appeared as corrupted). I thought it was probably just the harddrives I was using, so I waited until I got another. So, now, with the latest version of Swiss, things still aren't working.

Stats:
Make: M.N
Connection type: SATA
7200 RPM
8MB buffer
Capacity: 120GB (appears as 111GB)
Current filesystem: NTFS (FAT32 is too large without some partitioning)

(This harddrive I pulled out of an enclosure that had stopped working, but the drive still works fine.)

I'm using this to connect to an IDE cable: http://www.amazon.com/gp/product/B002Y2 ... 04_s00_i00

It works fine to connect the harddrive to the computer, and I tried it with IDE-EXI. What happens is this:
-Start up harddrive, already connected to the IDE-EXI, and the green light on the IDE-EXI is on. On the harddrive side, the SATA-IDE has two lights that are both on (red for access and green for on).
-Start up Swiss, connect IDE-EXI to Slot-B, green light on IDE-EXI may or may not turn off.
-At this point, the lights on the SATA-IDE get brighter.
-Try to read from Slot-B, and it'll either go right back to the menu, or attempt to read for awhile before quitting.

I've tried different combinations of hooking things up (having the IDE-EXI in before Swiss starts, try in Slot-A, "compatible" vs "fast," etc), but nothing has worked yet. I have taken the jumper on the SATA-IDE off, left it on, and I don't believe the jumper on the drive does anything significant in relation to Swiss reading it (it's on Spread Spectrum Clocking. However, I could be wrong if this is actually the problem, as I haven't taken it off or moved it).

Any ideas of what I could try to make this work? Or, is the harddrive/SATA-IDE I have the problem?
User avatar
emu_kidid
Site Admin
Posts: 4566
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: IDE-EXI Troubles

Post by emu_kidid » Mon Aug 06, 2012 1:30 am

NTFS isn't supported by Swiss. 120GB isn't too large for FAT32, you can have up to 2TB with FAT32 I believe. Windows of course wants you to use NTFS for such a large HDD, but there are very good applications out there that will happily format FAT32 on that drive for you.
Image
User avatar
BigRobotBil
Posts: 42
Joined: Fri Dec 17, 2010 1:28 am

Re: IDE-EXI Troubles

Post by BigRobotBil » Mon Aug 06, 2012 1:48 am

When i tried formatting under Windows using the commandline, it told me that my drive was too large. So, I'll try a different application when I get the chance.
Benni
Posts: 259
Joined: Mon Oct 17, 2011 7:45 am

Re: IDE-EXI Troubles

Post by Benni » Mon Aug 06, 2012 7:59 am

commandline?

right click on HDD select Format and then use Fat32!!!

No tools needed
only brain.exe
User avatar
SouLSLayeR
Posts: 73
Joined: Sun Apr 22, 2012 10:36 pm
Location: Greece

Re: IDE-EXI Troubles

Post by SouLSLayeR » Mon Aug 06, 2012 8:20 am

^
that's where windows screw the plan up :P
siphoned
Posts: 188
Joined: Wed Mar 31, 2010 3:50 pm

Re: IDE-EXI Troubles

Post by siphoned » Tue Aug 07, 2012 2:44 am

I used Swissknife to format my HDD for Swiss. Weird but true.
User avatar
BigRobotBil
Posts: 42
Joined: Fri Dec 17, 2010 1:28 am

Re: IDE-EXI Troubles

Post by BigRobotBil » Tue Aug 07, 2012 4:21 am

Benni wrote:commandline?

right click on HDD select Format and then use Fat32!!!

No tools needed
only brain.exe
On my copy Vista, they don't have the option in the GUI. It was suggested to use the command line by the internet, since then you don't have to download anything extra (being that I already have utilities to do this on another computer, and I was hastily doing this with the one I had at the time). I didn't expect for the formatter to spit out the error, since, well, I thought it would work without issues. Being pressed for time and me just wanting to try this drive out, I just put it as NTFS and called it a day. Now that I see it needs to be FAT32, I'll do it when I can. No need to make fun of people for simply using the command line when it simply has more features than the out-of-the-box Windows GUI ever will (I suppose the only mistake I made was expecting some in Windows to work correctly ;) ).

EDIT:
Still having issues. I formatted it to FAT32 using this (full format), and Swiss doesn't pick up anything unless I change the rate to 32Hz. When that happens, everything appears as garbage data and the drive turns corrupted when I plug it back into my computer. I made sure it wasn't fragmented before I connected it to the Gamecube.

Any ideas?
Post Reply