IPL settings (language and clock) are not getting saved. Battery already replaced

Portables, case replacements, mods etc, all in here!
Post Reply
User avatar
andzlay
Posts: 445
Joined: Thu Jul 08, 2010 12:53 am
Location: Germany

IPL settings (language and clock) are not getting saved. Battery already replaced

Post by andzlay » Sun Aug 16, 2020 10:39 am

Hi all!
I just modded an old cube (DOL-001 PAL) that I had laying around with a GC-Loader. After powering it on again, I saw that I had to set language and time again. After the second reboot I noticed, that the cube is not saving these settings. So I assumed that the clock battery is dead. I got a CR2032 holder and a fresh CR2032 and replaced the old thing. I measured with a multimeter at different solder points of the controller board (3.2V) and the soldering seems ok. But the cube is still not saving my settings and the time. So I measured the old battery, which still had 3,05V. Weird.
Any ideas where to check next? Thanks!
User avatar
emu_kidid
Site Admin
Posts: 4703
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: IPL settings (language and clock) are not getting saved. Battery already replaced

Post by emu_kidid » Mon Aug 17, 2020 12:58 am

Can you try reverting the GameCube back to stock (DVD drive) and then checking it?
Image
User avatar
Papy.G
Posts: 519
Joined: Mon Mar 04, 2019 6:14 am
Location: France, Occitanie
Contact:

Re: IPL settings (language and clock) are not getting saved. Battery already replaced

Post by Papy.G » Mon Aug 17, 2020 5:28 am

Bad connection of the Controller's board's flat cable, maybe?
DMG/MF OC, AGB/SC miniSD, NTR/NeoMK3, USG/flashme V8/SC miniSD
DOL001(EUR)/RGB/GCPlug/GBP/SD2SP2, RVL 001(EUR)/RGB/CMP/WiiSD

Zelda WW with Tingle Tuner in split screen was what the GC RF modulator was made for! (Video)
User avatar
andzlay
Posts: 445
Joined: Thu Jul 08, 2010 12:53 am
Location: Germany

Re: IPL settings (language and clock) are not getting saved. Battery already replaced

Post by andzlay » Tue Sep 01, 2020 8:33 pm

OK guys, I finally found time to check further.
I put the stock DVD drive back again -> still not working
I tried another controller-board (had it laying around) -> not working either

So either the other daugher-board I had laying around is broken, or something seems to be wrong with my mainboard. Or maybe just the connector.
Do you have any ideas on how to troubleshoot this further? Well I'm planning to open another cube with a known-working controller-board to try next.
User avatar
emu_kidid
Site Admin
Posts: 4703
Joined: Mon Mar 29, 2010 10:06 am
Location: Australia
Contact:

Re: IPL settings (language and clock) are not getting saved. Battery already replaced

Post by emu_kidid » Tue Sep 01, 2020 10:37 pm

Seems to me like you should at least verify continuity to the controller port board via points on the GameCube mainboard. I've had a GameCube with corrosion on one of the legs of the flex connector.
Image
User avatar
andzlay
Posts: 445
Joined: Thu Jul 08, 2010 12:53 am
Location: Germany

Re: IPL settings (language and clock) are not getting saved. Battery already replaced

Post by andzlay » Wed Sep 02, 2020 9:20 pm

Now that you say it... There are some weird looking points at the mainboard. Looks like quite some corrosion and maybe even some resistors broken.
I don't think I can fix that, I'm still pretty bad with soldering.
withFlash.jpg
(4.94 MiB) Not downloaded yet
User avatar
Diego borella
Posts: 141
Joined: Sat Jan 11, 2020 8:37 pm
Location: Brazil

Re: IPL settings (language and clock) are not getting saved. Battery already replaced

Post by Diego borella » Wed Sep 02, 2020 10:07 pm

the plate crystal appears to be corroded.
try to disconnect the flat, pass a smoothing pen, fold it, to see if the continuity ...
User avatar
andzlay
Posts: 445
Joined: Thu Jul 08, 2010 12:53 am
Location: Germany

Re: IPL settings (language and clock) are not getting saved. Battery already replaced

Post by andzlay » Fri Sep 04, 2020 8:50 am

Uhm. What is the "plate crystal"? And what is a "smoothing pen"? I never heard these words. I googled it, but "plate crystal" returns 100% nonsense. "Smoothing pen" returns stuff regarded to smooth 3d printed ABS. I'm confused now :D
dilav
Posts: 113
Joined: Tue Nov 29, 2011 10:54 am
Location: USA

Re: IPL settings (language and clock) are not getting saved. Battery already replaced

Post by dilav » Wed Sep 16, 2020 4:58 am

Clean the areas with isopropyl alcohol before trying to take measurements.

The battery is connected to Pin 1 of the front panel socket. Ensure you are getting battery voltage on the circle test point under R16 (might be R15?, it's left of C74).

R16 looks dodgy. It should have low resistance, a few hundred ohm at most. If it seems dodgy to you as well bridge it for now. If you cannot bridge the small R16 resistor points, run a jumper between the last pin of the IPL chip and Pin 1 of the socket.

Ensure C162 is not shorted, remove if it is.

X2 is the crystal oscillator for time keeping. It looks good, but make sure it's not bridge. Make sure C170 next to it is not shorted, remove it if it is.

Good luck.
Post Reply